Solved Problem with Exams Plugin linking to UltraPermissions

Discussion in 'Bukkit Help' started by Minecraffan1234, Apr 4, 2019.

Thread Status:
Not open for further replies.
  1. Offline

    Minecraffan1234

    Hi all,

    I wonder if one of you could help me out with a small problem.

    I am currently using a plugin called Exams however it doesn't link to the current permission plugin I am using "Ultra-Permissions" and the Exam plugin is now inactive so I can not contact the developer which is disappointing however it is an open source plugin.

    I checked a tiny bit of code in the source code and see where I believe all the other permission plugins are linked in but Ultra-Permissions is not there.

    I am wondering if someone could kindly add Ultra-Permissions into the Exams plugin so when someone passes an exam, they receive a rank out of the Ultra-Permissions permission.yml (as at the moment you don't but in plugins like PEX you do)

    Link to the piece of source code I am talking about - https://github.com/DogOnFire/Exams/blob/master/src/main/java/com/dogonfire/exams/Exams.java

    Plugin itself - https://dev.bukkit.org/projects/exams?gameCategorySlug=bukkit-plugins&projectID=42067

    Permission plugin - <Edit by Moderator: Redacted not allowed paid resource url>

    Be much appreciated if someone will be able to do this, compile it back up and send a link to me.
     
  2. Online

    timtower Moderator Moderator

    @Minecraffan1234 Ultra permissions is a paid plugin, can't do a lot with that.
    The permissions plugin should provide support for the default Bukkit permissions system instead.
     
  3. Offline

    Minecraffan1234

    Hi @timtower

    I understand it is a paid plugin which I have paid for, what you mean can't do a lot with that? I am asking someone to edit the exam plugin not the ultrapermission plugin.

    Sadly I believe it doesn't link after many attempts but I guess I could try contacting them see if they can do anything on their end but I thought it would be an exam plugin issue due to the permission node is not in the code?
     
  4. Online

    timtower Moderator Moderator

  5. Offline

    Minecraffan1234

    You make a good point but I would happily test their update out.

    Also I am not a coder but I feel starting at line 136 on - https://github.com/DogOnFire/Exams/blob/master/src/main/java/com/dogonfire/exams/Exams.java
    it shows all the permission nodes that work with exams, so would adding UltraPermissions in a layout like that, maybe solve the problem?

    Not tried it myself due to would not know the best way to do it e.g. downloading, adding it in and compiling it.
     
  6. Online

    timtower Moderator Moderator

    @Minecraffan1234 That is commented code, that isn't active. And that code only tells metrics what is being used, does nothing with permissions.
    The permissions are handled through Vault, so if UltraPermissions supports that then everything is fine.
     
  7. Offline

    Minecraffan1234

    Okay thank you, strangely it didn't work after multiple tries but I give it another shot when I can, cheers.
     
  8. Online

    timtower Moderator Moderator

    Seems that the permissions manager is only for setting groups.
    The permission checks are with the default player#haspermission, if your plugin doesn't support that then it won't work.
    But having your console log would make it easier. Please post it using https://pastebin.com
     
  9. Offline

    Minecraffan1234

    @timtower unsure what you want to see as no console logs come up when doing the exam, etc but here it is to show -
    https://pastebin.com/5FsSsZFJ

    At the beginning I created the rank called L and assigned myself it to make sure it works then removed it (giving me default rank - student) then did the exam.

    I set up both the rank and exam up right as seen below -
    L rank - https://imgur.com/a/I4LwO9N
    Exam - https://pastebin.com/Erz3k4sg

    It works perfectly fine with PEX, may test it with PEX again and show it when I get chance.
     
  10. Online

    timtower Moderator Moderator

    @Minecraffan1234 If PEX is working then you want to check the permissions plugin.
     
  11. Offline

    Minecraffan1234

    Thank you for trying to help @timtower

    I have found a way to make it work, did not recognize I can make the exam execute a command to give the user a role. Sorry for the inconvenience.
     
  12. Online

    timtower Moderator Moderator

    As long as it works ;)
    Marked as solved.
     
Thread Status:
Not open for further replies.

Share This Page