Prison Rankup For PEX

Discussion in 'Archived: Plugin Requests' started by scenecraft, Mar 11, 2014.

  1. Offline

    scenecraft

    Plugin category: Fun/Mech

    Suggested name: PrisonRankupForPEx

    What I want: I' Want a Plugin that use /rankup with pex i tried paidrank and it not working and i tried on another plugin and it no support pex it will need a vault and a essentials plugin to get a work! i like with config rank and a price

    Ideas for commands:

    /Rankup

    Ideas for permissions:
    NONE

    When I'd like it by: Wed
     
  2. Whats the error? And you can use PrisonRankUp, have you even tried all the plugins out there? You only tried PaidRanks, people just don't spend time making plugins that are already made. Put the errorlogs that PaidRanks and people may fix it here.
     
  3. Offline

    scenecraft

  4. Thats fairly, odd, let me see your errors for PrisonRankUp
     
  5. Offline

    scenecraft

  6. Offline

    NetherResident

    scenecraft Here is your error, first off you are enabling a plugin, named PrisonRankup.
    Code:
    [21:00:45] [Server thread/INFO]: [PrisonRankup] Loading PrisonRankup v1.4
    Then you are proceeding to enable it again (you possibly have the same jar in your plugins folder, twice?)
    Code:
    [21:00:58] [Server thread/INFO]: [PrisonRankup] Enabling PrisonRankup v1.4
    [21:00:58] [Server thread/ERROR]: Error occurred while enabling PrisonRankup v1.4 (Is it up to date?)
    java.lang.IllegalArgumentException: Plugin already initialized!
     
  7. Online

    timtower Moderator Moderator

    NetherResident Loading and Enabling are 2 different things, loading is only getting the jar and the dependency's, enabling is making the plugin function by calling onEnable
     
  8. Offline

    NetherResident

    timtower Hmm I didn't catch that, I thought it was trying to enable it twice.
     
  9. Offline

    mazentheamazin

    scenecraft
    It was a bug I ran with the plugin, I actually fixed it in 1.5 but its still awaiting approval *rolling eyes*. You need to use this version of CraftBukkit for that error to be resolved (Don't worry, I am pointing to dl.bukkit.org).
     
  10. Offline

    scenecraft

    i will go try
     

Share This Page