Solved Pressure plate teleport

Discussion in 'Plugin Help/Development/Requests' started by Timppali, Nov 21, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    Timppali

    Suggested name: Pressure plate Teleportation

    What I want: A plugin that allows you to link pressure plates (stone or wooden) into a warp so you can teleport using them. The player would step onto a pressure plate and be teleported either into an Essentials warp, set before or then to a warp set up by the plugin. So if it's possible to link the plugin with Essentials, I'd like to use those warps. If it isn't, there would have to be a way to set the warps for the teleports.

    I know there are plugins like KonseptGate and ButtonWarp but those are outdated. So if someone knows a plugin that does this and is in 1.7.9 and ready to be updated to 1.8 later, you can tell about it in this thread.

    Ideas for commands:
    /linkwarp <Warp name> (When looking into a pressure plate to link it to a warp)
    /makewarp <Warp name> (Creates a warp where you are standing at)
    /removewarp <Warp name>
    /unlinkwarp (When looking into a pressure plate)

    Ideas for permissions:
    - pressureplate.admin (To use the commands above)
    When I'd like it by: When you have time.
     
  2. Offline

    timtower Moderator Moderator

    Timppali Outdated doesn't mean broken till proven otherwise.
     
  3. Offline

    mrCookieSlime Retired Staff

    Timppali
    You could also just use command blocks.
    And outdated does not mean broken till proven otherwise. (EDIT: timtower ninja'd)
    Most Plugins work for all Versions.
     
    GamingNorge likes this.
  4. Offline

    Timppali

    timtower Ya I know that. If a plugin wont be updated and it will hav some problems, like ButtonWarp has, I think its better to change the plugin. And by outdated I meant buggy. KonseptGate is difficult to use, so I just wanted to reques a plugin that is easier to use without all the extra stuff KonseptGate offers. :)

    mrCookieSlime My server has command blocks disabled so I cant use those.

    And also ButtonWarp is really outdated, so its not working. And KonseptGate has economical aspects to it, as does every other plugin I have found. I wouldn't like to have economical aspects.

    EDIT by Timtower: merged double post.
     
  5. Offline

    timtower Moderator Moderator

    Timppali Most developers don't update when they don't need to.
     
  6. Offline

    Timppali

    timtower But ButtonWarp says that it's inactive and "check again in a few months". It has been over a year since the last update and the plugin doesn't work correctly, so you could say its outdated. I have proven that it doesn't work. Anyways, as I edited (I didn't want to doublepost) I don't want an economical aspect to the plugin that KonseptGate offers. :)

    Im sorry for spam.
     
  7. Offline

    mrCookieSlime Retired Staff

    Timppali
    You could of course just enable command blocks or use VariableTriggers.
     
  8. Offline

    Timppali

  9. Offline

    87pen

    Timppali likes this.
  10. Offline

    Timppali

    That plugin didnt do what I wanted. You need to right click a sign to be able to warp. Request not "filled" yet.
     
  11. Offline

    Timppali

  12. Offline

    BitBoxGaming

    @Timppali

    I can have a go at this, however I wouldn't be able to hook into Essentials, it would be a stand alone plugin

    edit: Actually, I may be able to hook into the Essentials api.
     
    Last edited: Dec 18, 2014
  13. Offline

    15987632

    @Timppali I use buttons warp and it works like a charm
     
  14. Offline

    Timppali

    @BitBoxGaming it wouldn't have to be linked with Essentials, a stand alone plugin would be fine. (Maybe even more preferred).

    And @15987632 ButtonWarp doesn't work for me in 1.8.
     
  15. Offline

    timtower Moderator Moderator

    Moved to Bukkit alternatives.
     
  16. Offline

    Timppali

    Why was my thread moved? :confused:
     
  17. Offline

    mrCookieSlime Retired Staff

    @Timppali
    Because you are requesting it to work with an Alternative (Spigot 1.8)
     
  18. Offline

    Timppali

  19. Offline

    Xxstick

    why not just using a command block?
     
  20. Offline

    Timppali

    @Xxstick I dont want the commad line to be visible. The "Teleporting to location x y z"
     
  21. Offline

    Xxstick

    @Timppali

    I tested with command blocks, and you can use more than the Default vanilla commands in the command block, you can use commands from plugins too
     
  22. Offline

    mrCookieSlime Retired Staff

    There is also a gamrule which disables this.
    /gamerule doCommandBlockOutput false
    I think.
     
    Last edited: Dec 23, 2014
  23. Offline

    nverdier

    Wait I think he wants command blocks..
     
  24. Offline

    mrCookieSlime Retired Staff

    Sorry, what?
    That comment was referring to command blocks...
     
  25. Offline

    nverdier

    It was saying how to disable them. I don't think he needs that?
     
  26. Offline

    mrCookieSlime Retired Staff

    @nverdier

    He is requesting this Plugin just because he wants to disable them...

    Yea, I think I should have quoted that post instead of tagging him.
     
  27. Offline

    nverdier

    @mrCookieSlime This fixes that..
     
  28. Offline

    mrCookieSlime Retired Staff

    Yes, but it is always helpful to know multiple solutions for a problem. And this way he doesn't have to install any Plugins.
     
    nverdier likes this.
  29. Offline

    nverdier

    :D
     
  30. Offline

    Timppali

    @nverdier @mrCookieSlime Ya but I need Multiverse support. You cant use command blocks to teleport to another worlds, can you?​
     
Thread Status:
Not open for further replies.

Share This Page