PreciousStones - Back under the development of phaed

Discussion in 'Inactive/Unsupported Plugins' started by aPunch, Apr 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Ryannober, Avous and kahlilnc like this.
  2. Offline


    Look in your database how many unbreakables do you really have?

    Redownload 4.0.2 from my link. It fixes the output errors.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  3. Offline


  4. Offline


  5. Offline


    @phaed the jack-o-death force field doesnt work
  6. Offline




    Same 1,000,000 thing again :(

    FYI: Tried first 4.0pre and it shows: imported 3,904,951 unbreakables AND works OK (i.e: shows protected blocks in-game). Updated .JAR to 4.0.2, and again shows 1,000,000 on run, and none of the blocks are protected


    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  7. Offline

  8. Offline


    Could you make another thread where people can share their own PreciousStones?
    this looks like an epic plugin. a diamond for you, sir.
  9. We can't figure out how to make it so any force-field is enabled by default for anyone else. Is there any way to turn the whitelist into a blacklist, or some flag or node to grant? I guess a permission node would be ideal, it works for admins, but I don't want to give everyone the isAdmin node, as that might break other stuff :p
  10. Offline


    I am completely ignorant about setting up and running mysql in mac osx for minecraft.
    Any help would be greatly appreciated.
  11. Offline


    Will try now. BTW: Your download link still points to 4.0.2


    imported 4,017,088 unbreakables
    On first run shows: 1,000,000 unbreakables (none protected in-game)

    any update on this ?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  12. Offline


    Big problem on our server with world guard. We built a big spawn area and world guarded it like most servers do so nobody can destroy or build anything.
    Well.... some players started placing lapis blocks which we use for entry bouncing and though world guard will prevent them from being placed, the field will stay there. So we ended up with forcefields everywhere but no blocks. People couldn't get through the area at all. Had to disable and remove the precious stones plugin.
    Is it a bug, or is there somewhere a setting or something I missed.
  13. Offline


    This is with 4.x?

    For now import your old stones with 4.0pre, then switch over to 4.0.3. I'll fix this issue when I can.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  14. Offline


    Yes this is with 4.0.2
  15. Offline



    Already tried. Doesn't work. Still shows 1,000,000 unbreakables (none protected in-game)

    Here's my GIANT unbreakables.txt

    Hope it helps


    btw: I can give you a copy of my World too if you want.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  16. Offline



    Since 4.0.2, when I start the server there is about 10 seconds of freeze on PS loading
    2011-05-09 10:47:43 [INFO] [PreciousStones] version [4.0.1] loaded
    2011-05-09 10:47:43 [INFO] [PreciousStones] < imported 0 unbreakables
     2011-05-09 10:47:57 [INFO] [PreciousStones] < imported 0 fields
    2011-05-09 10:47:57 [INFO] [PreciousStones] world fields: 165
    2011-05-09 10:47:57 [INFO] [PreciousStones] world unbreakables: 0
    2011-05-09 10:47:57 [INFO] [PreciousStones] nether fields: 2
    2011-05-09 10:47:57 [INFO] [PreciousStones] nether unbreakables: 0
  17. Offline


    This is normal. PS is loading your database into RAM. You have only to pray to your DB not get too big (like mine) cuz then PS will SIMPLE stop working and all your blocks WILL STAY unprotected.

  18. 1) 12:56:57 [SEVERE] Nag author: '<NoAuthorGiven>' of 'PreciousStones' about the following: onVehicleUpdate has been replaced with a new signature, (VehicleUpdateEvent)

    2) Would love some flag to put Pstone in blacklist mode, pretty please!
  19. Offline


    Ok, none of my old blocks are protecting.
    New works, but the old.
  20. Offline


    welcome aboard :D
  21. Offline


    So anybody having same problem with fields staying in place after world guard denies placing block??? Any fix for that??
  22. Offline


    2011-05-09 22:40:07 [WARNING] Task of 'PreciousStones' generated an exception
    java.lang.ClassCastException: org.bukkit.craftbukkit.entity.CraftTNTPrimed cannot be cast to org.bukkit.entity.LightningStrike
    at net.minecraft.server.WorldServer.a(
    at net.sacredlabyrinth.Phaed.PreciousStones.managers.MineManager$ Source)
    at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
    at net.minecraft.server.MinecraftServer.h(

    happens if a proximity mine tries to detonate, and my server actually restarts :confused:

    also the first topic says that forcefield blocks will only work while you're offline, but they work while i'm online too, how do I set them to only work when the player is offline?
  23. Offline


    I CANT FIGURE THIS OUT IN HELL.... Please help me lol i put mysql in my lib folder and ran prescious stones it loaded but when i type /ps help i get
    /ps help -Displays precious stones commands??

    please help thanks
  24. Offline

    IOn Vash

    well after 6 hours of converting its still not done. Had I known it would take this long I would have had it converting the file on a private server so people could still play.

    Around hour 7 it finished loading but when i got in nothing was protected... I'm restarting now to see if it will work.

    the 40 minute server startup time is a bit annoying. flatfile was at least 500 times faster

    Ok I figured out how to make that faster, I set the max IO threads to 50, Optimized the DB and then defragged the MySQL DB folder. brought it down to about 10 minutes
  25. Offline


    It seems that if i change the config file to put some more cloakable blocks and change the block types of some of them the plugin stop working. I have no message from it in the console... i do need help.
    I might have screwed with mysql since i have no idea of how does it works.
    i seriously need help
  26. Offline


    For all those without any support from the author(s).

    People at OwnBlocks are working on a Converting from PS tool.

    I Can't wait, I'm sick of PS
  27. Offline


    That is all fine and good but OwnBlocks just tracks block placement and renders protection based on that
    PreciousStones generates fields that protect, heal, prevent explosions etc

    Apples and Oranges mate
  28. Offline


    Most ppl use PS only for block protection. The problem we're all having right now is with the protection of blocks.

    BTW: You can still stick with PS for fields.
  29. Offline


    To be honest with you I already migrated manually to a zone based plugin that has all the functions from PS that I need
    If I can get the financial side sorted I'll likely be moving to VPS and going back to precious stones
    It took me maybe an hour to establish all of the fields I needed, took a little math and a lot of copy and paste
  30. Offline


    ok doky. problem with fields staying after denying placing blocks was not worldguard issue but default spawn protection issue. Once removing spawn protection and just using world guard solved the problem
  31. Offline


    whats wrong with PS? the new database driven version works awesome, had some small issues with CaPiTaL letters but nothing really bad.
Thread Status:
Not open for further replies.

Share This Page