PreciousStones - Back under the development of phaed

Discussion in 'Inactive/Unsupported Plugins' started by aPunch, Apr 20, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Ryannober, Avous and kahlilnc like this.
  2. Offline


    If you're updating to 4.2, and fail at running the sql query

    alter table ps_fields change velocity float
    change it to

    alter table ps_fields modify velocity float;
    as 'change' wasnt the correct syntax.

  3. Offline


    oooo thanks

    SQLite support should start working as soon as bug# 365 is fixed, and bukkit upgrades to the new version, from the trend it looks like they release every 4-5 months or so:

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  4. Offline

    Bill Warner

    started the upgrade to 4.x starting with latest 4.2. I've got the database created and I see the plugin generated the tables needed, but I'm getting the follow:

    20:40:20 [INFO] [PreciousStones] version 4.2 loaded
    20:40:20 [INFO] [PreciousStones] world fields: 0
    20:40:20 [INFO] [PreciousStones] world unbreakables: 0
    20:40:20 [INFO] [PreciousStones] nether fields: 0
    20:40:20 [INFO] [PreciousStones] nether unbreakables: 0
    20:40:20 [INFO] [PreciousStones] wilderness fields: 0
    20:40:20 [INFO] [PreciousStones] wilderness unbreakables: 0
    20:40:20 [SEVERE] null loading PreciousStones v4.2 (Is it up to date?)
            at net.sacredlabyrinth.Phaed.PreciousStones.managers.TagManager.tagWorld(
            at net.sacredlabyrinth.Phaed.PreciousStones.managers.TagManager.checkTaggedWorlds(
            at net.sacredlabyrinth.Phaed.PreciousStones.managers.TagManager.<init>(
            at net.sacredlabyrinth.Phaed.PreciousStones.PreciousStones.onEnable(
            at org.bukkit.plugin.SimplePluginManager.enablePlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugin(
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at org.bukkit.craftbukkit.CraftServer.reload(
            at org.bukkit.command.SimpleCommandMap$ReloadCommand.execute(
            at org.bukkit.command.SimpleCommandMap.dispatch(
            at org.bukkit.craftbukkit.CraftServer.dispatchCommand(
            at net.minecraft.server.MinecraftServer.b(
            at net.minecraft.server.MinecraftServer.h(
    Also is there a way to import the old fields? from 3.x versions?
  5. Offline


    Same here
  6. Offline


  7. Offline

    Bill Warner

    You are awesome!!

    What about importing 3.x txt files into the db? is that possible?
  8. Offline


  9. Offline

    Bill Warner

    Hmm, both not able to read I guess and the import isn't working.

    doing some playing now hope I can get it working, have well over 1500 pstones i really don't want to have to replace.

    ok, brought a backup into place and ran it.

    23:38:22 [SEVERE] Caused by: java.sql.SQLException: Field 'id' doesn't have a default value
    happens on every attempt to import.

    should this be set as an index field in the db?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 13, 2016
  10. Offline


    Try this:
  11. Offline

    Bill Warner

    is that different than the 4.2.1 above? neither one worked.

    2011-05-16 00:48:15 [INFO] Starting minecraft server version Beta 1.5_02
    2011-05-16 00:48:15 [INFO] Loading properties
    2011-05-16 00:48:15 [INFO] Starting Minecraft server on *:25565
    2011-05-16 00:48:15 [INFO] This server is running Craftbukkit version git-Bukkit
    -0.0.0-729-g5ee3f0f-b766jnks (MC: 1.5_02)
    2011-05-16 00:48:52 [INFO] [PreciousStones] version 4.2.1 loaded
    2011-05-16 00:48:53 [SEVERE] javax.persistence.PersistenceException: ERROR executing DML bindLog[] error[Field 'id' doesn't have a default value]
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.persist.dml.DmlBeanPersister.execute(
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.persist.dml.DmlBeanPersister.insert(
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.persist.DefaultPersistExecute.executeInsertBean(
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.core.PersistRequestBean.executeNow(
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.core.PersistRequestBean.executeOrQueue(
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.persist.DefaultPersister.insert(
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.persist.DefaultPersister.saveVanillaInsert(
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.persist.DefaultPersister.saveVanillaRecurse(
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.persist.DefaultPersister.saveRecurse(
    2011-05-16 00:48:53 [SEVERE]    at
    2011-05-16 00:48:53 [SEVERE]    at
    2011-05-16 00:48:53 [SEVERE]    at
    2011-05-16 00:48:53 [SEVERE]    at net.sacredlabyrinth.Phaed.PreciousStones.managers.ForceFieldManager.saveField(
    2011-05-16 00:48:53 [SEVERE]    at net.sacredlabyrinth.Phaed.PreciousStones.managers.StorageManager.loadFields(
    2011-05-16 00:48:53 [SEVERE]    at net.sacredlabyrinth.Phaed.PreciousStones.managers.StorageManager.<init>(
    2011-05-16 00:48:53 [SEVERE]    at net.sacredlabyrinth.Phaed.PreciousStones.PreciousStones.onEnable(
    2011-05-16 00:48:53 [SEVERE]    at
    2011-05-16 00:48:53 [SEVERE]    at
    2011-05-16 00:48:53 [SEVERE]    at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    2011-05-16 00:48:53 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    2011-05-16 00:48:53 [SEVERE]    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    2011-05-16 00:48:53 [SEVERE]    at net.minecraft.server.MinecraftServer.e(
    2011-05-16 00:48:53 [SEVERE]    at net.minecraft.server.MinecraftServer.a(
    2011-05-16 00:48:53 [SEVERE]    at net.minecraft.server.MinecraftServer.init(
    2011-05-16 00:48:53 [SEVERE]    at
    2011-05-16 00:48:53 [SEVERE]    at
    2011-05-16 00:48:53 [SEVERE] Caused by: java.sql.SQLException: Field 'id' doesn't have a default value
    2011-05-16 00:48:53 [SEVERE]    at com.mysql.jdbc.SQLError.createSQLException(
    2011-05-16 00:48:53 [SEVERE]    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    2011-05-16 00:48:53 [SEVERE]    at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    2011-05-16 00:48:53 [SEVERE]    at com.mysql.jdbc.MysqlIO.sendCommand(
    2011-05-16 00:48:53 [SEVERE]    at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    2011-05-16 00:48:53 [SEVERE]    at com.mysql.jdbc.ConnectionImpl.execSQL(
    2011-05-16 00:48:53 [SEVERE]    at com.mysql.jdbc.PreparedStatement.executeInternal(
    2011-05-16 00:48:53 [SEVERE]    at com.mysql.jdbc.PreparedStatement.executeUpdate(
    2011-05-16 00:48:53 [SEVERE]    at com.mysql.jdbc.PreparedStatement.executeUpdate(
    2011-05-16 00:48:53 [SEVERE]    at com.mysql.jdbc.PreparedStatement.executeUpdate(
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.lib.sql.ExtendedPreparedStatement.executeUpdate(
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.type.DataBind.executeUpdate(
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.persist.dml.InsertHandler.execute(
    2011-05-16 00:48:53 [SEVERE]    at com.avaje.ebeaninternal.server.persist.dml.DmlBeanPersister.execute(
    2011-05-16 00:48:53 [SEVERE]    ... 25 more
    repeated over and over.
  12. Offline


  13. Offline

    Bill Warner

    That did it!! Can I say you rock?

    ...and need a tip jar.
  14. Offline


    Phew, almost had a 3x hearth attack. forgot to update the database first.. had to reboot bukkit reload didnt cut it. ^^
    4.2.1 seem to work well so far.
  15. Offline


    Ok, so I finally got around to trying out your plugin, but I cannot seem to get your landmines or shocker blocks to work.

    I set them down, check that the field exists on top of them, but my friend who is helping me test my server to get it ready to open never triggers it, and vice versa when we walk on them. The other ones I have tried so far work fine, (sky cannon, air, etc).

    I am sure I am overlooking something trivial, but think you could shed some light as to what?
  16. Offline


    The people who place them, those allowed into the fields, or have admin bypass permissions, do not trigger mines or shockers.
  17. Offline


    Yes yes, thank you, I actually found out in a fairly exciting show right before I read your post when a non admin logged into the server and died. Thanks for the response though, appreciate it.
  18. Offline


    Is there step-by-step guide on how to install this plugin?
    How and where do I enter the required items to my "groups" ?
    How do I create a MySql database on the host server?

    I am using Provision Host to host my minecraft server... are any of you familiar with their servers? And if so, am I able to use this plugin on their servers?

    There is a bukkit.yml file already in place, but it's contents already have this:

    update-folder: update
    username: *****
    isolation: SERIALIZABLE
    driver: org.sqlite.JDBC
    password: *****
    url: jdbc:sqlite:{DIR}{NAME}.db

    I assume that if I change this to match this plugin's bukkit.yml... I'm going to run in to probelms... right?

    Ok... I know you're slapping your foreheads and saying "this dude is in over his head!"
    Well... yes I am! :)
    I'm doing this for fun and to learn something new!

    Any help and/or thoughts will be greatly appreciated.


  19. Offline


    A quick google told me that your host supports MySQL.

    Your bukkit.yml says yu are currently using sqlite (an inferior database than MySQL), so you may have a plugin using a sqlite for database. Figure out which plugin it is, cause once you switch to MySQL that plugins data will be reset. If you are ok with that plugin resetting its data, then reach out to your host and tell them you want to switch your bukit.yml to MySQL and you need them to fill out the url and credentials. Once they do this you can just drop in PreciousStones and it will work.
  20. Offline


    Thanks for the reply phaed,

    Yep, I did ask them to install this PreciousStones for me... after reading your post I saw that they had not put bukkit.yml into the PreciousStones folder... so I moved there myself.

    I think it is loaded now because in the log window I can see where it says: "Installing database for PreciousStones due to first time usage"

    Now when I type in any commands I get this: "/ps help - Displays PreciousStones commands" which I assume is another good sign. Since I do get this message with every command I enter does this mean that I need to insert the following into my groups?
    .benefit.* #can create precious stones (members) preciousstones.whitelist.* #can add others to their blocks (members) preciousstones.special.* #can use special features(veterans) preciousstones.bypass.* #can bypass all protection (mods) preciousstones.alert.* #in-game alert on notifys and warnings (mods) preciousstones.admin.* #admin tools (admins) preciousstones.override.* #these players will receive no warnings or notifications preciousstones.blacklist #these players will be backlisted, this overrides all other permissions

    What about this list? Where does it go?
    I'm using McMyAdmin... it looks like I need to install a Group Manager or Permissions plugin as well? I do have ops.txt as well.
    preciousstones.bypass.snitch #wont show up on any snitch lists preciousstones.bypass.mine #proximity mine preciousstones.bypass.lightning #proximity lightning fields #alert for block placement notifys preciousstones.alert.notify.destroy #alert for block destroy notifys preciousstones.alert.notify.bypass-place #alert for block bypass-place notifys preciousstones.alert.notify.bypass-destroy#alert for block bypass-destroy notifys preciousstones.alert.warn.entry #alert for entry warnings #alert for fire warnings preciousstones.alert.warn.pvp #alert for pvp warnings #alert for place warnings preciousstones.alert.warn.destroy #alert for destroy warnings preciousstones.alert.warn.noplace #alert for noplace warnings preciousstones.alert.warn.destroyarea #alert for destroy area warnings preciousstones.alert.warn.conflict #alert for conflict placement warnings preciousstones.alert.warn.unprotectable #alert for unprotectable related warnings preciousstones.admin.delete #use /ps delete #use /ps info preciousstones.admin.list #use /ps list preciousstones.admin.reload #use /ps reload #use /ps save preciousstones.admin.setowner #use /ps setowner preciousstones.admin.fields #use /ps fields preciousstones.admin.clean #use /ps clean preciousstones.admin.details #view all details with right-click preciousstones.admin.bypass.log #user does not show up in logs preciousstones.admin.isadmin #used internally to detect admins preciousstones.admin.viewconflicting #tells you locations of conflicting pstones when placing new field preciousstones.override.notify #users will not be shown any notifications preciousstones.override.warn #users will not be shown any warnings

    Thanks again

    EDIT: Ok, so I'm looking over the Permissions 2.7.3 (Phoenix) video and web page... I'm kinda getting the idea now... but still could use some guidance. Thanks again!
  21. Offline


    bukkit.yml goes in the same folder that has craftbukkit....jar not in the PreciousStones folder. I mentioned this in the Persistence instructions on the OP.

    If you're getting "/ps help - Displays PreciousStones commands" for every command you type then something is wrong.

    I can't teach you how to set up permissions plugin, that is far outside the scope that i'm willing to help in, you're gonna have to do that on your own.
  22. Offline


    I keep getting the following errors every few moments while my server is running -- Most of the time it seems harmless, but one time I logged onto my server and my preciousstones blocks were not functioning, perhaps the problem is shouting at me in the console:

    The last packet  successfully received from the server was 60,002 milliseconds ago.  The  last packet sent successfully to the server was 0 milliseconds ago.
    	at sun.reflect.GeneratedConstructorAccessor44.newInstance(Unknown Source)
    	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(
    	at java.lang.reflect.Constructor.newInstance(
    	at com.mysql.jdbc.Util.handleNewInstance(
    	at com.mysql.jdbc.SQLError.createCommunicationsException(
    	at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(
    	at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(
    	at com.mysql.jdbc.MysqlIO.checkErrorPacket(
    	at com.mysql.jdbc.MysqlIO.sendCommand(
    	at com.mysql.jdbc.MysqlIO.sqlQueryDirect(
    	at com.mysql.jdbc.ConnectionImpl.execSQL(
    	at com.mysql.jdbc.ConnectionImpl.execSQL(
    	at com.mysql.jdbc.StatementImpl.executeQuery(
    	at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.testConnection(
    	at com.avaje.ebeaninternal.server.lib.sql.DataSourcePool.checkDataSource(
    	at com.avaje.ebeaninternal.server.lib.sql.DataSourceManager.checkDataSource(
    	at com.avaje.ebeaninternal.server.lib.sql.DataSourceManager.access$100(
    	at com.avaje.ebeaninternal.server.lib.sql.DataSourceManager$
    	at com.avaje.ebeaninternal.server.lib.BackgroundThread$Runner.runJobs(
    	at com.avaje.ebeaninternal.server.lib.BackgroundThread$
    Caused  by: Can not read response from server. Expected  to read 4 bytes, read 0 bytes before connection was unexpectedly lost.
    	at com.mysql.jdbc.MysqlIO.readFully(
    	at com.mysql.jdbc.MysqlIO.reuseAndReadPacket(
    	... 15 more
    2011-05-16  23:39:24 [INFO] Reseting DataSourcePool [PreciousStones] min:2 max:20  free:1 busy:1 waiting:0 highWaterMark:3 waitCount:0 hitCount:3141
    2011-05-16  23:39:24 [INFO] PSTMT Statistics: name[PreciousStones.332]  startTime[1305607134133] pstmtHits[0] pstmtMiss[0] PreciousStones.332  size:0 max:20 totalHits:0 hitRatio:0 removes:0
    2011-05-16 23:39:24 [INFO] Closing Connection[PreciousStones.332] psReuse[0] psCreate[0] psSize[0]
    2011-05-16 23:39:24 [INFO] Busy Connections:
    name[PreciousStones.333] startTime[1305607164136] stmt[null] createdBy[null]
    2011-05-16 23:39:24 [INFO] Closing Connection[PreciousStones.333] psReuse[0] psCreate[0] psSize[0]
    2011-05-16 23:39:24 [SEVERE] Closing Connection[PreciousStones.333] that is already closed?
     2011-05-16 23:39:34 [SEVERE] RESOLVED FATAL: DataSourcePool [PreciousStones] is back up!
    2011-05-16  23:39:34 [INFO] Reseting DataSourcePool [PreciousStones] min:2 max:20  free:0 busy:0 waiting:0 highWaterMark:3 waitCount:0 hitCount:3142
    2011-05-16 23:39:34 [INFO] Busy Connections:
    2011-05-16 23:39:34 [INFO] DataSourcePool [PreciousStones] grow; id[PreciousStones.334] busy[1] max[20]
    2011-05-16 23:39:34 [INFO] Closing Connection[PreciousStones.334] psReuse[0] psCreate[0] psSize[0]
      2011-05-16 23:39:54 [INFO] DataSourcePool [PreciousStones] grow; id[PreciousStones.335] busy[1] max[20]
    Any clue what would be causing this?
  23. Offline


    Never seen this before, but from the looks of it the connection to the MySQL server is timing out. Contact your host.
  24. Offline



    I've given users the bounce and launch nodes but they still cant use the sky cannon or launch pad. Ive also tried adding users to a field manually and still nothing. Perhaps im overlooking something, or not understanding what these nodes do.

    PS 4.2.1 CB 766
  25. Offline


    Any one help?
  26. Offline


    Contact BroHoster and see if you do actually have a MySQL database, if you do then ask them for the access details and overwrite those in the bukkit.yml, I was with brohoster until just recently (moved to VPS) and I was never told about having a MySQL database available to me
  27. Offline


        isolation: SERIALIZABLE
        driver: com.mysql.jdbc.Driver
        password: *delete*
        url: jdbc:mysql://mysqlhost/TC64615875372210512388343
  28. Offline


    Sigh...... i wish this used SQL or something thats not MySql, to complicated and errors for me... i missed precious stones being without MySql... at least its a good plugin...
  29. Offline


    MMm doesnt seem to be working, is there a way I can get the older version of PS now?
  30. Offline


    You give up pretty easily... Paste your bukkit.yml through here, you probably have some formatting errors: If there is none then contact your host to get you set up.

    We no longer support the old versions. You're going to have to find them elsewhere.
  31. Offline

    IOn Vash

    say is it just me or does it no longer check for orphans on startup?
Thread Status:
Not open for further replies.

Share This Page