Problem/Bug Post all bugs/issues with forum update here

Discussion in 'Forum Feedback' started by ZeldoKavira, Dec 9, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    ZeldoKavira Administrator Curse

    Thanks for being patient with us while we updated the forums. Please post any issues you find here. While doing this please be as descriptive as possible, in order to help with this I have provided a small form here that should help with this. Please read the posts so that you do not repost the same bug unless you have information that will greatly help with solving the issue, we want to keep this thread as clean as possible so that we can quickly assist users.

    Bug/Issue Description:
    Page where issue is seen:
    Screenshot (Not required, but very helpful):

    Note:
    The BukkitDev linker being partially missing is KNOWN. Do not report this.


    Thanks,
    Zeldo
     
  2. Bug/Issue Description: XenStaff 404s.
    Page where issue is seen: /XenStaff/

    Bug/Issue Description: Search causes server error. Perform any search and observe "A server error occurred. Please try again later."
    Page where issue is seen: http://forums.bukkit.org/search/search

    Bug/Issue Description: All post edit information/history has been seemingly lost.
    Page where issue is seen: Any post which was edited before the forum upgrade now displays no such information.

    EDIT by Timtower: merged posts

    Bug/Issue Description: Nav tabs:hover unreadable.
    Page where issue is seen: Every forums page.

    [​IMG]

    My complaint is primarily about the bottom nav tabs but I'd prefer the text-shadow to be removed from the top tabs too and the color set to #fff for contrast.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Jun 29, 2016
    MisterErwin and timtower like this.
  3. @lol768 ninja'd ;)

    Bug/Issue Description: Syntax highlight for Java is missing
    Page where issue is seen: Try to insert a code snippet and Java syntax highlighting is missing (may simply be due to a plugin not being installed. Not sure though)

    http://screencloud.net/v/dV2Q
     
    pookeythekid likes this.
  4. Bug/Issue Description: GIFs don't seem to be working. I don't know if this is just me though.
     
  5. Offline

    timtower Ninja on the waves Moderator

    Example of that?
     
  6. @timtower
    In user signatures. It was working fine earlier, now it seems to be a frozen image.
     
  7. I have a feeling you classify these as the same thing but the Minecraft association is missing in addition to the BukkitDev association.
     
  8. Offline

    mbaxter ʇıʞʞnq ɐ sɐɥ ı Retired Staff

    The URL "forums.bukkit.org" no longer displays the forums.

    Previous behavior was that "bukkit.org" showed the portal and "forums.bukkit.org" showed the forums. Now I have to visit forums.bukkit.org/forums which is a bit redundant.

    Edit: I guess breaking hearts by force redirecting away from the forums subdomain is a solution. Not the nicest looking solution, but certainly a solution...
    Still doesn't fix the fact that visiting forums.bukkit.org no longer results in the forums index...
     
    Last edited: Dec 9, 2014
  9. Bug/Issue description: XenPorta dates & titles aren't properly aligned:

    [​IMG]
    Visible on portal page.

    One of the following BBCodes also used to work, I don't recall which:

    EDIT: While this BBCode works, the "X-Frame-Options: ALLOW-FROM HTTP://FORUMS.BUKKIT.ORG" is going to stop it from embedding properly because the forums are served from the wrong subdomain now

    http://dev.bukkit.org/bukkit-plugins/worldedit/
    http://dev.bukkit.org/bukkit-plugins/worldedit/
     
    Last edited: Dec 10, 2014
  10. Offline

    ZeldoKavira Administrator Curse

    The point here from the start was to redirect forums.bukkit.org to bukkit.org. The fact that it does not redirect to the /forums/ is the bug here and is being worked on

    1) Fixed

    2) This is because the old data was held by a custom plugin. We voted to not used this custom plugin anylonger as this functionality is built into the forums.

    This is a plugin bug. We are not going to alter plugin templates for something small like this.
     
  11. Offline

    timtower Ninja on the waves Moderator

    Not having that issue.
     
  12. Posts on the home page always appear to have 0 likes, regardless of the amount of likes the actual thread obtains.
     
  13. Thanks.

    I presume you meant to refer to #3 here (rather than the search issue). In any case, you seemingly chose not to transfer across the past edit information to the system provided by XenForo. Did the past system not store enough information for such a transition to be possible?

    There's no need to change the add-on's templates. Adding something like the below to the site's extra.css template would fix the issue:

    Code:
    .EWRporta_Portal .recentNews .subHeading h2 {
        font-size: 1em;
    }
     
  14. Offline

    ZeldoKavira Administrator Curse


    Yes sorry I ment #3, however #2 has been fixed as well. The information from the edits was not created by Xenforo and the data did not transfer across, there was too much data saved before. Yes, you can add that to the extra.css however if the plugin updates you can end up with conflicts.


    This has been fixed now.


    This has been fixed
     
    Last edited: Dec 9, 2014
  15. Template conflicts? No. Styling conflicts? Perhaps - but the addon is unmaintained which looks to me as a pretty good sign it's not going to be updated any time soon in the future.
     
  16. Bug/Issue: Robot count displayed in online member count
    Page where issue is seen: Main forum page where online members are displayed

    http://screencloud.net/v/2dN5

    Not the biggest issue in the world, but the robot count didn't used to show and it's kinda irrelevant in my opinion.
     
  17. Offline

    ZeldoKavira Administrator Curse

    This is an issue with the update. Once a post receives a new like now that we have updated it will update this value to the proper one.

    This is a feature of the update, not a bug
     
    ChipDev likes this.
  18. @ZeldoKavira
    I know it's not a bug ;) Just more of a suggestion.
     
  19. Offline

    ZeldoKavira Administrator Curse

    I've added this one. We are trying to shy away from as many manual edits as possible, however I will agree that this one appears that it is not going to update for awhile.

    These should both be fixed now.

    http://dev.bukkit.org/bukkit-plugins/worldedit/
     
    Last edited by a moderator: Dec 9, 2014
    TGRHavoc and lol768 like this.
  20. Bug: I ordered a pizza over an hour ago and it still hasn't been delivered. lol jk.

    I haven't had a chance to look at the rest of the code tags, but the java code tag isn't working. I would post a screenshot but its a little annoying to do so on my phone. Other than that, loving the new changes.
     
    pookeythekid likes this.
  21. @teej107 sorry about your pizza, Cookie sneezed on it and Tim stood on it so I have to remake it.

    As for the tag, I will quickly check and if it doesn'tdoesn't work I will report to Zeldo.
     
    pookeythekid, teej107 and timtower like this.
  22. Offline

    ZeldoKavira Administrator Curse

    Code:
        public void onEnable() {
            this.getServer().getPluginManager().registerEvents((Listener)this, (Plugin)this);
            this.getConfig().options().copyDefaults(true);
            this.saveDefaultConfig();
        }
    Appears to be working to me
     
  23. Offline

    timtower Ninja on the waves Moderator

    Code:java
    1. public void onEnable() {
    2. this.getServer().getPluginManager().registerEvents((Listener)this, (Plugin)this);
    3. this.getConfig().options().copyDefaults(true);
    4. this.saveDefaultConfig();
    5. }

    @ZeldoKavira This one is not though.
     
  24. It seems that "syntax" has been replaced with "code".
     
  25. Offline

    ZeldoKavira Administrator Curse

    Will look into this.
     
    timtower likes this.
  26. Spoilers are messed up.
    Show Spoiler

    this is a spoiler just in []'s with spoiler inside of it. then a [/] spoiler!
     
  27. @ChipDev Zeldo is already aware and is fixing it.
     
    ChipDev likes this.
  28. Good.
    *Yay, I noticed something real!
     
  29. Offline

    ZeldoKavira Administrator Curse

    Both fixed indev and will be going live here shortly
     
Thread Status:
Not open for further replies.

Share This Page