Plugins Won't Work

Discussion in 'Bukkit Help' started by Deitnerb, Sep 25, 2015.

Thread Status:
Not open for further replies.
  1. Offline

    Deitnerb

    I'm using Bukkit with a 1.8 Minecraft server and plugins won't work. The server works perfectly but the plugins won't. I'm trying to use Worldedit and Essentials. Can anyone help?

    [​IMG]
     
  2. Offline

    timtower Administrator Administrator Moderator

  3. Offline

    Binner_Done

    When you say 'Wont Work' can you explain that more?
     
  4. Offline

    Deitnerb

    @timtower I think this is what your asking for http://pastebin.com/0xMRzMrX
    XD I just noticed in that log I banned myself a few times lol

    And @Binner_Done by 'Wont Work' I mean just that I've watched a few Youtube vids on how to do this I've followed all the instructions and everything seems to work fine but when I get on the server it's still vanilla Minecraft.
     
  5. Offline

    timtower Administrator Administrator Moderator

    @Deitnerb You sure that you are starting the Bukkit server?
     
  6. Offline

    Deitnerb

    @timtower I'm doing what I saw on Youtube vids, I'm a noob to this.
     
  7. Offline

    Binner_Done

    Yeah, to me that log doesnt look like the bukkit I know!

    @Deitnerb Have you installed spigot 1.8.8?
     
  8. Offline

    Deitnerb

  9. Offline

    Triology12

    Be sure to have the most recent version of Essentials/WorldEdit installed, Otherwise it might be causing errors.
     
  10. Offline

    timtower Administrator Administrator Moderator

    @Deitnerb Could you post your run.bat?
    @Triology12 Server isn't showing any plugins loading though.
     
  11. Offline

    Triology12

    Didnt read it properlly, But now i see.

    @Deitnerb Took a closer look to it, It seems WorldEdit Nor the Essentials is in the plugins folder.

    EDIT by Timtower: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Sep 26, 2015
  12. Offline

    Binner_Done

    Yeah, you have to put essentials and world edit inside the plugin folder for them to work :p

    @Triology12 I saw it just as you did XD
     
  13. Offline

    Deitnerb

    I had them in the plugins folder but I decided to see if keeping them in the server folder would make a difference.
     
  14. Offline

    oceantheskatr

  15. Offline

    Deitnerb

    @oceantheskatr Still doesn't work. Is there some kind of Bukkit log I could use to troubleshoot this? Or is there a way I can give someone access to the server panel to see whats going on? And I also tried Spigot (which correct me if I'm wrong I think is a type of Bukkit). But it still won't work -.-

    EDIT: I've also tried it with another plugin but still nothing. So it has to be Spigot/CraftBukkit
     
    Last edited: Sep 27, 2015
  16. Offline

    Boomer

    The vanilla-looking "Minecraft server 1.8.8" executable there also looks like thats what is being launched, not the craftbukkit, which would be totally blind to any plugins...
     
  17. Offline

    Deitnerb

    Can somebody give me a walkthrough of how to install Spigot? I've watched over 10 Youtube videos and this is just really hard I can't figure it out. I have a 32 bit Windows 7 operating and I'm using the easy Minecraft server version.
     
  18. @Deitnerb
    1. Why do you have a mc server? That will ignore the plugins
    2. Post your run.bat
    3. WorldEdit should go in the plugins folder.
     
  19. Offline

    oceantheskatr

    @Deitnerb Here's a video I made a few months ago on how to set up a Spigot/Craftbukkit server on 1.8+. I've been told by many people that it helped them, so hopefully it'll help you too!
     
  20. Offline

    Deitnerb

    @oceantheskatr Thank you so much!! It finally worked. Now the only problem is I can't get the console to open up so I can op myself...

    So thanks for all your help everyone I think everything is working fine now. :)
    I'll just post to this again if I have any more problems.

    EDIT by Timtower: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Sep 27, 2015
  21. Offline

    Boomer

    the console will remain open if you made your BAT file correctly, otherwise, if you see a flash and then the black console screeen flickers in and out when you start, you're missing the pause command at the end of the .BAT that keeps the console alive
     
  22. Offline

    oceantheskatr

    Well adding "pause" in at the end of your bat file with keep the console open after the server is "done running". When it's stopped for any reason, such as EULA not being set to true, an error starting, port already in use, etc. Putting "pause" in will make it so that you can manually close it. (Or something to that effect.)
     
  23. Offline

    Boomer

    True that.. most likely is the Eula once he got it running..
     
  24. Offline

    oceantheskatr

    @Boomer Probably, though my tutorial does show how to set it to true, so I'm not sure. OP will have to add "pause" and then send us either a screenshot of the problem, or their latest.log.
     
Thread Status:
Not open for further replies.

Share This Page