Solved Plugin Tutorial error Missing artifact org.bukkit:bukkit:jar:bukkit-1.7.9-R0.2

Discussion in 'Plugin Development' started by Skeletonxf, Aug 3, 2015.

Thread Status:
Not open for further replies.
  1. Offline


    I was trying to follow the plugin tutorial and added in all three of the copy/paste code to the pom.xml file, but when I tried to use Maven to update the project Eclipse told me the artifact was missing. As far as I can tell it can't find the jar file it's looking for but I have no idea how to fix this because I literally just followed the tutorial word for word. Have I missed a step or something?


    I was following this tutorial and reached the end of Reference the Bukkit API

    I found a new error popup

    ArtifactTransferException: Failure to transfer org.bukkit:bukkit:jar:1.7.9-R0.2 from was cached in the local repository, resolution will not be reattempted until the update interval of bukkit-repo has elapsed or updates are forced. Original error: Could not transfer artifact org.bukkit:bukkit:jar:1.7.9-R0.2 from/to bukkit-repo ( Remotely Closed [id: 0x016513ae, / :>]

    Does this mean/help anything?

    Edit: I deleted the relevant lastupdated file under .m2 and retried the download. It seems Eclipse or Maven or whatever was just not trying to download the file (the file path was correct). After a lot of prodding I've now got it to download the file, and then I followed through with the original next step of updating the project through maven, and my errors are finally gone. I suspect it may have been my slow internet and me being impatient or something simply not realising it was meant to download the jar.
    Last edited: Aug 3, 2015
  2. @Skeletonxf It would be better to not use Maven if you don't know how to use it. Just export the plugin by right clicking, export, jar file.
  3. Offline


    Rightclicking what?

    And that doesn't explain why following the tutorial step by step has given me the errors in the first place.
  4. Online

    timtower Administrator Administrator Moderator

    @Skeletonxf Right clicking the project in Eclipse.
  5. Offline


    @Skeletonxf delete the pom.xml and do other ways youtube shows many tutorial using eclipse. that might help you to use it better
  6. Offline


    I can't find how to mark the OP as solved so I'll just say this is solved and hopefully a moderator can do it for me. The file was just not being downloaded automatically, the code was correct.
  7. Online

    timtower Administrator Administrator Moderator

    @Skeletonxf Top right corner, thread tools, edit thread, something along those lines.
Thread Status:
Not open for further replies.

Share This Page