Plugin not working?

Discussion in 'Plugin Development' started by BiskitDEV, Apr 9, 2015.

Thread Status:
Not open for further replies.
  1. Offline

    BiskitDEV

    Hey Everyone!

    I made out this fairly simply plugin, and once I finished I loaded it into my test server, and it got no errors, and it loaded into the game correctly, but it didn't seem to work? It was an item with a custom recipe.

    Any help will be amazing!

    Code; http://pastebin.com/DYUnrQVz
     
  2. Offline

    Coopah

    @BiskitDEV
    I think you may have to get the craftevent and check if the crafted item contains the custom recipe.
     
  3. Offline

    pie_flavor

    @Coopah Nope, you don't. That's if you want something complicated. Think fireworks or leather armor.
    @BiskitDEV getServer().addRecipe(speedFeather);
    By the way, you do know that the 2 means data value right? That'll be impossible to get ingredients for normally.
    I'm gonna assume that you are trying to make it require 2 emeralds. This is impossibru, the recipe would have to be changed.
     
  4. Offline

    mine-care

  5. Offline

    Coopah

    @pie_flavor @mine-care
    I was assuming he was going to make more complex things and this was just a example.
     
  6. Offline

    pie_flavor

    @Coopah Even with something like a speed feather, you can do concrete crafting recipes the way he did. Only if it's a case-by-case thing (such as combining different colors for leather armor) do you have to use custom code. Case in point: The TARDIS plugin.
     
  7. Offline

    BiskitDEV

  8. Please set this thread to Solved by going to Thread Tools (at the top) > Edit Title > Prefix > Solved. :)
     
Thread Status:
Not open for further replies.

Share This Page