Plugin Not Working

Discussion in 'Plugin Development' started by glory_fades, Oct 25, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    So on my Server the Plugin Works Fine and everything but when i upload it to my test server it doesnt work? and on my regular server it looks like this

    and on my test server it looks like this [​IMG]

    now the commands work but the gui does not. Has anyone had a similiar problem or knows a fix to this? If so please comment down below
  2. Offline


    Make sure you are running the same CraftBukkit version on both your servers.
  3. Offline


    glory_fades Same operating system for both servers? Could be a font thing. Other than @teej107's suggestion i'm not sure what it would be.
  4. Offline


    if i try adding my plugin to my regular server i get that gui thing not working still so its not the version
  5. Offline


    glory_fades Check if you have other plugins coded by you on the server if they share the same package name then thats the maybe promblem and good luck with pk :D
  6. Offline


    xepisolonxx i do not have any other plugins at the time im just running a brand new server with one plugin and yet when i use the gui, it opens but when i go to click the item it says unknown command but if i type the command it works?
  7. Offline


    This was happening on a test server that some people that I was working for had set up for me. We believe it is a operating system problem because my person server, their live server, and the test server were all different operating systems. We actually never tried really hard to find a fix for this and ended up just re-installing it to an operating system that we knew worked.

    It could be font related etc, but it also broke my plugin similar to yours because of some string equal checks that got messed up due to the new characters being put in. The operating system probably doesn't support the char set that the plugin needs, who knows.
Thread Status:
Not open for further replies.

Share This Page