Plugin for what I call Gun Game

Discussion in 'Plugin Requests' started by FullSendMC, Jan 6, 2022.

  1. Offline

    FullSendMC

    Hi, I am wanting a plugin built called GunGame. I am in no rush to get it done. This is a little bit harder than other custom plugins.
    Commands
    Game Restart (restarts the game)
    Game Start (starts the game)
    Game Stop (stops the game)
    Permissions
    GunGame.admin (allows above commands)
    This plugin would be for a mini game. There is not a time limit for each game. Each time you kill someone you get a new weapon. As you get more kills you get a weapon that does less damage. Once you reach the top level and get a kill without a weapon you win. I want the level you are on to be able to be put in a scoreboard on the side. Along with the leader level. I want it to implement a points system so each time you get a kill you earn 1 point and every win you earn 50. I want there to be a level system too. I want all wins and kills to be tracked and for them able to be put in a display on the lobby server. These stats include kills and wins along with level. I want them to be logged for weekly, monthly and all time. I want this to be connected to the hub using MongoDB.
    I want there to be a config file so i can change the weapon for each level, the amount of levels each game, amount of players required to start, and URI to link mongodb along with the database name in mongodb.
    Please message me with any questions regaurding this plugin.

    Edit: when you die to another player I want you to get randomly teleported to one of the preset locations that can be set in the config file. Also when you get killed with an empty hand i want you to go back a level and i want that to be sent in chat. Also i want the win to be broadcasted in chat and i want in the config file for a custom command to be sent to give the winner points on the server wide system.
     
  2. Offline

    timtower Administrator Administrator Moderator

  3. Offline

    FullSendMC

    I would like 1.17
    Also i want it compatible with 1.8 combat plugins
     

Share This Page