Players can't see their own and/or others messages

Discussion in 'Bukkit Help' started by ibab, Nov 16, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    ibab

    Recently, I have noticed my server having this kind of an issue. The players can't see the others chatting and/or can't see their own messages.

    I found this strange as for long time I hadn't updated or changed anything on the serverside. Just suddendly players started to report me about this issue.

    Here is a list of plugins I have on my server.
    [​IMG]

    Heres information about my server.
    Type: Dedicated server
    RAM: 16gb
    Processor: i7 2600
    Java version: 1.6.0_20
    OS: CentOS 6
    CB: 1337

    Its also 64-bit.
    Also running the server with McMyAdmin and mono.

    This doesn't seem to happen for everyone. Apparentally part of the players can see their and others messages just fine and others have this kind of issues. No matter in which group they are in, part of them just has these for some reason.
     
  2. Offline

    Windwaker

    Well I know that Showcase withholds your chat if you start to buy something, could that be it?
     
  3. Offline

    ibab

    I doubt that, because its the ShowCaseStandalone, not the normal one. This one is based off only commands, while the normal ShowCase allowed you to duck and right click to the halfblock to use it. This doesn't do anything similiar to those.

    EDIT: I noticed restarting the server fixed the problem. However, I do believe its going to happen agian because they have said its been happening for 3-4 days now. I just don't understand what can it be?

    Just bumping this up so it wont completely die. Any advices of what could I do are appreciated.
    I already tried removing ShowCaseStandalone and SimpleJail, none fixed it, though.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 21, 2016
  4. Offline

    Netto Hikari

    Having the same issue here... I like to give detailed and formatted information, so here goes:

    Operating system: Ubuntu 11.04 Maverick Meercat
    Architecture: x64
    Kernel: 2.6.38-12-server #51-Ubuntu SMP Wed Sep 28 16:07:08 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
    Server specs:
    • CPU: Intel Core i7 980-X Extreme Edition (6x3,33 GHz + 6 HT Cores)
    • RAM: 24 GB RAM (20 dedicated for Minecraft)
    • Storage: 128 GB SSD
    • Whatever, this is not necessary.
    Java version: 1.7_01 x64
    Wrappers: None
    Craftbukkit build: #1337 (RB)
    Startup line: I read about the switches on bukkit.org and on java documentation pages. They always worked great. Here's my start.sh file:

    Code:
    #!/bin/sh
    BINDIR="$(dirname "$(readlink -fn "$0")")"
    cd "$BINDIR"
    java -server -Xmn5G -Xms10G -Xmx20G -XX:PermSize=128m -XX:MaxPermSize=256m -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -XX:+CMSParallelRemarkEnabled -XX:MaxGCPauseMillis=50 -XX:ParallelGCThreads=3 -XX:+UseAdaptiveGCBoundary -XX:-UseGCOverheadLimit -XX:+UseBiasedLocking -XX:SurvivorRatio=8 -XX:TargetSurvivorRatio=90 -XX:MaxTenuringThreshold=15 -Xnoclassgc -XX:UseSSE=4 -XX:+UseStringCache -XX:+UseCompressedStrings -XX:+OptimizeStringConcat -XX:+UseFastAccessorMethods -XX:+AggressiveOpts -Djava.net.preferIPv4Stack=true -jar craftbukkit.jar
    Plugins: Many of these I have coded. Since they didn't change in a few days, they're probably not the problem cause.
    • ECBackup
    • ECBans
    • ECBoost
    • ECChat
    • ECCore
    • ECExtra
    • ECHunt
    • ECNullWG
    • ECPassword
    • ECSupport
    • ChestShop
    • ColoredSigns
    • FalseBookBlock
    • FalseBookCore
    • FalseBookExtra
    • FalseBookIC
    • HawkEye
    • LWC
    • LagMeter
    • Minequery
    • MobBounty
    • Modifyworld (PEX)
    • Multiverse-Core
    • Multiverse-Portals
    • MyHome
    • OpenInv
    • Permissions (PEX bridge as very few plugins still seem to need it)
    • PermissionsEx
    • Spout
    • VanishNoPacket
    • WorldBorder
    • WorldEdit
    • WorldGuard
    • dynmap
    • iConomy
    • Rawcritics Ore Obfuscation (Spout)
    Error: Broadcast messages don't show up any more after some time. Some players still can see them, others don't. A restart fixes the issue for about 1 hour max. It started happening yesterday after I updated all plugins (not made by me). Plugins added: FalseBookIC, switched from BorderGuard to WorldBorder; Plugins updated: LagMeter, PermissionsEx, VanishNoPacket, dynmap (enabled webchat visibility).

    No errors in log.

    What I tried: Read the all the changelogs of updated plugins, upgraded PEX to development version.
     
  5. Offline

    Donny

    I had the same problem ever since 1337 RB. I now use CB: 1367 and haven't had the problem since.

    Odd thing is we all use hawkeye

    Plugins: IPGet, VanishNoPickup, Xray Detection, PermissionsEx, xAuth, iConomy, OKB3, KiwiAdmin, xWarp, Minequery, MobDisguise, Permissions, FalseBookExtra, FalseBookCart, CommandBook, FalseBookCore, LWC-Economy, ModTRS, WorldGuard, NoCheat, FalseBookBlock, WorldEdit, HeroChat, FirstLastSeen, FalseBookIC, Votifier, BukkitCompat, dynmap, MobBounty, WorldBorder, SimpleRegionMarket, LWC, PreciousStones, mcMMO, Register, HawkEye, EasyBan, ChestShop
     
  6. Offline

    ibab

    And CB 1367 has worked just fine for you all the time?
    I'm not really into using any non recommended builds, but if its deemed to work fine and not have any issues with being stable, I might give it a try.
     
  7. Offline

    Lolmewn Retired Staff

    Try disabling all plugins one by one.
    Disable one, check if it works. Not? Enable again, disable the next one.
     
  8. Offline

    ibab

    This would just take ages with that many plugins. Also since when I restart, it works fine for around 10 minutes, then it will either then break or not.
     
  9. Offline

    Netto Hikari

    I solved it by upgrading to build 1438... Works fine, no bugs. Running smooth since yesterday, no restarts.
     
  10. Offline

    ibab

    I upgraded to 1367, didn't help.
    I will try 1438 now.

    Bumping up again.
    Even after build 1438, the same issue occurs. Anyone got ideas what I should try?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 21, 2016
  11. Offline

    Netto Hikari

    Did you try updating all plugins to the newest version avaiable? Maybe use a PEX development version (these are very stable)... Delete all temporary files that have been eventually created by plugins?

    EDIT: Ohkay, it seems that the problem hast just occured again on my server. I still see the messages, but my users won't. Using CB #1438. Gonna investigate later.
     
  12. Offline

    Netto Hikari

    ibab, any news?
     
  13. Offline

    Tanite

    I've been having that problem for a while. We share more than a few plugins in common though :/
     
Thread Status:
Not open for further replies.

Share This Page