Here is the usage: In the javadoc it says it was deprecated because it is a "magic number". I'm developing against API 1.7.5-R0.1. Am I doing something wrong, or is getName really deprecated? If so, what is the replacement? I've been away from the Minecraft scene for a while so I may be missing out on some crucial information. I don't want to use getDisplayName or similar because it can be changed.