PermissionsEx

Discussion in 'Bukkit Help' started by MrMr57, Nov 27, 2014.

Thread Status:
Not open for further replies.
  1. Offline

    MrMr57

    Hello, I was asking to see if anyone knew how to fix this problem I have with my perms. I want to have some worlds have different permissions than others. For instance I could type in a command like /bal in one world but not in the other. Please help me with this problem. Here is my permissions.yml file.

    http://pastebin.com/hTTDkJML
     
  2. Offline

    DOGBOY60

    Multiverse may help, not sure

    EDIT by Timtower: removed capslock, it doesn't add anything.
     
  3. Offline

    JaguarJo Retired Staff

    MrMr57 Here, I'll give you an example of how to set up per world permissions using your PermissionsEx file. There is a worlds section that you add, and then you specify each world name and the permissions it gets under it. Like this:
    Code:
    groups:
      Member:
        permissions:
        - global.permission.nodes
        worlds:
          NameofWorld:
            permissions:
            - nodes.for.thisworld
          Other_WorldName:
            permissions:
            - nodes.for.thisother.world
        options:
          rank: '1000'
          default: true
          prefix: '&6[Member]&f-'
      Helper:
        inheritance:
        - Member
        permissions:
        - more.global.perms
        worlds:
          NameofWorld:
            permissions:
            - moreperms.justfor.thisworld
            - andmore.perms
          Other_WorldName:
            permissions:
            - and.other.perms
        options:
          default: false
          rank: '900'
          prefix: '&e[Helper]&f-'
     
  4. Offline

    MrMr57

    I tried that and It didn't work
     
  5. Offline

    JaguarJo Retired Staff

    MrMr57 Is PEX working for you otherwise? Because it looks like you still have some default: true/false and prefix lines outside of the options section in your old file that might be messing with the plugin.
     
  6. Offline

    MrMr57

    JaguarJo Pex is working but in the file it says the prefix then the prefix well that doesn't work so I had to do those ingame but the perms work just fine. I just need to know how to use the per world permissions.
     
  7. Offline

    JaguarJo Retired Staff

    MrMr57 Well the example I gave is how per world perms are set up. If standard perms are working regularly, then I don't know why it isn't accepting the per world sections. Are you sure that you've copied your world names exactly? PEX is extremely picky when it comes to capitalization and things like that. Did you remove the permission nodes from the global sections that you wanted limited to only specific worlds?

    When you tried adding the per world sections, what part of it didn't work? Like, did it disable the whole plugin and all the perms quit working, or did it just not seem to change anything from how it was before?
     
  8. Offline

    MrMr57

    JaguarJo It didn't change anything from how it was before
     
Thread Status:
Not open for further replies.

Share This Page