Solved PermissionsEx Not Working Red in /pl? *Help!*

Discussion in 'Bukkit Help' started by McSouls, May 8, 2014.

Thread Status:
Not open for further replies.
  1. Offline


    I've been running my server for awhile now, It's still on 1.7.4, I opened the server about 2 weeks ago, It's been very succssful for the most part. A couple of days ago I was adding some permissions to one of my groups, and then I did a /pex reload. It said there was an error, I tried fixing it then do /pex reload and nothing happend. From experience I did /pl to check if it was red, infact is was. I tried looking around to see if anyone had similar issues, and all I got was "your spacing was off" I've checked this a billion times with Online YAML Parser, and I've re-wrote it twice, After re-writing it for the 2nd time, I finally got it working! Then I downloaded a plugin on my server, did /reload and it went red again! I didn't even edit it this time just did a /reload. Therefore I am coming here to help figure out why after I /reload my server permissionsex breaks! Here are my PermissionsEx Files and my plugins list:

    > PermissionsEx >>

    > Plugins List >>
  2. Offline


    McSouls Well first of all, you have redundancies in your inheritances. In other words, if B inherits from A and C inherits from B, then you don't need to also add that C inherits from A because it will already get A's permissions from B. So I cleaned up your inheritances: (You also had one group that was inheriting from itself and that was probably what broke during your /pex reload.)

    The other thing is, you really shouldn't be using /reload. It has a tendency to break things sometimes. If an individual plugin has its own reload command, like PEX has /pex reload and Essentials has /ess reload, that's okay. But a plain old /reload for the whole server, don't do that. It's much safer to do a full /stop and then /start so that things shutdown and load up properly.
  3. Offline


    JaguarJo It's making it red when I do /stop /start still.
  4. Offline


    Try changing the UID in your permissions.yml back to your player name. My guess is you have it working fine, but haven't assigned yourself the rights to use it.
  5. Offline


    On just about every server I have ever setup since 1.3, the /reload command causes the server/plugins to break. Strike that command from your server and ensure it is never issued again by anyone. It will cause more problem than it can ever solve. Instead, stop and restart the server.

    If you start the server and /pl shows the plugin as red, then something didn't work right (almost always due to configuration issue - e.g. nut behind the wheel). To trouble-shoot this situation, you need to examine the server log file which can be found in <server folder>/logs/latest.log

    We need to see the start of the log where it shows the version of CraftBukkit you are using, and every part related to PermissionsEx if you don't want to show the entire log. This will allows to see the CB and PEX version you are using as well as the error message which usually tells us exactly where the problem is located.

  6. Offline


    I am just doing a server reset, totally, to see how that works. If anyone else can tell me why permissionsEx would be doing that please reply.
  7. Offline


    Alright, So I figured out why it wasn't working. My server is 1.7.4 and I was downloading all of them with 1.7.4 in the name, turns out I should've looked at the file version types in the description, I downloaded the 1.7.2 one pasted my perms in and BAM! It worked thanks for the help
Thread Status:
Not open for further replies.

Share This Page