[PermissionsEx] Group Lifetime problems

Discussion in 'Bukkit Help' started by Weasel_Squeezer, Feb 16, 2013.

Thread Status:
Not open for further replies.
  1. Offline

    Weasel_Squeezer

    I am having serious issues with permissions ex right now with timed groups.
    I run the following command:
    /pex user Weasel_Squeezer group add vip empire 60

    This should put me into the vip group for 60 seconds, but instead, it puts me in there indefinitely... I am still in the group after many minutes has passed. I looked at the permissions file for my entry under users, and the lifetime option has been added correctly as such:
    Code:
    Weasel_Squeezer:
      group:
        - Ruins
      worlds:
        empire:
          group:
            - Vip
          options:
            group-Vip-until: '1361051524'
    I tried running some code to figure out exactly what that value is in relation too, but I found nothing. I do not think it is a timestamp because System.currentTimeMillis() subtracted by this or the other way around gives either a largely negative number or a positive number which when converted from milliseconds to days gives no accurate result, and even from seconds to days gives nothing like it should.

    I also want to know why when you run the command again, it doesn't seem to add any time in the permissions.yml file. I want to have it so that it will add the time to the current time left for the player.

    I may end up adding timed groups to my plugin instead...

    Any ideas of whats wrong? this is extremely frustrating. I am going to explode.
     
  2. Offline

    Tombula77

    Yes, it's correct value. User stay in vip group until next login. Sorry for my english.
     
Thread Status:
Not open for further replies.

Share This Page