Permissions, MultiVerse, WorldGuard

Discussion in 'Bukkit Help' started by Schlumpfpirat, May 11, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Hello Bukkit Community,

    my server is running on the latest Bukkit version (766) on a root server.
    A list of my plugins can be found here:

    Everything worked well before I did this:
    Alright I finally decided using Multiworld to open up my server for everyone, so I downloaded MultiVerse, because an other server, Serenity (, used is aswell using almost the same plugins as I do, so I thought: "Yeah, why not, there sure won't come up any issues".
    So I downloaded MultiVerse and rebooted my server, which would cause some issues.
    Here is a normal startup log of my server:
    As you can see WorldGuard got some issues with MultiVerse..

    I went back on my server and let a friend of mine join, usually he was able to punch trees and pick up items, which he was not now anymore.
    So I gave him Adminrights and now he was able to break blocks and pick up items. I figured out, that noone in the world is able to build, only if I change build: false to build: true in Default group.
    Even if I turn out MultiVerse the problem still continues.
    I now tried around like one week and still didn't figure out what the problem is, or why Serenity gets it working.
    I don't really know what to write else, so I'm posting the configs of my worlds and placing some screenshots here to let you get a look on everything.
    And no, I did not change anything in WorldGuard's world ymls at all, and YES MultiVerse, WorldGuard and Permissions are up-to-date.

    Got no issues with world and tnt atm, because default's build is set to true.

    Permissions Folder:
    Bukkit Folder:
    WorldGuard Folder:
    Permissions (world.yml):
    Permissions (NETHER.yml):
    Permissions (open.yml):
    Permissions (tnt.yml):

    Let me know if you need any additional information.



    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 16, 2016
  2. Offline


    I really wish i had something for ya, i do. I like to blame essentials cause it hates working with many plugins. For giggles, I'd try disabling that. (yeah, i know it worked before, but its not now, even without multiverse)

    After that, I'd wipe out all of the plugins and start re-adding them one by one and keep testing the user groups.

    I'm using all 3 of these plugins plus several others and it all works great.

    **edit* try wiping out all of worldguard's config files first. Just delete them all. Delete the whole worldguard directory and let it recreate it.
  3. Offline


    Be sure that your has everything enabled to true, whether it is really true or not.

    In the individual worlds, in the MultiVerse folder (Worlds.yml), you can set the individual world's properties.

    The plugins work together, I've been using them almost since I've been running the server.

    Also, try creating the worlds (use names very close, so there's not much editing) in MultiVerse, then save/stop the server and rename the worlds in the World.yml file (again @ MultiVerse folder) to the originals.
  4. Offline


    Alright, sitting here in class, typing on my iPhone, so I can't write that much, but I'll post the conclusion today (GMT +2).
    That's what I did: I deleted WorldGuard Folder, but it still didn't work, so I decided to turn off Essentials, after I had no success there aswell I turned off WorldGuard, which still didn't bring success. After this I decided to turn off Essentials, WorldGuard and MultiVerse. And guess what, ot still didn't work.
    So I decided to turn off everything, but Permissions, because I thought Permissions may be screwed up. BUT now it worked. So I here I was kinda happy jumping around. Them. The last thing I did was to turn back on WorldEdit, WorldGuard, Essentials and MultiVerse, which still worked.
    So I'll turn back on every plugin one by one and kill the plugin developer of coding such a crap..
    Naaah jk.

    Thanks for your help so far!

    I'm soo stupid.
    As you can clearly tell I downloaded AntiGrief.. BUT since there are no permission nodes I didn't give away any permissions.
    Now I gave away 'antigrief.*' to Builder Group, now it works..

    Anyways I still got one question:
    What are the Permission nodes for AntiGrief and what do they do?

    Thanks :]

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 16, 2016
  5. Offline


    I believe AntiGrief has no permission nodes, it simply follows the build:true|false node, and you can configure what build:false will actually block.

    Please confirm: you use Essentials, AND multiverse, to have multiple worlds? I use essentials to enable my nether, how did you configure this? you disabled the Essentials-nether, and Multiverse can simple create multiple new worlds (including a nether)?

    Might be easier if you would post your essentials and MV configs, I'm also willing to make the jump to a multi-world server now :D.
  6. Offline


    Actually there are permission nodes for AntiGrief^^ otherwise the Permission 'antigrief.*' wouldn't have had any effect.

    I never actually used Essentials for Multiworld.
    I'm using Essentials and EssentialsSpawn but I sure can post my configfiles.
    MultiVerse (MultiVerse.yml):
    MultiVerse (Worlds.yml):

    Let me know if you need any further files or information.
  7. Offline


    Thanks, but could you show me your essentials config... instead of a picture of the folder :p?

    Actually, its just one thing I'm intrested in from the essentials config...
      enabled: true
      folder: nether
      portals-enabled: true
    you have enabled: false?
  8. Offline


      enabled: false
      folder: nether
      portals-enabled: false
      generate-exit-portals: false
      use-1to1-ratio: false
  9. Offline


    Thanks! (lol seems my config file is very old... I should let Essentials regenerate it :p)
Thread Status:
Not open for further replies.

Share This Page