Solved People can't connect to my server (anymore)

Discussion in 'Bukkit Help' started by MatsExe, Jul 11, 2015.

Thread Status:
Not open for further replies.
  1. Offline

    MatsExe

    Okay, let me explain the situation here. I have private server for friends and events, everything worked fine until my connection decided to kick out my PC from the internet access. I couldn't use that connection for a several days so I had to use a sub-connection, the server already happened to be broken then but I thought it was because of the sub-connection.

    Using my main connection now, the server is still broken. I can connect to it with localhost and strangely even my external ip, but others can't. This is the error message they are getting. NOTE: The console doesn't mention a failed connection or some sort.

    [​IMG]

    This is what canyouseeme.org says:

    [​IMG]

    As I already mentioned before I can connect on it through my external ip and the custom ip I am using. This server slot uses the custom ip.

    [​IMG]

    So I have no clue what is happening right now, I already have googled for solution but none seemed to work for me.

    If you have any possible solutions, please share them with me. Thanks!

    EDIT: When it was offline I updated my server from 1.7 to 1.8 but that doesn't really have any affect on the connection or does it?
     
  2. Offline

    benjfb1

    So the server starts up fine? Can you pastebin a FULL copy of your logs?
    Sounds like a network problem?
     
    MatsExe likes this.
  3. Offline

    MatsExe

    Here you go:

    Code:
    C:\Users\Mats\Desktop\Games\1.8 Bukkit>java -Xmx512M -jar craftbukkit1_8_7.jar -
    o true
    Loading libraries, please wait...
    [20:23:45 INFO]: Starting minecraft server version 1.8.7
    [20:23:45 WARN]: To start the server with more ram, launch it as "java -Xmx1024M
    -Xms1024M -jar minecraft_server.jar"
    [20:23:46 INFO]: Loading properties
    [20:23:46 INFO]: Default game type: SURVIVAL
    [20:23:46 INFO]: Generating keypair
    [20:23:46 INFO]: Starting Minecraft server on *:25565
    [20:23:46 INFO]: Using default channel type
    [20:23:47 INFO]: This server is running CraftBukkit version git-Bukkit-e91aed8 (
    MC: 1.8.7) (Implementing API version 1.8.7-R0.1-SNAPSHOT)
    [20:23:47 INFO]: [PermissionsEx] Loading PermissionsEx v1.23.3
    [20:23:47 INFO]: [DisableCommands] Loading DisableCommands v1.5
    [20:23:47 INFO]: [AlwaysDay] Loading AlwaysDay v2.2.8
    [20:23:47 INFO]: [WorldEdit] Loading WorldEdit v5.6.3
    [20:23:47 INFO]: [GetGamemode] Loading GetGamemode v2.0
    [20:23:47 INFO]: [ClearInventory] Loading ClearInventory v1.3
    [20:23:47 INFO]: [Launchpads] Loading Launchpads v1.1
    [20:23:47 INFO]: [NoRain] Loading NoRain v1.4
    [20:23:47 INFO]: [FarmProtect] Loading FarmProtect v1.8.2
    [20:23:47 INFO]: [OpenInv] Loading OpenInv v2.3.0
    [20:23:47 INFO]: [WorldGuard] Loading WorldGuard v6.1
    [20:23:47 INFO]: Preparing level "world"
    [20:23:48 INFO]: Preparing start region for level 0 (Seed: -1728897264872108230)
    [20:23:48 INFO]: Preparing start region for level 1 (Seed: -1728897264872108230)
    [20:23:49 INFO]: [PermissionsEx] Enabling PermissionsEx v1.23.3
    [20:23:49 INFO]: [PermissionsEx] Initializing file backend
    [20:23:49 INFO]: [PermissionsEx] Permissions file successfully reloaded
    [20:23:49 INFO]: [DisableCommands] Enabling DisableCommands v1.5
    [20:23:49 INFO]: [DisableCommands] Disable Commands version 1.5 has been enabled
    .
    [20:23:49 INFO]: [DisableCommands] Developed by: [lst96, Mindfulhacker]
    [20:23:50 INFO]: [DisableCommands] ┬║aDisableCommands v1.5 is the latest version
    available!
    [20:23:50 INFO]: [AlwaysDay] Enabling AlwaysDay v2.2.8
    [20:23:50 INFO]: [AlwaysDay] AlwaysDay v2.2.8 is now enabled.
    [20:23:50 INFO]: Please donate at the AlwaysDay page (http://dev.bukkit.org/serv
    er-mods/always-day/) if you are enjoying this plugin! Any contributions are grea
    tly appreciated!
    [20:23:50 INFO]: [WorldEdit] Enabling WorldEdit v5.6.3
    [20:23:50 INFO]: WEPIF: PermissionsEx detected! Using PermissionsEx for permissi
    ons.
    [20:23:51 INFO]: [GetGamemode] Enabling GetGamemode v2.0
    [20:23:51 INFO]: [GetGamemode] Plugin Enabled.
    [20:23:51 INFO]: [ClearInventory] Enabling ClearInventory v1.3
    [20:23:51 INFO]: [EmeraldLauncher2] Enabling EmeraldLauncher2 v1.0
    [20:23:51 INFO]: [NoRain] Enabling NoRain v1.1.5
    [20:23:51 INFO]: [FarmProtect] Enabling FarmProtect v1.8.2
    [20:23:51 INFO]: [FarmProtect] You are running the latest version of FarmProtect
    [20:23:51 INFO]: [FarmProtect] Version 1.8.2 by jacklin213 has been Enabled!
    [20:23:51 INFO]: [OpenInv] Enabling OpenInv v2.3.0
    [20:23:51 INFO]: [WorldGuard] Enabling WorldGuard v6.1
    [20:23:51 INFO]: [WorldGuard] (world) TNT ignition is PERMITTED.
    [20:23:51 INFO]: [WorldGuard] (world) Lighters are PERMITTED.
    [20:23:51 INFO]: [WorldGuard] (world) Lava fire is blocked.
    [20:23:51 INFO]: [WorldGuard] (world) Fire spread is UNRESTRICTED.
    [20:23:51 INFO]: [WorldGuard] Loaded configuration for world 'world'
    [20:23:51 INFO]: [WorldGuard] (world_the_end) TNT ignition is PERMITTED.
    [20:23:51 INFO]: [WorldGuard] (world_the_end) Lighters are PERMITTED.
    [20:23:51 INFO]: [WorldGuard] (world_the_end) Lava fire is blocked.
    [20:23:51 INFO]: [WorldGuard] (world_the_end) Fire spread is UNRESTRICTED.
    [20:23:51 INFO]: [WorldGuard] Loaded configuration for world 'world_the_end'
    [20:23:51 INFO]: [WorldGuard] Loading region data...
    [20:23:52 INFO]: Server permissions file permissions.yml is empty, ignoring it
    [20:23:52 INFO]: Done (4,614s)! For help, type "help" or "?"
    >
    Thanks for offering help!
     
  4. Offline

    benjfb1

    Did you have your computer port-forwarded, if so do it again therefore being the reason others can't join. You could always use hamachi instead, but port-forwarded it again if it was previously.
     
    MatsExe likes this.
  5. Offline

    oceantheskatr

    @MatsExe Never use Hamachi, your friends will hate you ;)

    I think that your internal IP may have changed. Before the connection loss it may have been 192.168.0.5 and then now it's 192.169.0.6 or something, so check that by lauching command prompt and typing ipconfig. Look for the internet connection type you're using (mine is Ethernet adapter Local Area Connection) and look at the IP for IPv4. Mine is 192.168.0.2, though it was 192.168.0.4 a few weeks ago. Make sure that it matches the portforwarded one.
     
    MatsExe likes this.
  6. Offline

    MatsExe

    I removed my old port forwarding setting and redid it but no fix unfortunately, I could send you some settings of my port forwards if that clears up something...

    @oceantheskatr Actually my internal ip did change but that didn't fix the problem when I tried to re-portforward it.
     
  7. Offline

    MatsExe

    Solved.
    If some people experience the same issue:

    Removing the external IP from my port forward settings removed the thing where I could strangely connect with the public IP but others couldn't.
    I restarted my router and used a DMZ host, which seemed to work.
     
    Last edited: Jul 14, 2015
Thread Status:
Not open for further replies.

Share This Page