Others Can't Connect to my Bukkit Server!

Discussion in 'Bukkit Help' started by rogvid700, Jul 6, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Ok so my server is running on a wireless connection.


    Ok so the image above is a picture of my server running, with my server properties as server-ip= (blank) and my portchecker receiving the error message that it could not test the port because some other application was blocking it. When others try to connect...it just says "Connecting to the server" then it times out.


    The picture above is my server running, with my server properties as server-ip=localhost......It now says that my port is open and other players CAN connect to my server....but, when they try to... it just says "logging in" and then times out.


    The picture above is of my server running, with the server properties as server-ip= (which is my IP) The portchecker is now saying that my port is NOT OPEN, therefore others CANT connect to my server. When they try to it just says "Connecting to server" then it times out.


    The picture above is of my port forwarding rule for minecraft.


    The image above is of my port forwarding of minecraft....(third one down from Networked Computer/Device)

    If you need anymore screenshots for more info...PLEASE LET ME KNOW
  2. Offline


    on my server its working with a black
    in the confing
    when another programm blocks the port, just take another

    what did you exactly do in your firewall config?
    you need to config the incomming rules, not the outgoing
    tcp and udp, all remoteports
    do you have the windowsfire wall or another one?

    you could also try to connect to your public ip instead of localhost for testing the connection

    for checking your public ip, here is something :)

    you have to forward skype ??? since when does someone has to do this?
  3. Offline


    it probably the Wireless Connection it always bad to use for a server.
    ill recommend to get a wire and use that.

    also that Portchecker does only check it from Lan View its best to check from a Wan Server Like www.canyouseeme.org
  4. Offline


    Don't bind to an IP. Like MG127 said, it works when you do that.
  5. Offline


    lol I didnt have to forward skype, it did it autuomatically :)

    THANKYOU TO EVERYONE WHO POSTED SOMETHING TO AID IN MY MINECRAFT BUKKIT SERVER PROBLEM BUT IT HAS BEEN FIXED NOW...Turns out that I was running java in 32-bit mode on my 64-bit computer, I just un-installed java and downloaded the specific windows 7 64-bit download, and changed the RUN.bat txt document and it worked! players can succesfully join my server. Oh and leaving my server-ip= blank didnt work....I filled it with my IP...now it works..:) but thankyou for the suggestion



    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  6. Offline


    Cracked it! Turn your modem off and on, the INTERNAL ip should change and the server will work again1
  7. Offline


    I have the exact same problem mabey it's just the computer itself not us if we all have windows 7 mabey thats the problem we might have to do something diffrent than everyone else
  8. Offline


    ok im having the same problem as rogvid but i have done everything right for my bukkit server and when i put in my external ip for other players to join it wont let me join through that it only lets me join through local host and my brother he has a computer and im using his computer to test the external ip but i dont think that makes a difference because we use the same wifi is there anyone who knows what to do

    by the way does anyone still use this forum

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  9. Offline


    omg now i have it 2
  10. Offline


    I FOUND YOUR PROBLEM!!!!Call your internet service provider and ask them if any ports such as 25565 is blocked.Because in one of your pics it said it had been locked.So your ISP muush of blocked it because the port 25 is always being locked from spam and all i recommend this :)
Thread Status:
Not open for further replies.

Share This Page