Problem/Bug Nothing happens when I issue a comand

Discussion in 'Bukkit Help' started by rustedstrafer, Apr 4, 2020.

Thread Status:
Not open for further replies.
  1. Offline

    rustedstrafer

    I'm trying to build a server on 1.8 but nothing happens when I issue a command in the chat.
    Console says: "(My Nick) issued server command: /(command)" and nothing else. Few moments after I run the server, this message appears repeatedly in the console:
    Code:
    [21:00:13 WARN]: [Essentials] EssentialsTimer Error:
    java.lang.NullPointerException
            at com.earth2me.essentials.perm.PermissionsHandler.getName(PermissionsHandler.java:153) ~[EssentialsX-2.17.2.0.jar:?]
            at com.earth2me.essentials.User.isAuthorizedCheck(User.java:117) ~[EssentialsX-2.17.2.0.jar:?]
            at com.earth2me.essentials.User.isAuthorized(User.java:93) ~[EssentialsX-2.17.2.0.jar:?]
            at com.earth2me.essentials.User.checkActivity(User.java:646) ~[EssentialsX-2.17.2.0.jar:?]
            at com.earth2me.essentials.EssentialsTimer.run(EssentialsTimer.java:58) [EssentialsX-2.17.2.0.jar:?]
            at org.bukkit.craftbukkit.v1_8_R1.scheduler.CraftTask.run(CraftTask.java:53) [craftbukkit.jar:git-Bukkit-33d5de3]
            at org.bukkit.craftbukkit.v1_8_R1.scheduler.CraftScheduler.mainThreadHeartbeat(CraftScheduler.java:349) [craftbukkit.jar:git-Bukkit-33d5de3]
            at net.minecraft.server.v1_8_R1.MinecraftServer.z(MinecraftServer.java:668) [craftbukkit.jar:git-Bukkit-33d5de3]
            at net.minecraft.server.v1_8_R1.DedicatedServer.z(DedicatedServer.java:284) [craftbukkit.jar:git-Bukkit-33d5de3]
            at net.minecraft.server.v1_8_R1.MinecraftServer.y(MinecraftServer.java:609) [craftbukkit.jar:git-Bukkit-33d5de3]
            at net.minecraft.server.v1_8_R1.MinecraftServer.run(MinecraftServer.java:517) [craftbukkit.jar:git-Bukkit-33d5de3]
            at java.lang.Thread.run(Unknown Source) [?:1.8.0_231]
    Only the commands "/say" and "/login" work. Messages appear when I type, and plugins seem to work (at least the ones that don't require any chat commands).
    Commands I issue in the console also don't work.
    When I issue a command that doesn't exist, it obviously says "Unknown command. Type "/help" for help.".
    Thanks for all help.
     
  2. Offline

    timtower Moderator Moderator

  3. Offline

    rustedstrafer

  4. Offline

    timtower Moderator Moderator

    @rustedstrafer Find a version made for your server version instead.
     
  5. Offline

    rustedstrafer

    @timtower Umm I didn't get it, it says it's available for 1.8? If not, what do you suggest?

    I've installed Bssentials for 1.8, and still, some commands do the same thing (most of them work). And there's no GroupManager or something like that. Is it about Bssentials or my server?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: Apr 4, 2020
Thread Status:
Not open for further replies.

Share This Page