[Not solved, but no longer needed] No crash, but server loses internet connection

Discussion in 'Bukkit Help' started by DZComposer, Aug 8, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    First off, let me say that I'm new to minecraft servers and bukkit, so it is entirely possible that I misconfigured something.

    Anyway, I have a hosted virtual server (Xen is the hypervisor) with a public IP address running Windows Server 2008 SP2. Server has "three hyper-threaded cores" and 5GB RAM. Internet connection speed is ~800MBit down, ~500Mbit Up.

    JRE7 Update 25 (1.7.0_25-b17), both 32-bit and 64-bit versions installed, but I do not know which is being used here.

    Issue has happened with both versions 1.5.2-R1.0 (stable) and 1.6.2-R1.0 (beta).

    Seemingly at random, but only when more than one person is connected to the server, the server OS will lose internet connection. This only happens when running Minecraft/Bukkit. I can run other game servers without issue.

    By losing internet connection, I mean completely no internet. Other services are cut-off, can't ping out, can't load webpages. I can't even RDP into the server. Only way I can get in is to VNC into the hypervisor. Once in, I can see everything is running fine. The minecraft/bukkit server is still running. No errors show in the console window or in the logs (reason given for disconnects is either 'connection reset' or 'disconnect.genericreason'). Windows logs also show no errors. I can issue commands to the Minecraft server and it takes them just fine. The machine, however, has just dropped-off the internet. Only way to get it back is to reboot the server. Host claims they do not firewall-off minecraft servers.

    I've tried disabling QoS packet scheduling, but no dice.

    Once again: This server is in a datacenter and has a public IP. This is not a home network setup.

    Googling has yielded little help, so I'm hoping someone here can shine some light on this for me.

    EDIT: server configs and log
  2. Offline


    I think its a adapter problem or a minecraft plugin. Investigate if anything that shuts off the adapter.
  3. Offline


    The adapter was the first thing I checked. It doesn't get disabled. It even still retains its IP address. It just can't talk to the network.

    Also, this only happens when I have 2 or more players on Minecraft. I have run TF2, Left 4 Dead 2, Battlefield 1942, Wolfenstein Enemy Territory, and a few other games with no problems (Minecraft is the only server running at the moment, though).

    There is also a MySQL instance running.

    As far as plugins, all I have at the moment are WorldEdit and WorldGuard.

    Everywhere I see similar issues on Google, there are no answers. But there is a common thread: Windows.

    I have concluded that Windows is not the OS for this, so I will be reconfiguring my server to run CentOS Linux.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jun 3, 2016
Thread Status:
Not open for further replies.

Share This Page