not connecting :(

Discussion in 'Bukkit Help' started by manaforge, Jan 17, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    so i have a craftbukkit server set up, no plugins so its vanila and im trying to connect from school which has a seperate ip then my home, but it says cannot connect, i know my server is up and running because its been running for a week with no hicups, i can play at home with no problems i get to school and bam cannot connect, im using the ip address from this seems not to work and yes i have my ports open. please any help would be appreciated. thanks.
  2. Offline


    Test if your ports are open (yes, I know you said they were, but test to make sure):

    telnet <ipaddress> <port number>

    If you get a blank window, you've connected to your server. Now in your server console, you should see an error - since it doesn't know what to do with a telnet connection.

    That will tell you if a) Your port is open, and b) If you're able to connect to your server.
  3. Offline


    Connecting in a LAN and from the outside are 2 completely different things. You don't have to open ports in LAN. So like TnT said: doublecheck your ports and the ip. 99% one of them is wrong (or not forwarded /opened correctly).
    If this isn't working try to set up a real vanilla server first (not craftbukkit, just the one from

  4. Offline


    so for the telnet thing i just use cmd.exe? or is there a program that does this? im on my laptop (windows vista) and i tried telnet ip port and nothing

    edit* wow i feel silly, i use this stuff day in and day out, i used puTTy to try and connect, nothing comes up and says connection not real or problems with the connect, ill get u a ss in 1 sec

    edit* ok so i used puTTy and it opened up a blank window with nothing in it, then about 5 seconds later it closes. (my brother shut my server off ><), but i still cant connect to it. i did the telnet exactly how u said and i used my ip and the port.
  5. Offline


    Check your server console - if your Minecraft server is up and running, it should show an error in the console itself.

    In vista, if you want the telnet command in your cmd.exe, you need to install the telnet client in your programs and features (add windows component). Vista/W7 doesn't have it built in by default.
  6. Offline


    its not showing anything, my ip is and the port is obviuosly 25565, when i open putty i connect to the ip then place the port in port then i click telnet, then i click open, a blank screen shows up. then on the console it shows nothing. ><
  7. Offline


    I just tried the same thing - IP you listed and port number you gave. I did get a blank screen. I just tried typing in there a bunch of garbage. Did you see any error messages on your craftbukkit server console? I'm guessing you should see something. Either way, I'd be confident your server is accepting connections on port 25565.

    Next step: What build are you running? What OS/version? What java version?
  8. Offline


    '32-bit' is not recognized as an internal or external command,
    operable program or batch file.
    2011-01-17 17:26:14 [INFO] Starting minecraft server version Beta 1.2_01
    2011-01-17 17:26:14 [INFO] Loading properties
    2011-01-17 17:26:14 [INFO] Starting Minecraft server on *:25565
    2011-01-17 17:26:14 [INFO] Preparing level "world"
    2011-01-17 17:26:14 [INFO] Preparing start region
    Preparing spawn area: 20%
    Preparing spawn area: 32%
    Preparing spawn area: 61%
    Preparing spawn area: 69%
    Preparing spawn area: 73%
    Preparing spawn area: 81%

    2011-01-17 17:26:21 [INFO] Done! For help, type "help" or "?"
    at Source)
    at net.minecraft.server.Packet104.a(SourceFile:31)
    at net.minecraft.server.Packet.b(SourceFile:108)
    at net.minecraft.server.NetworkManager.f(SourceFile:157)
    at net.minecraft.server.NetworkManager.c(SourceFile:15)
    2011-01-17 17:34:29 [INFO] / lost connection
  9. Offline


    Good news - that last line was someone trying to telnet into your server, which means your ports are open and all is good to go.

    Are you sure your connection issues aren't related to all the problems going on with Minecraft authentication today? I'm having a hard time connecting anywhere, or even logging in.
  10. Offline


    been like this ever since i started my own servers, vanila and craftbukkit
    so really >< i dont know whats wrong :(
  11. Offline


    Let me see if I can log into it.

    I can, and it looks good to me. I'm going to make a giant penis for you to enjoy, if you can ever get into your server. ;)

    My guess: your school is doing some network management and killing your connection. Try from your lan.
  12. Offline


    k, so i put that stuff into putty. I get a blank screen for a second or two then it closes - nothing pops up in my server log. Does this mean the port isnt working?
  13. Offline


    Most likely, yes. Post your IP and port and I can try.
  14. Offline

  15. Offline


    I can't connect to that externally. If you can't telnet to it or connect to it, it means you likely have a firewall in the way.
  16. Offline


    Okay. I'll try forwarding the port again.

    i tried re-forwarding the port, then tried the telnet command again, but no luck. I might just not be following the tutorial on though. does anyone know exactly what you need to put into all of the boxes when youre adding a new definition to your firewall?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 6, 2016
  17. Offline


    Loaded question. There are many different routers, and may different ways to open ports. At bare minimum we need you router model, and preferably a screenshot of how you have it currently configured.

    Edit: Can you connect from within your own LAN? Did you check for a firewall on the machine you are trying to host your Minecraft server on?
  18. Offline


    im having the same problem i can connect from localhost but not lan or web.. ports are setup and all my other servers(mumble, web) work
    i dont even see a response on the server console though
    using newest bukkit build and latest java on windows7 64b

    EDIT fixed... windows firewall
  19. Offline


    Yeah, i can log on when I'm on my own network. Its just not working for anyone else, so its pretty obvious that its most likely a port forwarding issue. I'm running the server from the same machine I'm playing on (i know thats not the best set-up, but i was getting fed up with that ancient piece of 20th century crap in the basement). I have a 2wire 2701HG-B router. what exactly do you need a screenshot of? the user defined definition i have set to or the firewall settings summary page?
Thread Status:
Not open for further replies.

Share This Page