[Newbie] "The import org.bukkit cannot be resolved"

Discussion in 'Plugin Development' started by Toxinist, Dec 4, 2021.

  1. Offline

    Toxinist

    Code:
    package me.Toxinist.ChestsAndCrafting;
    
    import java.util.ArrayList;
    import java.util.Arrays;
    import java.util.List;
    
    import org.bukkit.Bukkit;
    import org.bukkit.Location;
    import org.bukkit.Material;
    import org.bukkit.Sound;
    import org.bukkit.block.Block;
    import org.bukkit.block.BlockState;
    import org.bukkit.block.Chest;
    import org.bukkit.craftbukkit.libs.org.apache.commons.lang3.tuple.Pair;
    import org.bukkit.enchantments.Enchantment;
    import org.bukkit.inventory.Inventory;
    import org.bukkit.inventory.ItemStack;
    import org.bukkit.inventory.meta.EnchantmentStorageMeta;
    import org.bukkit.plugin.Plugin;
    import org.bukkit.plugin.PluginManager;
    import org.bukkit.plugin.java.JavaPlugin;
    The errors are one every line that has "org.bukkit" in it

    Never had this problem before, I believe it started to throw errors when I updated java from version 16 to 17 I'm not sure.

    This happens in every plugin I have, I'm doing things in eclipse, screenshot attached.

    I did plugins for my 1.17 server before and I tried to stay away from methods that were going to get deprecated in the future. They worked fine. Does this mean I can use the plugins I made in 1.18 servers as well?

    upload_2021-12-4_15-42-6.png
     
  2. Offline

    timtower Administrator Administrator Moderator

    @Toxinist Those projects are broken, check your build path
     

Share This Page