New CraftBukkit 1.1 Recommended Build released!

Discussion in 'Bukkit News' started by EvilSeph, Jan 30, 2012.

Thread Status:
Not open for further replies.
  1. Offline

    EvilSeph Retired Staff

    A new CraftBukkit Recommended Build (1.1-R3) that fixes bugs present in either Minecraft 1.1 or our previous Recommended Build is now available.

    Will plugins break with this build?
    Provided the developers of the plugins you are using are keeping up with the development of Bukkit, all your plugins should work fine.

    Important notice for game server providers and other plugins or individuals that are making use of our RB RSS feed:
    We're currently in the process of developing a new download site service to replace the unwieldy Jenkins setup we've been using since the project's inception. See our recent announcement here for more information on this initiative. As a result, anyone making use of our old RB RSS feed will need to update their systems accordingly when we have the new system ready. Until then, we're providing a grace period for people to switch over so consider this a heads up.

    Upgrading to this new Recommended Build is highly recommended as it contains numerous (critical) exploit and bug fixes. For those of you running an older 1.1 Recommended Build, please update immediately as we've addressed issues found in our previous Recommended Builds.

    For more detailed information on what is contained in this update, please see the Recommended Build announcement thread here:
    http://goo.gl/FBWDg

    Download CraftBukkit 1.1-R3 here
     
    Harcken, Cicadia, tombik and 17 others like this.
  2. Offline

    i7vSa7vi7y

    If you think about it, 7v = an italics N. Draw the 7v on paint, but put them really close together. Then tilt your head 45 degrees to the right. If you still don't see it... I don't know what to say...
     
  3. Offline

    fwxbit

    http://imgur.com/zWFuz

    This happened to my on my piston tape.

    The blocks disappear and are replaced with a completely transparent block that can be destroyed but can not be pushed by pistons.

    It seems to happen when the piston tape chunk gets reloaded.

    It's really annoying to have to fix it every time I leave the area, and return.
     
  4. Offline

    TnT Retired Staff

    Make sure you are on 1.1-R3 (build 1846).
     
  5. Offline

    chaseoes Retired Staff

    Apparently 1.1 messed up pistons, I have a different problem relating to how they get powered:
    http://i.imgur.com/4Lgxd.png
    http://i.imgur.com/UkbzL.png
    http://i.imgur.com/BGS60.png
     
  6. Offline

    Iron79

    Nice Work.
     
  7. Offline

    eleljrk

    Well, this is getting ridiculous... I've been waiting in good faith for at least an answer, even believing for a workaround.
    Is there nothing anyone can do?
     
  8. Offline

    Keanulaszlo

    Am I the only one who is having trouble with the download link?
    When I click on it, it says "No Data Received".
     
  9. Offline

    TnT Retired Staff

    Repo is currently down. The team is aware and working on the issue. We will have it back up ASAP! :)
     
  10. Offline

    Keanulaszlo

    Thanks!

    It seems to be back up. That was fast! :D

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 23, 2016
  11. Offline

    romobomo

    eleljrk

    Have you tried:

    Code:java
    1.  
    2. @EventHandler
    3. public void onPlayerInteract(EntityInteractEvent e) {
    4. if(e instanceof PlayerInteractEvent) {
    5. PlayerInteractEvent event = (PlayerInteractEvent) e;
    6. ...
    7. // do stuff with event
    8. }
    9. }
    10.  
     
  12. Offline

    eleljrk

    romobomo

    It doesn't work like that, you can't make a EntityInteractEvent a PlayerInteractEvent.
    I even tried this with a EntityInteractEvent, but EntityInteractEvent don't have the getAction() function which I require for this to work; what I tried was to call a EntityInteractEvent, check if entity was a player, etc etc.. Works until you need event.getAction() which doesn't exist in EntityInteractEvent.

    Besides, I don't even know what EntityInteractEvent really does.. Might be something completely different from PlayerInteractEvent.

    Thanks for your input, but I've tried this before.
     
  13. Offline

    romobomo

    eleljrk

    Quite right, just tested and it does not work. Just figured it might, as this is what I had to do for PlayerDeathEvent. Sorry couldn't help, will look into it.
     
  14. Offline

    Iron79

    nice.. ;)
     
  15. Offline

    Lyude

    Is it me, or do none of the download links in any of wiki articles, or this topic (yes, I have tried all of them) work?
    EDIT: Nevermind, the latest one in the topic does work, however I only seem to be able to download the file via wget. Trying to download it in chrome just puts me back on the directory list page (with no error or anything)
     
  16. Offline

    TnT Retired Staff

    I just quickly went through the links on wiki.bukkit.org with my Chrome browser. Any I tried worked for me. Can you link me to the ones that don't work?
     
  17. Offline

    ozziecraft

    Would be nice if you made the link more "wget" freindly URL's makes more work instead of having to be able to simply wget the file straight to where we need it instead of having to go the long way round to do the same thing.
     
  18. Offline

    ZachBora

  19. Offline

    TnT Retired Staff

    I think he's referring to how:
    Code:
    wget http://repo.bukkit.org/service/local/artifact/maven/redirect?g=org.bukkit&a=craftbukkit&v=RELEASE&r=releases
    
    Doesn't work. Perhaps he doesn't know that this works perfectly fine?
    Code:
    wget 'http://repo.bukkit.org/service/local/artifact/maven/redirect?g=org.bukkit&a=craftbukkit&v=RELEASE&r=releases' -O craftbukkit.jar
    
     
  20. Offline

    ZachBora

    PlayerInteractEvent inherits from PlayerEvent, not EntityInteractEvent.
     
  21. Offline

    keaft

  22. Offline

    gomme600

    Hi what happend to the plugins list ??? Its empty !!! ( Sorry i know this is the wrong place but i dont know where to post this )
     
  23. Offline

    TnT Retired Staff

    plugins.bukkit.org works. Please refresh your browser.
    plugins.bukkit.org/curseforge is being worked on. We hope it have it back up ASAP!
     
  24. Offline

    Arin

    well my houses are commiting suiside so...
     
  25. Offline

    EvilSeph Retired Staff

    plugins.bukkit.org/curseforge is now back up!
     
    TnT likes this.
  26. Offline

    Fire_Head431

  27. Offline

    Taien

    The problem here, as someone else said shortly after you posted, is not the InvocationTargetException, but the ArrayIndexOutOfBoundsException. Now you cut off your copy right before the line number...but I looked in your code there, and I see what I think is the problem. This line:

    Code:
     if (this.plugin.getCreation(event.getPlayer()) == null) { this.plugin.getCreations().add(new Creation(this.plugin, this.plugin.getProperties().get(this.plugin.getProperties().size()-1).getID()+1, event.getPlayer())); }
    This line would throw an exception like the one you pasted if the array had zero properties in it, because you're trying to get index -1, which doesn't exist. (Understand? The this.plugin.getProperties().size() = 0, and you are subtracting 1 from that.) So throw in a line with something like this:

    if (this.plugin.getProperties().size() > 0) blah blah blah

    Hope this helps
     
    eleljrk likes this.
  28. Offline

    eleljrk

    Thank you for solving the issue.
    However, it's my fault I haven't updated my status on this thread, because I did fix this some days back. My apologizes, but thank you. It's great to see someone who care around here.

    So, yeah.. Sorry.
     
  29. Offline

    EvilSeph Retired Staff

    He didn't cut off the stacktrace - that's how far it got. As a result, we've been working on improving the stacktraces to track down the actual cause of this issue but I have also got other things on my plate, so it is taking longer than I hoped.

    Glad you solved the issue. We've been looking into possible bugs with the event system but thankfully it seems that it isn't the case.
     
    eleljrk likes this.
Thread Status:
Not open for further replies.

Share This Page