My survival world isn't survival

Discussion in 'Bukkit Help' started by phsikotic, Oct 18, 2019.

  1. Offline

    phsikotic

    I have a lobby type set up with a few portals that go to different multiverse worlds

    The survival world is not working properly.. No mobs are spawning, players regen health super fast and hunger is not an issue. The other worlds seem to toggle between creative and adventure mode (in the lobby) fine. Also have a few command signs that go to bed wars and pvp, they work OK though commandsigns tend to vanish, players have no trouble switching between modes.

    I dont know when this started happening, but it was working fine previously.

    I have tried setting game mode to survival using /mvm set mode survival while in the world and /mvm set mode survival (world), I tried /ungod.. if i manually set a player to survival mode its the same thing.

    I removed worldguard and pvparena mod entirely, figured these were the most likely culprits..


    I noticed i can toggle myself to creative with /mvm set just fine... if i set it back to survival i am back to the broken state


    Tried manually setting the gamerule for domobspawning and mobs still dont spawn.

    Researched this a bit and not finding much out there.. any ideas what I should do?


    Don't see any errors in the startup for the mods

    Mod list:
    CleanroomGenerator, WorldEdit, HolographicDisplays, LaggRemover, WorldGuard, PermissionsBukkit, SpawnerSilk, ChatFeelings, Vault, MysteryBags, Essentials, PlotSquared, Multiverse-Core, EssentialsXMPP, Shopkeepers, IslandWorld, EssentialsProtect, Multiverse-Inventories, EssentialsChat, EssentialsGeoIP, PhatLoots, EssentialsAntiBuild, Multiverse-Portals, IslandWorldChallenges, EssentialsSpawn, IslandWorldHeadRank, AntiXRay, BedWars, CommandSigns, VoidSpawn
     
  2. Offline

    DerDonut

    Have you tried Multiverse Modify Command? (Not just game mode but also difficulty, monsters etc)
    Another way would be to change the values in the config file.
     
  3. Offline

    phsikotic

    thank you - I didnt notice there was a mvm set command for difficulty... setting it to normal/hard fixed this!
     

Share This Page