Solved My start_server.command file says I Dont Have the appropriate access privileges!!!

Discussion in 'Bukkit Help' started by cray_Z, Dec 21, 2011.

Thread Status:
Not open for further replies.
  1. Offline

    cray_Z

    Hi Bukkit,
    I was recently trying to update my server to 1.0.1 and I get so far as where the line/bold/underline is: When I do that and save the file into my CraftBukkit folder, i double click to run it. Then a little window pops up and says: It could not execute the file because i didn't have the appropriate access privileges. By the way im on a mac(if u havent noticed).
    PLZ help!!!

    thanks-
    cray_z

    Mac OS X

    1. Install Java
      Since OS X 10.7 Java does not come packaged with OS X. You will need to install java from the Apple's website http://support.apple.com/kb/DL1421
    2. Obtaining the Server Files
      To run a server you will need the server jars, i.e. the server files. We will need a place to put the files.
      1. Create a New Folder
        Open up finder, and create a new folder in your Home folder named CraftBukkit
      2. Download the File
        Download the server files. You can download the latest builds from the front page of the wiki.
        Note: Download the stable build if you are not chasing the cutting edge in the development build
      3. Move the File
        Move the file from the Downloads folder to the CraftBukkit folder you created.
      4. Rename the File
        We will rename it craftbukkit.jar
    3. Obtaining startup script
      To easily start the server you will need a startup script. The following is a basic server script to start your server.
      1. Open up TextEdit and past the following in
        1. #!/bin/bash
          cd "$( dirname "$0" )"
          java -server -Xmx2G -jar ./craftbukkit.jar
      2. Save the file
      3. -------------------Save it in your CraftBukkit folder as start_server.command---------------------------
      4. Allow the script to run
        1. Open up Terminal.app
        2. Type into Terminal.app
          chmod +x
        3. drag the start_server.command into Terminal.app
        4. hit return
    4. Starting the server
      From this point on you can start the server by double-clicking start_server.command.
      You will need to run the server once for it to generate some configuration files.
      [​IMG] Warning:To stop the server, do not press the red x instead type stop into the server.
     
  2. Offline

    TnT Retired Staff

    Did you forget to do the step right under the bold/highlighted line? That step is what should give you the permissions required to run the file.
     
  3. Offline

    ShootToMaim

    Make sure you're an admin, and not just a user.
     
  4. Offline

    cray_Z

    no, i did that

    i am an admin it says:
    The file "start_server.command" could not be executed because you do not have appropriate access privileges

    To view or change access privileges, select the file in the Finder and choose File > get info.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 22, 2016
  5. Offline

    ShootToMaim

    Run it as an admin.
     
  6. Offline

    cray_Z

    how? im not too good with computers
     
  7. Offline

    Nuinbot

    Right-click -> Run as administrator
     
  8. Offline

    cray_Z

    are you sure thhis is for a mac? i cant seem to do that

    this is wat happens when i try to do the alterate method:
    Bukkit Server bennettnolan$ curl -O http://ci.bukkit.org/job/dev-CraftB...rtifact/target/craftbukkit-0.0.1-SNAPSHOT.jar
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    100 1026 100 1026 0 0 4418 0 --:--:-- --:--:-- --:--:-- 9500
    MacBook-Pro:Bukkit Server bennettnolan$ mv craftbukkit-0.0.1-SNAPSHOT.jar CraftBukkit.jar
    Anitas-MacBook-Pro:Bukkit Server bennettnolan$ echo "cd ~/Desktop/Bukkit\ Server> java -Xincgc -Xmx[RAM]M -jar CraftBukkit.jar" >LaunchServer.command
    [1] 472
    cd ~/Desktop/Bukkit\ Server
    java -Xincgc -Xmx[RAM]M -jar CraftBukkit.jar
    -bash: gt: command not found
    [1]+ Done echo "cd ~/Desktop/Bukkit\ Server
    java -Xincgc -Xmx[RAM]M -jar CraftBukkit.jar"
    -bash: LaunchServer.command: command not found
    MacBook-Pro:Bukkit Server bennettnolan$ chmod +x LaunchServer.command
    chmod: LaunchServer.command: No such file or directory
    MacBook-Pro:Bukkit Server bennettnolan$ echo "Open LaunchServer.command with TextEdit, and replace [RAM] with:
    > 512 or 1024 or 1536 or 2560 or 3072 or 5120
    > That is the ram amount the server will have.
    > 512=512MB; 1024=1GB; 1536=1.5GB; 2560=2.5GB; 3072=3GB; 5120=5GB
    > It is good to update your server at least once per week." >README.txt
    [1] 476
    Open LaunchServer.command with TextEdit, and replace [RAM] with:
    512 or 1024 or 1536 or 2560 or 3072 or 5120
    That is the ram amount the server will have.
    512=512MB; 1024=1GB; 1536=1.5GB; 2560=2.5GB; 3072=3GB; 5120=5GB
    It is good to update your server at least once per week.
    -bash: gt: command not found
    [1]+ Done echo "Open LaunchServer.command with TextEdit, and replace [RAM] with:
    512 or 1024 or 1536 or 2560 or 3072 or 5120
    That is the ram amount the server will have.
    512=512MB; 1024=1GB; 1536=1.5GB; 2560=2.5GB; 3072=3GB; 5120=5GB
    It is good to update your server at least once per week."
    -bash: README.txt: command not found
    MacBook-Pro:Bukkit Server bennettnolan$ open -a TextEdit LaunchServer.command
    The file /Users/bennettnolan/Desktop/Bukkit Server/LaunchServer.command does not exist.
    MacBook-Pro:Bukkit Server bennettnolan$

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 22, 2016
  9. Offline

    Nuinbot

    Ahhh, my bad. Yeah, that is for Windows.

    Also, just curious: Why are you running on a laptop? If you are hosting a server for others, I would suggest getting a bare-bones system that has decent speed and memory and start an Ubuntu server. Easy to maintain and a lot less overhead. It has done wonders for me and my friends on my private server.
     
    ShootToMaim likes this.
  10. Offline

    hammale

    just open up a terminal, cd to the directory of the startup script and do
    Code:
    sudo ./SCRIPTNAME.sh
    thats how i'd do it in linux which is pretty much osx :D
     
  11. Offline

    cray_Z

    yes im on a laptop ty

    so far ive done that, and it says type your password, terminal wont me type

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 22, 2016
  12. Offline

    hammale

    lol its typing its just invisable so people dont see ur password :D
     
  13. Offline

    pseudonym813

    Hi,

    When I type in:

    sudo ./server_start.command.sh

    terminal outputs:

    sudo: ./server_start.command.sh: command not found

    Thanks for anyone's help.:)
     
  14. Offline

    Hero683752

    When I do it it says:
    cHolden:~ holdengude$ chmod +x/Users/holdengude/Desktop/CraftBukkit/start_servercommand
    usage:chmod [-fhv] [-R [-H | -L | -P]] [-a | +a | =a [# [ n]]] mode|entry file ...
    chmod [-fhv] [-R [-H | -L | -P]] [-E | -C | -N | -i | -I] file ...
    Holden:~ holdengude$
     
  15. Offline

    Manwholikespie

    alright. I have been having this same problem lately... It works fine on the other mac I have, but it wont work on my dads. We have different user accounts on this, and I believe you need to be the original user/grandadmin to run it. However, terminal uses this special term called, "bash". What you want to do, and I know you may be too lazy to do this at time, is open terminal when you want to start your server, and type in "bash " (use the space) and then drag in your start_server.command. Then hit RETURN or ENTER to let the code do its pretty thang. You are welcome. If you find a way to run it just by double clicking, TELL ME AT ONCE.
     
    Zapperier likes this.
  16. Offline

    Danimal

    To get the proper privledges to launch the Craftbukkit.jar you must name the start file (Start.command)
     
  17. Offline

    cray_Z

    I fixed that... This post was in 2011!
     
  18. Offline

    Enderman789

    ok, i am having the exact same problem as he is, and none of these solutions are working. sorry to bump the topic if you all of you are irritated by that, but i don't like being told by a dumb computer that all my work is for nothing.
     
  19. Offline

    Zapperier

    Don't you all just hate how stuff always is so complicated for macs? They're great otherwise, but this is so annoying.
     
  20. Offline

    sscoop3

    It has said to go to the info and I did do that but I dont know how to change my privileges, Im on the administrator account so I am able to change the settings, I am on a computer and not a laptop This server is 1.4.7 that I am trying to run I have even looked at tutorials but its the same thing, vanilla works for me but I want pluggins
     
  21. Offline

    thefinalosx

    Hey guys, sorry to bump this topic again, but when I used the command
    bash (drag in start_server.command)
    it said that it was unable to access craftbukkit.jar
    Someone please help D:
     

    Attached Files:

Thread Status:
Not open for further replies.

Share This Page