My Server Won't Work (Need someone to test)

Discussion in 'Bukkit Help' started by MegaNarwhal, Apr 1, 2012.

Thread Status:
Not open for further replies.
  1. Offline


    Ok, so I just got Minecraft and Bukkit and I've been trying to set up a server. I'm running Bukkit 1.2.4 R1.0, and this is what I get when I run it:

    Show Spoiler

    182 recipes
    27 achievements
    18:22:53 [INFO] Starting minecraft server version 1.2.4
    18:22:53 [INFO] Loading properties
    18:22:53 [INFO] Starting Minecraft server on *:25565
    18:22:53 [INFO] This server is running CraftBukkit version git-Bukkit-1.2.4-R1.0
    -b2126jnks (MC: 1.2.4) (Implementing API version 1.2.4-R1.0)
    18:22:54 [INFO] [AdminCmd] Loading AdminCmd v5.12 (BUILD 01.03.2012 @ 20:13:36)
    18:22:54 [INFO] Preparing level "world"
    18:22:54 [INFO] Default game type: 0
    18:22:54 [INFO] Preparing start region for level 0 (Seed: -8138132877135983381)
    18:22:55 [INFO] Preparing spawn area: 52%
    18:22:55 [INFO] Preparing start region for level 1 (Seed: -8138132877135983381)
    18:22:56 [INFO] Preparing spawn area: 24%
    18:22:57 [INFO] Preparing spawn area: 85%
    18:22:57 [INFO] Preparing start region for level 2 (Seed: -8138132877135983381)
    18:22:57 [INFO] [AdminCmd] Enabling AdminCmd v5.12 (BUILD 01.03.2012 @ 20:13:36)

    18:22:57 [INFO] [AdminCmd] Plugin Enabled. (version 5.12 (BUILD 01.03.2012 @ 20:
    18:22:58 [INFO] [AdminCmd] motd.txt loaded
    18:22:58 [INFO] [AdminCmd] motdNewUser.txt loaded
    18:22:58 [INFO] [AdminCmd] news.txt loaded
    18:22:58 [INFO] [AdminCmd] rules.txt loaded
    18:22:59 [INFO] Server permissions file permissions.yml is empty, ignoring it
    18:22:59 [INFO] Done (5.082s)! For help, type "help" or "?"

    The ip in the is blank. I've tried another port and I'm pretty sure I have port forwarding set up correctly (Belkin, TCP and UDP, inbound and private ports 25565, private IP is correct). I'm running Norton Antivirus and set it to allow incoming and outgoing for remote and local port 25565, and Comcast is my ISP. I'm pretty sure I have EVERYTHING set up correctly yet it doesn't work. :mad: I realllllllly want to set up a server for me and my friends to play on, so any help would be greatly appreciated. :)

    Here's a link to the server's folder (I didn't include the worlds):

    And yes, I read the common problems thread.
  2. Offline


    So whats the problem?
    Your friends aren't able to connect?
  3. Offline


    Yes. I am able to connect and play it, but nobody else can. says that the connection timed out for every port I've typed into it.
  4. Offline


    I don't think it's Comcast because my friend who owns a server has Comcast and his server works just fine.
  5. Offline


    Your server is running on port 25565.

    You sure you have port forwarded that correctly ?

    May I ask how your friends connect ? and with what IP do your friends try to connect with ?
  6. Offline


    My friends (try to) connect with my public IP that I directly copied from
  7. Offline


    What's weird is that no port I've tried on actually works...
  8. Offline


    Sorry for triple posting, but I really want to know if anyone has had this problem or has any ideas on how to fix it.
  9. Offline


    I have comcast too and what I didn't see specified in the OP is that you may not have setup a static IP address yet. I had to setup a static IP address for it to work, otherwise comcast will normally assign you a different IP address each time you run it, which would cause you to be able to connect when connecting to "localhost" but the IP changing each time for your friends to do it.
  10. Offline


    Are you sure that you have forwarded to the port 25565?
  11. Offline



    hurraylifesucks: Does a static IP cause any security vulnerabilities?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
  12. Offline


    I did a little research and I made a static IP. Please try connecting to my server at:
    Hope it works :oops:

    For some reason in the cmd window it keeps saying "[WARNING] Can't keep up! Did the system time change, or is the server overloaded?" when I'm on the server.
  13. Offline


    Do you see this little 'Edit' button below your posts? ;)
  14. Offline


    No, but I see it above yours. [creeper]
    Anyway, can someone try connecting to my server to see if the static IP did any good?
  15. Offline


    I tryed connecting. No luck
  16. Offline


    Crap. Do I need to set the IP from the router settings or can I do what I did which was go into the adapter settings and change the DNS and IP from there?
  17. Offline


    I dont think you need to change that. But I am having the same problem with verizon/apple airport extreme
  18. Offline


    I'm going to set up port forwarding for my other router to see if that helps.

    Ok, try my server now.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 25, 2016
Thread Status:
Not open for further replies.

Share This Page