My Minecraft server won't allow me to connect to it.

Discussion in 'Bukkit Help' started by Bke413, Mar 29, 2013.

Thread Status:
Not open for further replies.
  1. Offline


    I have watched youtube videos on how to create a craftbukkit server for minecraft and I thought I had everything running like it should except it won't let me access my server. I've tried localhost and 25565 and my internal IP none of them work. Can anyone please help me. This is my command prompt that opens when I double click run.bat -
    210 recipes
    27 achievements
    21:41:30 [INFO] Starting minecraft server version 1.4.7
    >21:41:30 [INFO] Loading properties
    21:41:30 [INFO] Default game type: CREATIVE
    21:41:30 [INFO] Generating keypair
    21:41:31 [INFO] Starting Minecraft server on *:25565
    21:41:31 [INFO] This server is running CraftBukkit version git-Bukkit-1.4.7-R1.0
    -b2624jnks (MC: 1.4.7) (Implementing API version 1.4.7-R1.0)
    21:41:32 [INFO] [WorldEdit] Loading WorldEdit v5.5.5
    21:41:32 [INFO] [LevelCraftReborn] Loading LevelCraftReborn v1.003
    21:41:32 [INFO] [Essentials] Loading Essentials v2.10.1
    21:41:32 [INFO] [EssentialsChat] Loading EssentialsChat v2.10.1
    21:41:32 [INFO] [EssentialsProtect] Loading EssentialsProtect v2.10.1
    21:41:32 [INFO] MLog clients using java 1.4+ standard logging.
    21:41:32 [INFO] [EssentialsSpawn] Loading EssentialsSpawn v2.10.1
    21:41:32 [INFO] [EssentialsAntiBuild] Loading EssentialsAntiBuild v2.10.1
    21:41:32 [INFO] Preparing level "world"
    21:41:32 [INFO] Preparing start region for level 0 (Seed: -4206708450014726138)
    21:41:33 [INFO] Preparing spawn area: 69%
    21:41:34 [INFO] Preparing start region for level 1 (Seed: -4206708450014726138)
    21:41:34 [INFO] Preparing spawn area: 52%
    21:41:35 [INFO] Preparing start region for level 2 (Seed: -4206708450014726138)
    21:41:35 [INFO] Preparing spawn area: 77%
    21:41:35 [INFO] [WorldEdit] Enabling WorldEdit v5.5.5
    21:41:36 [INFO] WEPIF: Using the Bukkit Permissions API.
    21:41:36 [INFO] [LevelCraftReborn] Enabling LevelCraftReborn v1.003
    21:41:36 [INFO] [LCR] All LevelPacks loaded. Active Packs: []
    21:41:36 [INFO] LevelCraftReborn has been enabled.
    21:41:36 [INFO] [Essentials] Enabling Essentials v2.10.1
    21:41:37 [INFO] Essentials: Using config file enhanced permissions.
    21:41:37 [INFO] Permissions listed in as player-commands will be given to all us
    21:41:37 [INFO] [EssentialsChat] Enabling EssentialsChat v2.10.1
    21:41:37 [INFO] [EssentialsProtect] Enabling EssentialsProtect v2.10.1
    21:41:37 [INFO] Initializing c3p0- [built 21-May-2007 15:04:56; debug? tr
    ue; trace: 10]
    21:41:37 [INFO] [EssentialsSpawn] Enabling EssentialsSpawn v2.10.1
    21:41:37 [INFO] [EssentialsAntiBuild] Enabling EssentialsAntiBuild v2.10.1
    21:41:37 [INFO] Server permissions file permissions.yml is empty, ignoring it
    21:41:37 [INFO] Done (5.412s)! For help, type "help" or "?"
  2. Offline


    Go to: and join the server with the IP listed on that site. If that doesn't work then it might be a antivirus or firewall issue.
  3. Offline


    Personally i think you should have to pass a basic troubleshooting rest before you can download Bukkit >_>
  4. Offline


    I have already tried this and my other Ips none of them work but thank you for the suggestion I'll check my firewall.
  5. Offline


    I have a vanilla minecraft server (1.5.1) running on Ubuntu 12.04 server that runs flawlessly. I have a newly installed craftbukkit server (1.4.7) on the same server in a different directory. When I start the craftbukkit server it appears to startup with no problems (no errors) yet it is not accessible from either the internal or public ip. Port 25565 is properly forwarded, Windows firewall is turned off, ip's are correct and I am not trying to run both servers at the same time. Copy of fresh server log file:
    2013-03-30 20:06:12 [INFO] Starting minecraft server version 1.4.7
    2013-03-30 20:06:12 [INFO] Loading properties
    2013-03-30 20:06:12 [INFO] Default game type: SURVIVAL
    2013-03-30 20:06:12 [INFO] Generating keypair
    2013-03-30 20:06:12 [INFO] Starting Minecraft server on *:25565
    2013-03-30 20:06:12 [INFO] This server is running CraftBukkit version git-Bukki$
    2013-03-30 20:06:12 [INFO] Preparing level "world"
    2013-03-30 20:06:13 [INFO] Preparing start region for level 0 (Seed: 9029492834$
    2013-03-30 20:06:13 [INFO] Preparing start region for level 1 (Seed: 9029492834$
    2013-03-30 20:06:14 [INFO] Preparing spawn area: 52%
    2013-03-30 20:06:14 [INFO] Preparing start region for level 2 (Seed: 9029492834$
    2013-03-30 20:06:14 [INFO] Server permissions file permissions.yml is empty, ig$
    2013-03-30 20:06:14 [INFO] Done (1.501s)! For help, type "help" or "?"
    2013-03-30 20:07:07 [INFO] CONSOLE: Stopping the server..^[[m
    2013-03-30 20:07:07 [INFO] Stopping server
    2013-03-30 20:07:07 [INFO] Saving players
    2013-03-30 20:07:07 [WARNING] DSCT: Socket closed
    2013-03-30 20:07:07 [INFO] Saving worlds
    O.K. Whats wrong here and why is it that my vanilla server works fine and the craftbukkit won't work at all? I do have anit-virus/malware running but I am hesitant to poke any holes in my protection especialy given the number that I have encountered on the various minecraft forums and sites. Any help that you could provide would be greatly appreciated.
  6. Offline


    Do you have a copy of the 1.4.7 client on your computer? A 1.5 client won't be able to connect to a 1.4.7 server.
  7. Offline


    That seems a little goofy since the revs are not that far apart, but I suspected that might be the problem. Thanks for the confirmation. So is there a craftbukkit 1.5 server available that would be compatabile with a 1.5 client? We seem to be able to connect to other modded servers out there that I suspect are Bukkit servers since I have heard it is the most popular. I downloaded what I thought was the latest rev with the Linux wget at url command. What url provides a 1.5 version if said version is available? I don't think we will be rolling back our minecraft client to 1.4.7.
    Also, is there a craftbukkit client that is required to be used with craftbukkit server? I was under the impression that the standard minecraft client (purchased game) would be compatible with craftbukkit. Is there a 1.5 compatible server in the works maybe to be available soon? Thanks for the help, and again, any help is greatly appreciated.

    Thanks for the mental prod. I figured out how to get the 1.5 craftbukkit server url.
    It is just a dev build at this point so there may be some bugs, but we will see how it goes. I can connect to it with my 1.5 client now.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 31, 2016
  8. Offline


    Yes there is a bukkit server 1.5 it is the development version Just type bukkit 1.5 in google and you should be able to download it. I had this exact problem.
  9. Offline


    Hello everbody,

    I made a 1.5.1 bukkit server and everything works but when I connect whit my sever it says it's a 1.4.7 server.
    I need help whit this problem.
    Does anyone now how to fix it?
  10. Offline


    Ok here's to everyone. When you start a new server run off your own computer you have to either port forward or use hamachi. You also need to set the ip the server is running on this can be done in Starting Minecraft server on ip:25565 the server properties file.
  11. Offline


    You have to portforward. Then go to to see your IP. If it doesn't works then go to and type this port: 25565! :)
Thread Status:
Not open for further replies.

Share This Page