[MISC] Sleep v7.0.0 - Multi-Player Sleep Management (Idle, Notifications, Force) [1.5.1]

Discussion in 'Archived: Plugin Releases' started by EdGruberman, Apr 26, 2011.

  1. Offline

    EdGruberman Retired Staff

    harakiwi, Glaze, Frogging101 and 2 others like this.
  2. Offline

    ssechaud

    Thanks, will give it a try tonight, you are EPIC!
     
  3. Offline

    ssechaud

    I don't know why, but sometimes we have problems where it won't force sleep and turn to day. It's strange because we have it setup and working fine, its just seems like an intermittent problem where it just sits there and does nothing. No error message in the console log or nothing to indicate what's going wrong. Any ideas on how we could track down what the problem is?
     
  4. Offline

    EdGruberman Retired Staff

    Create a /plugins/Sleep/MessageManager.yml text file and put the following in it:
    Code:
    send:
        PLAYER:
            level: ALL
        SERVER:
            level: ALL
        WORLD:
            level: ALL
        LOG:
            level: ALL
    That will show you all the debug information available. Your server log should contain a record of who is doing what and how the plugin is interpreting it all. If you can get me your log file output when the problem occurs with the debug information I can help decipher it all.

    What is your /plugins/Sleep/config.yml file? Do you use any world specific files? If so, what are those?

    Also what plugins are you running along with Sleep?
     
  5. Offline

    ssechaud

    I will setup the debug logs and get back to you on that. In the meantime here is a list of the plugins we are using:

    Appletree, AutoReplace, Backup, BananaChunk, ChopTree, CraftBukkitUpToDate, DelayedStop, DropBlock, Dynmap,
    Essentials, iChat, ItemID, LWC, HawkEye, Help, LagMeter, MagicCarpet, MinecartMania, Minequery, MobileAdmin, Nethrar, NoSpeedKick, OKReload, PermissionsBukkit, Ptweaks, SafeStop, ServerLogSaver, ServerUsage, SimpleCronClone, Sleep, Sleep-MessageManager, Stackable, Stargate, Stargate-DHD, VoxelAir, War, WeatherControl, Whitelist, WorldEdit, WorldGuard

    The only one I think would have an impact on Sleep is Essentials, and am sure I have made sure that it's options are turned off, and Sleep does work, it's just from time to time we get problems with it. I will take a log with the debug stuff you mentioned and post back with more useful information.

    And here is our Sleep config.yml:

    Code:
    inactivityLimit: 300
    safe: true
    force:
        count: 2
        percent: 50
    notifications:
        ENTER_BED:
            format: '%1$s went to bed.'
            maxFrequency: 10
            timestamp: true
        LEAVE_BED:
            format: '%1$s has got out of bed.'
            maxFrequency: 10
            timestamp: true
        NIGHTMARE:
            format: '%1$s is having a nightmare.'
            maxFrequency: 10
            timestamp: true
        FORCE_SLEEP:
            format: '%1$s is forcing sleep.'
            maxFrequency: 10
            timestamp: true
        FORCE_SAFE:
            format: '%1$s has forced safe sleep.'
            maxFrequency: 10
            timestamp: true
    activity:
        - PLAYER_MOVE
        - PLAYER_CHAT
        - PLAYER_INTERACT
        - PLAYER_DROP_ITEM
        - PLAYER_TOGGLE_SNEAK
        - PLAYER_ITEM_HELD
        - PLAYER_JOIN
    
    Thanks for the help and your time.
     
  6. Offline

    ssechaud

    We changed our config to this to test it out and had the problem, it seems it treats "-1" as force percent it checks for 100%.

    Config
    Code:
    inactivityLimit: 300
    safe: true
    force:
        count: 1
        percent: -1
    notifications:
        ENTER_BED:
            format: '%1$s went to bed.'
            maxFrequency: 10
            timestamp: true
        LEAVE_BED:
            format: '%1$s has got out of bed.'
            maxFrequency: 10
            timestamp: true
        NIGHTMARE:
            format: '%1$s is having a nightmare.'
            maxFrequency: 10
            timestamp: true
        FORCE_SLEEP:
            format: '%1$s is forcing sleep.'
            maxFrequency: 10
            timestamp: true
        FORCE_SAFE:
            format: '%1$s has forced safe sleep.'
            maxFrequency: 10
            timestamp: true
    activity:
        - PLAYER_MOVE
        - PLAYER_CHAT
        - PLAYER_INTERACT
        - PLAYER_DROP_ITEM
        - PLAYER_TOGGLE_SNEAK
        - PLAYER_ITEM_HELD
        - PLAYER_JOIN
    
    Debug Log:
    Code:
    >18:00:25 [INFO] CurlyJ [/84.9.247.180:49497] logged in with entity id 434 at ([world] 341.9375, 66.0, 2451.6875)
     >18:00:25 [FINE] §0[Sleep] Activity detected for CurlyJ (Event: PLAYER_JOIN)
     >18:00:25 [FINE] §0[Sleep] Setting CurlyJ in [world] to not ignore sleep. (Monitored Activity)
     >18:00:37 [INFO] millgid [/84.9.247.180:51503] logged in with entity id 993 at ([world] 701.3828786699944, 63.0, 1820.2511088103956)
     >18:00:37 [FINE] §0[Sleep] Activity detected for millgid (Event: PLAYER_JOIN)
     >18:00:37 [FINE] §0[Sleep] Setting millgid in [world] to not ignore sleep. (Monitored Activity)
     >18:08:12 [FINE] §0[Sleep] millgid entered bed in [world]
     >18:08:12 [EVENT] §8[Sleep] [WORLD] §8[world] §cmillgid§f went to bed.
     >18:08:12 [FINE] §0[Sleep] [world] Sleep needs no more; 1 in bed (need 1) out of 2 possible = 50% (need 100%)
     >18:08:16 [FINE] §0[Sleep] millgid left bed in [world]
     >18:08:16 [EVENT] §8[Sleep] [WORLD] §8[world] §cmillgid§f has got out of bed.
     >18:08:19 [FINE] §0[Sleep] millgid entered bed in [world]
     >18:08:19 [FINE] §0[Sleep] [world] Sleep needs no more; 1 in bed (need 1) out of 2 possible = 50% (need 100%)
     >18:08:55 [FINE] §0[Sleep] millgid left bed in [world]
     >18:08:55 [EVENT] §8[Sleep] [WORLD] §8[world] §cmillgid§f has got out of bed.
     >18:09:05 [FINE] §0[Sleep] millgid entered bed in [world]
     >18:09:05 [EVENT] §8[Sleep] [WORLD] §8[world] §cmillgid§f went to bed.
     >18:09:05 [FINE] §0[Sleep] [world] Sleep needs no more; 1 in bed (need 1) out of 2 possible = 50% (need 100%)
     >18:09:13 [FINE] §0[Sleep] CurlyJ entered bed in [world]
     >18:09:13 [EVENT] §8[Sleep] [WORLD] §8[world] §cCurlyJ§f went to bed.
     >18:09:13 [FINE] §0[Sleep] [world] Sleep needs no more; 2 in bed (need 1) out of 2 possible = 100% (need 100%
     >18:09:18 [FINE] §0[Sleep] CurlyJ left bed in [world]
     >18:09:18 [FINE] §0[Sleep] millgid left bed in [world]
    
     
  7. Offline

    EdGruberman Retired Staff

    @ssechaud - This is really great information, Thank you!

    I've updated the beta once again. You can get 3.1.0b3 now at the same location as before: https://github.com/EdGruberman/Sleep/raw/master/dist/Sleep.jar

    I hopefully fixed the problem you identified and I've also now updated the plugin to use the new Bukkit configuration classes (which should make it fully compatible now with the latest RB 1337.) Theoretically this change means nothing to anyone using the plugin other than full compatibility with the latest RB. You shouldn't have to change anything in your configuration file as a result.

    The changelog so far is:
    CHG: Added feature to disable sleep but still allow bed usage to set new spawn location
    CHG: Added ability to specify always safe sleep or not
    CHG: Split force sleep notifications to clarify configuration or player caused
    CHG: Added /sleep force safe now immediate command
    CHG: Default inactivity threshold set to 60 seconds
    CHG: Added %4$d parameter for total players possible to notifications
    FIX: FORCE_SAFE notification not displaying with default configuration
    FIX: Forcing safe sleep without at least 1 player in bed
    FIX: Code clean-up and organization
    CHG: Force count and force percent used together will force if either requirement is met.
    CHG: Force count and force percent used together will force if either requirement is met.
    CHG: Updated configuration file management classes to avoid deprecated methods
    FIX: Safe sleep not forced as expected sometimes


    I'm really trying to find time to test this myself, but that may not happen until this weekend/next week at the rate I'm going in my personal life. So again, if you are adventurous and willing to help out, please take a stab at it again if you can! Thank you!

    I found a few bugs just now related to the new configuration file code.

    It's 3.1.0b6 that's available on github now. https://github.com/EdGruberman/Sleep/raw/master/dist/Sleep.jar

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 14, 2016
    ssechaud likes this.
  8. Offline

    ssechaud

    Hi again, we have been using 3.1.0b6 for a few days now and we are having problems where some players go to bed, and it doesn't force sleep. Instead the players seem stuck in bed, and can't get out at all and have to restart their client to continue playing. I don't see anything in the log about it, just the exit message getting spammed:

    Code:
    2011-10-30 01:19:55§0[Sleep] CurlyJ entered bed in [world]
    2011-10-30 01:19:55§8[Sleep] [WORLD] §8[world] §cCurlyJ§f went to bed.
    2011-10-30 01:19:55§0[Sleep] [world] Sleep needs no more; 1 in bed (forced when 1) out of 2 possible = 50%
    2011-10-30 01:20:03 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?
    2011-10-30 01:20:04§0[Sleep] Forcing safe sleep in [world]...
    2011-10-30 01:20:04§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:11§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:31§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:33§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:34§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:34§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:34§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:34§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:34§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:35§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:35§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:35§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:37§0[Sleep] CurlyJ left bed in [world]
    2011-10-30 01:20:37§0[Sleep] CurlyJ left bed in [world]
    
     
  9. Offline

    EdGruberman Retired Staff

    @ssechaud - This is most likely a conflict/bug in either CraftBukkit or some other plugin you are using. Nothing in the Sleep plugin itself should force a user to be unable to leave bed. In fact, I'm not even sure that is possible as the leave bed event is not able to be cancelled.

    What other plugins are you running?

    @Silentspy had a similar problem a bit back on an older version, but I think he found it went away when he tested without any other plugins. I wonder if he ever isolated the specific problem in his case?
     
  10. Offline

    ssechaud

  11. Offline

    EdGruberman Retired Staff

    Do the players where the problem happens with run any client side modifications? Is it a consistent problem with those same players?

    Essentials has some sleep functions. Do you grant the essentials.sleepingignored to anyone? Not sure impact that will have and it might conflict depending on the settings.

    How many worlds do you have? Do you have a few custom nether realms? Nethrar and Stargate could enable such and that might add some complexity... if you do, can you clarify your world setup? Maybe I can duplicate locally and test myself to find the problem.

    Lastly, is it possible for you to test with only Sleep and MessageManager running temporarily to see if the issue still manifests itself?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 14, 2016
  12. Offline

    oystub

    Download link is down as of 9th of nov. :'( Looks like a great plugin though.
     
  13. Offline

    EdGruberman Retired Staff

    @oystub - Sorry about the outage. My server is currently down (might be another day or so also...) and I haven't fully migrated to dev.bukkit.org yet.

    Please feel free to try the current beta out at: https://github.com/EdGruberman/Sleep/raw/master/dist/Sleep.jar

    I'm about one step away from making it official anyways and it should work with the latest RB 1337.
     
  14. Offline

    EdGruberman Retired Staff

    I've officially released 3.1.0 now.

    Changelog is:
    Version 3.1.0 (2011/11/18) [ Download | Source ]
    • CHG: Default inactivity threshold set to 60 seconds
    • CHG: Force count and force percent used together will force if either requirement is met.
    • CHG: Split force sleep notifications to clarify configuration or player caused
    • CHG: World specific configuration file now at /plugins/Sleep/Worlds/<WorldName>/config.yml
    • CHG: Added /sleep force safe now immediate command
    • CHG: Added ability to monitor custom events for idle activity determination
    • CHG: Added feature to disable sleep but still allow bed usage to set new spawn location
    • CHG: Added ability to specify always safe sleep or not
    • CHG: Updated configuration file management classes to avoid deprecated methods
    • CHG: Added %4$d parameter for total players possible to notifications
    • FIX: Various NPEs for missing configuration files
    • FIX: Safe sleep not forced as expected sometimes
    • FIX: Forcing safe sleep without at least 1 player in bed
    • FIX: FORCE_SAFE notification not displaying with default configuration

    With the biggest impacting changes being at the top:
    [*]CHG: Default inactivity threshold set to 60 seconds
    [*]CHG: Force count and force percent used together will force if either requirement is met.
    [*]CHG: Split force sleep notifications to clarify configuration or player caused
    [*]CHG: World specific configuration file now at /plugins/Sleep/Worlds/<WorldName>/config.yml

    If you've customized your notifications, you'll want to check out the notifications in this version (specified in the Instructions in the first post) and adjust your configuration file accordingly.

    Also, MessageManager was updated, I suggest you grab that also. It fixes a bug where if players teleported between worlds notifications might not always have reached them properly.
     
  15. Offline

    Kidd0Elite

    Hi, I am interested in putting this on my server when bukkit updates to 1.0, but i don't know if what i want is possible....

    can i make it so it reacts normally but if an admin sleeps then the night is skipped, i am sorry if this has already been asked.
     
  16. Offline

    EdGruberman Retired Staff

    @Kidd0Elite - yes, you can grant your admins the sleep.force permission.
     
  17. Offline

    Kidd0Elite

    thank you, you replied so quickly aswell! :)
     
  18. Offline

    GamingSkell

    hey can u make a new methode for me ? i want a Bed Plugin, if someone dont go to Bed the player gets hur 1 heart every 10 sec to 1 heart life ?
     
  19. Offline

    EdGruberman Retired Staff

    @GamingSkell - That's an interesting concept... some type of punishment option to "encourage" people to go to bed... I'll see if I can get someting working for you, but no promises on a timeline.

    I just released a fix for a few things. If you aren't having problems with anything, it shouldn't matter to update.

    •FIX: Default configuration file not being created
    •FIX: Admins by default were always ignored and forced sleep by default

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 14, 2016
  20. Offline

    GamingSkell

    I´ll wait :) thanks for helping me.
     
  21. Offline

    XxTRAINEExX

    Hello Ed. I'm running an unsupported version of bukkit (1.0) so I realize you may not have an answer to this question. I've got messagemanager and the addon installed but the commands are not recognized in the console of the server. If I type "sleep reload" it sends me the help informaiton for the sleep command which lists "sleep reload" as an option.

    I'm reloading because it doesn't appear the server is pulling all of my configuration options properly. Mainly it's now broadcasting when people get in bed even though I have the options in the config file. No worries if you aren't able to answer this yet. Thanks Ed.
     
  22. Offline

    EdGruberman Retired Staff

    @XxTRAINEExX - /sleep reload works for me from the client or the server console in CB #1518.

    Usually it'll do the help response when an error occurs that is somehow not being caught properly. If you turn on more detailed logging you might get more information in your server log/console.

    Create a /plugins/Sleep/MessageManager.yml file with the following text in it:
    Code:
    send:
        PLAYER:
            level: ALL
        SERVER:
            level: ALL
        WORLD:
            level: ALL
        LOG:
            level: ALL
    Then restart your server and try the command again to see if you get any more details.
     
  23. Offline

    XxTRAINEExX

    @EdGruberman,

    The plugin appears to be working as the night turns to day but it doesn't broadcast to the chat window. Here's a couple captures from my server.

    Thanks again Ed,
    Brian

    Code:
    send:
      PLAYER:
        level: ALL
      SERVER:
        level: ALL
      WORLD:
        level: ALL
      LOG:
        level: ALL
    safe: true
    force:
        count: 2
        percent: 50
    notifications:
        ENTER_BED:
            format: '%1$s entered bed (Need +%2$d to sleep)'
            maxFrequency: 10
            timestamp: false
        LEAVE_BED:
            format: '%1$s left bed (Need +%2$d to sleep)'
            maxFrequency: 10
            timestamp: false
    sleep.notify:
            description: Messages will be generated for all sleep related activities and commands.
            default: true
            children:
                sleep.notify.ENTER_BED: true
                sleep.notify.LEAVE_BED: true
                sleep.notify.NIGHTMARE: true
                sleep.notify.FORCE_SLEEP: true
                sleep.notify.FORCE_SAFE: true
                sleep.notify.FORCE_CONFIGURATION: true
                sleep.notify.FORCE_CONFIGURATION_SAFE: true
    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 14, 2016
  24. Offline

    EdGruberman Retired Staff

    @XxTRAINEExX - Is that first part of the code (the "send" node) you indicated in /plugins/Sleep/MessageManager.yml? I assume so as you are seeing [FINE] entries in your log.If so, what does your server log contain upon restart related to [CONFIG] [Sleep]?


    The last part of that code you pasted (the "sleep.notify" node doesn't have to exist anywhere you would edit. It will only matter how you assign permissions. As long as you are not denying those permissions through some other plugin (PermissionBukkit?) by default players will get notifications that are configured.


    The middle part of your code paste (the "safe", "force", and "notifications" nodes) all should exist under /plugins/Sleep/config.yml. If so, the [CONFIG] [Sleep] entries in your server log should confirm them. Most important is to verify your server log confirms the notifications. My hunch is it's somewhere here that there is a mistake. Look closely at your config.yml file to ensure formatting...
     
  25. Offline

    XxTRAINEExX

    Interesting....

    My plugins/sleep directory only has a messagemanager.yml in it. Oddly enough the plugins/messagemanager only has a config.yml in it. Did I miss a step somewhere? Here are the contents of both files:

    plugins/sleep/messagemanager.yml:
    Code:
    send:
      PLAYER:
        level: ALL
      SERVER:
        level: ALL
      WORLD:
        level: ALL
      LOG:
        level: ALL
    safe: true
    force:
        count: 2
        percent: 50
    notifications:
        ENTER_BED:
            format: '%1$s entered bed (Need +%2$d to sleep)'
            maxFrequency: 10
            timestamp: false
        LEAVE_BED:
            format: '%1$s left bed (Need +%2$d to sleep)'
            maxFrequency: 10
            timestamp: false
    sleep.notify:
            description: Messages will be generated for all sleep related activities and commands.
            default: true
            children:
                sleep.notify.ENTER_BED: true
                sleep.notify.LEAVE_BED: true
                sleep.notify.NIGHTMARE: true
                sleep.notify.FORCE_SLEEP: true
                sleep.notify.FORCE_SAFE: true
                sleep.notify.FORCE_CONFIGURATION: true
                sleep.notify.FORCE_CONFIGURATION_SAFE: true
    plugins/messagemanager/config.yml
    Code:
    send:
      PLAYER:
        level: CONFIG
        format: -> %1$s
        log: '[PLAYER] [%2$s] %1$s'
      SERVER:
        level: CONFIG
        format: '%1$s'
        log: '[SERVER] %1$s'
      WORLD:
        level: CONFIG
        format: '[%2$s] %1$s'
        log: '[WORLD] %1$s'
      CUSTOM:
        level: CONFIG
        format: '[%2$s] %1$s'
        log: '[CUSTOM] %1$s'
      LOG:
        level: RIGHTS
        format: '[%2$s] %1$s'
        log: '%1$s'
    timestamp:
      pattern: HH:mm:ss
      format: '&8%2$s &_%1$s'
    color:
      SEVERE:
        PLAYER: RED
        SERVER: DARK_RED
        WORLD: DARK_RED
        CUSTOM: DARK_RED
        LOG: DARK_RED
      WARNING:
        PLAYER: YELLOW
        SERVER: GOLD
        WORLD: GOLD
        CUSTOM: GOLD
        LOG: GOLD
      NOTICE:
        PLAYER: LIGHT_PURPLE
        SERVER: DARK_PURPLE
        WORLD: DARK_PURPLE
        CUSTOM: DARK_PURPLE
        LOG: DARK_PURPLE
      INFO:
        PLAYER: WHITE
        SERVER: WHITE
        WORLD: WHITE
        CUSTOM: WHITE
        LOG: WHITE
      STATUS:
        PLAYER: GREEN
        SERVER: DARK_GREEN
        WORLD: DARK_GREEN
        CUSTOM: DARK_GREEN
        LOG: DARK_GREEN
      EVENT:
        PLAYER: GRAY
        SERVER: DARK_GRAY
        WORLD: DARK_GRAY
        CUSTOM: DARK_GRAY
        LOG: DARK_GRAY
      RIGHTS:
        PLAYER: BLUE
        SERVER: DARK_BLUE
        WORLD: DARK_BLUE
        CUSTOM: DARK_BLUE
        LOG: DARK_BLUE
      CONFIG:
        PLAYER: AQUA
        SERVER: DARK_AQUA
        WORLD: DARK_AQUA
        CUSTOM: DARK_AQUA
        LOG: DARK_AQUA
      FINE:
        PLAYER: BLACK
        SERVER: BLACK
        WORLD: BLACK
        CUSTOM: BLACK
        LOG: BLACK
      FINER:
        PLAYER: BLACK
        SERVER: BLACK
        WORLD: BLACK
        CUSTOM: BLACK
        LOG: BLACK
      FINEST:
        PLAYER: BLACK
        SERVER: BLACK
        WORLD: BLACK
        CUSTOM: BLACK
        LOG: BLACK
    
     
  26. Offline

    EdGruberman Retired Staff

    @XxTRAINEExX - Sorry, I wish I had more time to devote to documenting this plugin. I know the instructions are not obvious if you are not familiar with all the nuances of Bukkit plugins.

    plugins/Sleep/config.yml is the configuration file for this plugin. It is the most critical and where you need to define the following:
    Code:
    safe: true
    force:
        count: 2
        percent: 50
    notifications:
        ENTER_BED:
            format: '%1$s entered bed (Need +%2$d to sleep)'
            maxFrequency: 10
            timestamp: false
        LEAVE_BED:
            format: '%1$s left bed (Need +%2$d to sleep)'
            maxFrequency: 10
            timestamp: false
    plugins/Sleep/MessageManager.yml should have just this:
    Code:
    send:
      PLAYER:
        level: ALL
      SERVER:
        level: ALL
      WORLD:
        level: ALL
      LOG:
        level: ALL
    Forget the sleep.notify node. That is actually already defined inside the plugin's jar file and is only listed in the instructions in case you want to customize permissions you can use that as a reference of what permissions the plugin uses. But for your purposes it sounds like you can effectively ignore it.

    plugins/MessageManager/config.yml should be left alone/as is. It controls all message formatting options for plugins that use it. In your case that will only be the Sleep plugin. It will make sense to manage any settings for those messages at the /plugins/Sleep/config.yml file itself. So again, you can leave plugins/MessageManager/config.yml as it is.
     
  27. Offline

    EdGruberman Retired Staff

    Working on upgrading this to support 1.2 and fixing some bugs in the process. If anyone would like to test it out, please download the beta but also observe the following requirements:

    1 - You will need to delete any existing /plugins/Sleep/config.yml file as the configuration file has changed significantly.

    2 - MessageManager has been updated to 5.0.0 and you should simply download that latest MessageManager.jar file and replace your existing /plugins/MessageManager.jar file.

    3 - Please note the new PlayerActivity plugin dependency also. Same as MessageManager, simply download the PlayerActivity.jar file to /plugins/PlayerActivity.jar and it won't change anything else on your server.

    * Dependencies: MessageManager(jar) and PlayerActivity(jar)

    Version 4.0.0 (2012/03/??)
    • CHG: Overhaul for Minecraft 1.2
    • CHG: Dependency on PlayerActivity plugin to manage player idle monitor
    • CHG: ENTER_BED and LEAVE_BED notifications will display by default
    • CHG: Notify players that join the world if someone is in bed
    • CHG: Added INTERRUPT notification for players joining a world that was about to sleep
    • CHG: Added private STATUS notification for players joining a world that has players in bed
    • CHG: Added color termination markers after display names to avoid custom display name coloring altering entire message
    • CHG: Renamed and reworded force notifications
    • CHG: inactivityLimit changed to idle in config
    • CHG: Removed safe sleep and nightmare management
    • CHG: Display forced sleep notification after sleep completes
    • CHG: Customizable /sleep status message
    • CHG: All inactive references changed to idle
    • FIX: Players joining a world would interrupt forced sleep
    • FIX: Ops would always ignore sleep by default
     
  28. Offline

    EdGruberman Retired Staff

    Okay, I finally got un-lazy and figured out how to embed the plugins Sleep is dependent upon.

    Simply download Sleep.jar to your /plugins folder and then restart. That should be it!
     
    Silentspy likes this.
  29. Offline

    Silentspy

    Very nice! :)
     
  30. Offline

    EdGruberman Retired Staff

    I just did some significant updates to the architecture/logic and even though 4.0.0 wasn't fully released, I had to update the version to 4.1.0 to ensure the config.yml file changes would properly update for those who had download any of the 4.0.0 betas and/or release candidates.

    You can get the latest 4.1.0 beta from github. You should just copy the Sleep.jar to your /plugins folder and it will update things as appropriate. You may have to restart your server twice for the updates to fully take. Your server log will indicate what it's doing and if you need to restart again.

    For instance:
    If your config.yml file is updated it will display something like the following:
     
  31. Offline

    EdGruberman Retired Staff

    I decided to fully jump a version to show just how much has changed. I've been testing on the development 1.2.4-R0.1 builds with some good success over the last day or so.

    If anyone wants to jump ahead and give the latest beta a try, you can download the 5.0.0 beta from github.

    There was a bug in the 4.1.0 beta that didn't install the dependencies properly, the 5.0.0 beta should fix that.
     

Share This Page