[MISC/INFO] Dynmap-WorldGuard v0.60 - Add WorldGuard regions to Dynmap maps [1.6.2-R1.0+]

Discussion in 'Archived: Plugin Releases' started by Mike Primm, Nov 20, 2011.

  1. Offline

    Mike Primm

    I should be able to add that - I'll give it a look this weekend.
     
    DaEgo likes this.
  2. Offline

    Gomati

    I'm also looking forward for this!

    When i set regions they usually have no owner set.
    I want my players to see a red region if there is already a owner and green if there is none
     
  3. Offline

    DaEgo

    and ?
     
  4. Offline

    Mike Primm

    ...and I was too busy to take a look at it, and I'll try to find time to when I do have a chance....
     
  5. Offline

    Tanite

  6. Offline

    DaEgo

    is there no reload cmd ?
    when i add hidden regions and i do /dynmap reload, he RE-write the dynmap-worldguard config back as it was before
     
  7. Offline

    Mike Primm

    I'll be adding a proper reload for this, and all the other Dynmap-* mods shortly (next few days)
     
    DaEgo likes this.
  8. Offline

    DaEgo

    can u maybe add a version compability list with dynmap ?
    so that we know what version is written/compatible with urs
    cause when i try to update sometimes my regions on map are not visible, so i am still on dynmap 0.36 :(
     
  9. Offline

    Sketaful

    I've never had any problems with regions and I've always used the Dev builds
     
  10. Offline

    Mike Primm

    Right - "0.36 or later" (in the OP) means exactly that. I do regression tests on the add-on mods, like Dynmap-WorldGuard, each Dynmap release - the fact that they keep working is why updates on the simpler ones are somewhat infrequent.
     
  11. Offline

    Gomati

    Doesn't work anymore with Bukkit 1.2.5 R5.0 Release
    Code:
    [SEVERE] Could not load 'plugins/Dynmap-WorldGuard.jar' in folder 'plugins'
    org.bukkit.plugin.UnknownDependencyException: WorldGuard
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:195)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:214)
        at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:190)
        at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigurationManager.java:55)
        at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:158)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:424)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Hope you are also working on 1.3.1
     
  12. Offline

    Mike Primm

    That means WorldGuard isn't being found - do you have it installed, and if so, what version?
     
  13. Offline

    Gomati

    It is installed and was working before.
    I think that happened after I started the server with the 1.3.1 dev build to check if it works. It didn't so I started the server again with Bukkit-1.2.5 R5.0 now it doesn't work anymore with actual dynmap-worldguard 0.16
    Even a complete reinstall of this plugin is not working.
    I have Dynmap-Worldguard.jar in my Plugins folder. And the server is trying to use this file as he is saying

    "Could not load 'plugins/Dynmap-WorldGuard.jar'"

    if the file wouldn't be in the plugins folder it wouldn't even say that he is loading this plugin

    Problem solved.
    Worldguard 5.5.2 wasn't in Plugins-Folder somehow. So he tried to start Dynmap-Worldguard without Worldguard.
    Everything is now working fine with 1.2.5 R5.0

    Keep up your awesome work
     
    Mike Primm likes this.
  14. Offline

    DaEgo

    worldguard region are not loaded again, i delete complete dynmap folder
    and install new but it did not work, no error messages
    http://85.25.148.37:8124
     
  15. Offline

    Gomati

    It seems working to me. I got many areas of your map marked red. Using Firefox 14.0.1
     
  16. Offline

    DaEgo

    yeah me to but i see no worldguard regions
    and some times the map freeze

    did u see now the WG regions ?
    cause on to left side i have only the marker for "Players"
    no region

    lol crasy, i copy back dynmap 36.3 and complete dynmap folder and everything works instant in browser

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 21, 2016
  17. Offline

    Mike Primm

    Working fine on everything I test - with current WG, 0.60 dynmap, and current code here
     
  18. Offline

    DaEgo

    what browser do u support ?
    cause with FF my old 36.3 works fine
    with IE i just se a black screen, nothing else
    chrome ?

    "tiles" files are only generated by the server correct ?
    cause there is not such a dir inside dynmap-0.70-bin.zip
    cause map say Web files do not match with 0.70

    uff, i think i found it
    is it posible that the port makes trouble ?
    when i use 8124 i see map but no region
    [​IMG]
    when i use 8123 i see map AND region
    [​IMG]
    same server same files same jar, just different port

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 21, 2016
  19. Offline

    Tanite

    Can we puh-leeeeeease have a reload command? *sobs uncontrollably*
     
  20. Offline

    Viper_2

    Yes please make a reload command! Every time to restart the whole server when i edit some of the entrys in the config is very stupid! ^^
     
  21. Offline

    DaEgo

    is there a command to add and remove hiddenregions ?
     
  22. Offline

    Doppler

    This plugin has proven enormously useful. Kudos! One thing that would make it even better...a wildcard option for regions that will be hidden? For example, we use regions and greetings extensively for quests that we design, but we don't want them showing up for all to see. Right now we list them out one by one in the plugin config. We name the regions "quest_riverbed_1" and the like, so if we could hide all regions that begin with quest_* it would be great!

    Thanks!
     
  23. Offline

    DaEgo

  24. Offline

    DaEgo

    why u ignore me now ?
     
  25. Offline

    DaEgo

    Yeah finaly, nice, THX!
    damn, i cant press the like button again :-/

    ugh, there is a little problem when alle regions around are in use,
    so the green border is not visible,
    option 1 : can u make the "green" border move more inside the region
    or option 2 : just make complete region green
    [​IMG]

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 21, 2016
  26. Offline

    Mike Primm

    I've got to figure out how to control the 'z-order' of the elements in our layers - might need to update the javascript library I use for the map to do it, so not sure how easily it will get done.
     
  27. Offline

    Fr3xXy

    is there a possibility to set owned areas invisible?

    just would like to see free/unowned areas on my map.


    link to my livemap: map.minebench.de/?worldname=mb9
     
  28. Offline

    Mike Primm

    Not at present, but I could add it pretty easily.

     
  29. Offline

    Fr3xXy

    i would love it!
     
  30. Could you please add permissions to this plugin? I don't want every Tom, Dick and Harry seeing where is protected and where isn't.
     

Share This Page