Inactive [MISC] CommandHelper [3.2.0] - Repeat commands! Aliases! Advanced command scripting! [1000]

Discussion in 'Inactive/Unsupported Plugins' started by sk89q, Feb 16, 2011.

  1. Offline

    sk89q

    CommandHelper is a utility plugin for working with commands.

    • Build your own commands without knowing Java or having to make a plugin
    • Repeat your last command with /.
    • Per-player command aliases
    • Global command aliases
    [​IMG]

    [​IMG] CommandHelper 3.2.0

    [​IMG] Requirements: Java 1.6+ required. Mac OS X users may have to update their Java version. In addition, you need "WorldEdit," but the download linked above has a version with WorldEdit already bundled.

    [​IMG]

    [​IMG]
     
    Pinoyskii, DHLF, beleg and 6 others like this.
  2. Offline

    Scandragon

    I don't like it when plugins place files in the root..
    When you pay for hosting, you don't always have access to the root..

    In my case, I only have access to plugins directory.. Can't even use plugins that doesn't automatically create their setting files, as I can only upload .jar files (and world.yml) unless I zip them and send the zip to support
     
  3. Offline

    Jonathan Bloom

    Where do I put the files for it to read? I put my file in the root directory and made an alias that was @read NAME.txt, but the alias isn't loading.

    Nevermind, got it to work. Is it possible to add colored text support for read items?
     
  4. Offline

    Riwolfes

    I wanna have an alias for manpromote. So I've added :
    :/promote
    /manpromote

    Reloading the plugins I entered /promote USER Admin and got an error that the arguments would be wrong. But these arguments work with the nonalias. So can u tell me whicht variables I have to use?
     
  5. Offline

    Scandragon

    Try /manpromote %1
    I don't know how many parameters must be stated in manpromote, but if it's name and group, add %2
     
  6. Offline

    BangL

    Tested with new Recommended CB#600:

    Code:
    2011-03-30 01:31:45 [SEVERE] Could not load plugins\CommandHelper.jar in plugins: null
    org.bukkit.plugin.InvalidPluginException
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:102)
        at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:158)
        at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:106)
        at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:62)
        at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
        at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
        at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
        at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.reflect.InvocationTargetException
        at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
        at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
        at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
        at java.lang.reflect.Constructor.newInstance(Unknown Source)
        at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:98)
        ... 8 more
    Caused by: java.lang.VerifyError: class com.sk89q.commandhelper.CommandHelperListener overrides final method onPlayerCommandPreprocess.(Lorg/bukkit/event/player/PlayerChatEvent;)V
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(Unknown Source)
        at java.lang.ClassLoader.defineClass(Unknown Source)
        at java.security.SecureClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.defineClass(Unknown Source)
        at java.net.URLClassLoader.access$000(Unknown Source)
        at java.net.URLClassLoader$1.run(Unknown Source)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(Unknown Source)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:36)
        at org.bukkit.plugin.java.PluginClassLoader.findClass(PluginClassLoader.java:24)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at java.lang.ClassLoader.loadClass(Unknown Source)
        at com.sk89q.commandhelper.CommandHelperPlugin.<init>(CommandHelperPlugin.java:43)
        ... 13 more
    
    pls Update :)
     
  7. Offline

    Malkierian

    This :(
     
  8. Offline

    sk89q

    I will be updating this on Friday (PST).
     
  9. Offline

    sk89q

  10. Offline

    jmcneely

    Thanks for updating, I love this plugin!
     
  11. Offline

    habbah

    When the plugin first runs is it supposed to make a folder? because it isent. i cant find global-aliases.txt

    and when i type /alias test /give ^ 302 1
    just says cant find user ^?
    i cant use ^ to change a name when making alias?
     
  12. Offline

    sk89q

    Does /. work even?
     
  13. Offline

    ksevelyar

    Works fine with b617, thanks.
     
  14. Offline

    Scandragon

    sk, I can't get onto your wiki right now.. But doesn't worldedit also use /. for something?
    Seem to remember seeing that yesterday when fixing some permissions for my OPs

    And on that note, onto the worldguard thread to make a post
     
  15. how do i get the username of the person running the command
    it's not replaceing ~username or ^
     
  16. Offline

    link2110

    I can't get /perform to work on individual people either. /perform * works, but if i just /perform ~username command it doesnt work, it just returns "No users were matched" Does this work in 1.4_01 with CB 617, or is that particular command broken?

    Great plugin btw, i love it :D
     
  17. Offline

    Mega™

    Every time I use /each or /perform it just says "/perform <targets> <cmd>" or "/each <targets> <cmd>".
    Any fixes?
     
  18. Offline

    dslip

    @sk89q

    Just a quick question, can we pass the entire arguments line to a command?

    So, instead of
    :/testcmd
    /cmd %1 %2 %3 %4 ....%99 %100

    we can do
    :/testcmd
    /cmd %0 {0 for ALL args, otherwise number em as needed}
     
  19. Offline

    KevGraf94

    same here :/
     
  20. Offline

    ksevelyar

    Could you please add CommandHelper to minerepo?
     
  21. Offline

    Juze

    @sk89q : Please add a changelog and possibly test this against latest RB.
     
  22. Offline

    Nelien

    This would be a very useful plugin to make some end-user commands a lot shorter and easy to use. However, it doesn't seem to be working at the moment. Using Bukkit 684 and the global aliases doesn't seem to work. Last command doesn't work either, it just prints the command in a gray color on the chat but doesn't actually execute it. Global aliases just doesn't do anything.

    Craftbukkit 684
    ComandHelper 2.0.2
    My global-aliases.txt (put in [server root]/aliases/)
    Code:
    :/pra
    /permissions -reload all
     
  23. Offline

    sk89q

  24. Offline

    Nelien

    Nice to see an update on this! And what an update! This is basically a completely different plugin. A lot more complex, but I like it :).

    Now, as far as I've understood the config.txt stores the "global" commands now (with some restrictions if using Permissions), but where are the user aliases stored? I'm guessing they are directly compiled and not store in a .txt file?

    Also, /viewalias (/viewaliases) doesn't work for me, it doesn't show any aliases. I defined some both in config.txt and with my character.

    EDIT: Forgot to mention I'm using craftbukkit 684 (and CommandHelper 3.0-beta1), so maybe that's the culprit. Also, is the config file supposed to be recompiled every time I use ANY command? Seems to do so according to my console right now.
     
  25. Offline

    emoknight

    how do i use the alias command now ingame?
    this it like is /alias getplayername /tphere playername???
     
  26. Offline

    Ratchet

    my alias doesn't work anymore for some reason

    Code:
    :/gil
    /money %1 %2 %3 %4 %5
    just getting unknown console command?
     
  27. Offline

    ks07

    Working on the 1.5 RB (#733). Great job with the update!

    @Ratchet - If you've upgraded to CommandHelper v3, you need to rewrite all your aliases in the new format in a different file.
     
  28. Offline

    Ratchet

    I see..

    well, i've tried:

    /gil $ = /money

    in config.txt and it's not working :|

    come to think of it, even the /time example alias isn't working

    /time $time = /time set if(equals($time, 'day'), 1, if(equals($time, 'night'), 13500, $time))

    I /time day ingame and nothing happens, no message and the time doesn't change?
     
  29. Offline

    MineralMC

    I do like that the new plugin allows proper variable names, but for whisper - and other communication commands - it has doubled the amount of variables needed;

    # Commandbook
    /w $player $1 $2 $3 $4 $5 $6 $7 $8 $9 $10 $11 $12 $13 $14 $15 $16 $17 $18 $19 $20 $21 $22 $23 $24 $25 $26 $27 $28 $29 $30 $31 $32 = /whisper $player $1 $2 $3 $4 $5 $6 $7 $8 $9 $10 $11 $12 $13 $14 $15 $16 $17 $18 $19 $20 $21 $22 $23 $24 $25 $26 $27 $28 $29 $30 $31 $32

    Is there not some sort of method to create a special variable, for words and the like?


    Yes there is. Called a final variable, it's hidden away in the advanced guide, for those who care:
    http://wiki.sk89q.com/wiki/CommandHelper/Advanced_Guide

    ---

    However, v3 *has* broken my herochat global commands:

    / $ = /global $
    /1 $ = /global $
    /! $ = /global $

    The first is a blank space, "/ ", which I can see some scripting languages having problems with, but the other two are very clear commands.

    /gil $amount = /money $amount

    The $ is a variable.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
     
    Last edited by a moderator: May 9, 2016
  30. Offline

    Ratchet

    thanks, but I tried that and it's not working!
     

Share This Page