Inactive [MISC] CommandHelper [3.2.0] - Repeat commands! Aliases! Advanced command scripting! [1000]

Discussion in 'Inactive/Unsupported Plugins' started by sk89q, Feb 16, 2011.

  1. Offline

    sk89q

    CommandHelper is a utility plugin for working with commands.

    • Build your own commands without knowing Java or having to make a plugin
    • Repeat your last command with /.
    • Per-player command aliases
    • Global command aliases
    [​IMG]

    [​IMG] CommandHelper 3.2.0

    [​IMG] Requirements: Java 1.6+ required. Mac OS X users may have to update their Java version. In addition, you need "WorldEdit," but the download linked above has a version with WorldEdit already bundled.

    [​IMG]

    [​IMG]
     
    Pinoyskii, DHLF, beleg and 6 others like this.
  2. Looks pretty nifty. I'll give it a go.
     
  3. Offline

    Phaedrus

    Thank you! I used this a lot in hmod.
     
  4. Offline

    anon

    Thasts really good. Now I can shorten tons of comands, and the "/each * /tphere ^" is just awsome!
     
  5. Offline

    sk89q

    It appears that I forgot to change it to save all the files in the plugin's directory in plugins/, so I'll be posting an update later today that fixes that.
     
  6. Offline

    MintyAnt

    what... I didn't know you were the one that made this! :p

    Definitley useful, thanks for porting!
     
  7. Offline

    sk89q

    There was another command aliases plugin that came after. Maybe you were thinking about that.

    It didn't have 'repeat-last-command' though.
     
  8. Offline

    Stephen92

    worry about craftbook its the most anticipated plugin of all plugins lol.
     
  9. Offline

    OkinKun

    hmm, Why can't I do "/perform username command" ?
    Whenever I try that, I just get "No users were matched."

    I can, however, do the wild-card "/perform * command" on all users, but that's relatively useless.

    I seem to remember this problem also existed back when this plugin was for hmod. =/
     
  10. Offline

    AndyPandy89

    Awesome, thanks for porting.

    One request: adda run-as-instruction. I want my mods to be able to add users to the group member, but not demote admins/other mods.
    like this (using Modify-plugin+Permissions)
    /member
    @runas:admins
    /group %1 member
     
  11. Offline

    sk89q

    You have to do ~username.

    I will have to look into the possibility of this.
     
  12. Offline

    AndyPandy89

    Sweet, thanks [​IMG]
     
  13. Offline

    hyperch

    another dearly missed hmod plugin ported :) thx :)
    --- merged: Feb 18, 2011 7:14 PM ---
    btw, does this user permissions?
     
  14. Offline

    Vaupell

    YAY dont know how many times ive been trying to press "shift + Arrow up" to repeat last cmd :D

    This will do just fine.. Thank you!
     
  15. Offline

    Slayer9x9

    Wow this is amazing!
    Thanks for this.
     
  16. Offline

    Juze

    Oh finally, this plugin. Now waiting on CraftBook. [​IMG]
     
  17. Offline

    OkinKun

    Still no luck.
    Could you type out a full example? :confused:

    No where is there any example for using "/perform" on a single user.. =/ And I just can't get it to work no matter what syntax I try..
     
  18. Offline

    tiwar

    I just want to thank you sk89q very much for porting this wonderful plugin,it makes my life much easier..Thanks =)
     
  19. Offline

    sk89q

    Permissions isn't used yet.

    I'll have to see why ~username doesn't work. I only said that based from reading the code, but I haven't tried it with the port yet.
     
  20. Offline

    jaybud4

    When using the ingame command to set up an alias, is there any notation for a new line, as in another command?
     
  21. Offline

    sk89q

    Not yet.
     
  22. This may be clashing with another plugin, but I don't think any other plugin is using /. unless Essentials snuck it in without saying so. When I use /. it repeats in the chat with gray text that says /,.

    ...just tried using /. now and it says "No previous command" ... and I don't have the plugin installed ... so I am guessing Essentials probably added that. I'll have to look and see for sure.
     
  23. Offline

    sk89q

    Nah, it broke because Bukkit's changed (because of me). I have to fix it.
     
  24. Well something is saying "No previous command" when I use /. even with CommandHelper.jar not in the plugins folder.
     
  25. Offline

    sk89q

    Hmm, then I guess something's stealin' commands.
     
  26. Nevermind haha... I thought I removed it, but it's still there... I removed it and there is nothing else responding to /repeat or /. sooooo silly me! Still broken though :p

    By the way, thanks for all your work sk89q! :)
     
  27. Offline

    tehseano

    Love your plugin, one of my favorites! However I get this error from console, which I'm guessing you're already aware of :)

    Code:
    2011-02-23 01:03:05 [WARNING] Using the stupidly long constructor com.sk89q.commandhelper.CommandHelperPlugin(PluginLoader, Server, PluginDescriptionFile, File, File, ClassLoader) is no longer recommended. Go nag the plugin author of CommandHelper to remove it! (Nothing is broken, we just like to keep code clean.)
    2011-02-23 01:03:05 [INFO] CommandHelper 2.0-beta1 loaded.
     
  28. Offline

    hyperch

    On #432 I also get the long constructor warning

     
  29. Offline

    Klaymator14

    Is it possible to add a feature such as, if I made an alias called "/test", and wanted to add on more text in front of it in the chat menu like "/test variable", and that can substitute for "/reallylongword variable". Is this possible? If it is, I'd be very grateful if you could add it in! :D
     
  30. Offline

    NoFear13

    Please remove your old constructor:
    http://forums.bukkit.org/threads/oops-i-broke-your-plugins.599/#post-70677

    Now your Plugin works anymore, in the new Build
    :2011-02-25 23:37:43 [SEVERE] Could not load plugins\CommandHelper.jar in plugins: null
    org.bukkit.plugin.InvalidPluginException
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:80)
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.java:129)
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager.java:94)
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:59)
    at net.minecraft.server.MinecraftServer.e(MinecraftServer.java:204)
    at net.minecraft.server.MinecraftServer.a(MinecraftServer.java:191)
    at net.minecraft.server.MinecraftServer.d(MinecraftServer.java:131)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:246)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Caused by: java.lang.NoSuchMethodException: com.sk89q.commandhelper.CommandHelperPlugin.<init>()
    at java.lang.Class.getConstructor0(Unknown Source)
    at java.lang.Class.getConstructor(Unknown Source)
    at org.bukkit.plugin.java.JavaPluginLoader.loadPlugin(JavaPluginLoader.java:75)
    ... 8 more

    Thank you.
     

Share This Page