Inactive [MECH] XSigns v0.8 - Switch Signtext with Redstonecurrent or create Counters [1.2.4-R1.0]

Discussion in 'Inactive/Unsupported Plugins' started by Orangenpresse, Mar 6, 2011.

  1. Offline


    XSigns - Switch text with redstonecurrent:
    Version: v0.8

    When you place a sign you may type on each line <phrase1|phrase2>.

    On redstonecurrent phrase2 is shown otherwise phrase1

    See here:

    Big XSigns
    You can create XSigns with more text.
    First place your Sign and write

    finish the sign, break it and put it on the same place.
    And then write

    Youtube: Big XSigns

    Toggleable XSigns
    Start wie a Big XSign, but you can place as many |PhraseX| as you want,
    finish with |LastPhrase>

    Youtube: Toggleable XSign

    If you want to count something, just write [counter] in one line.
    This will create a counter which will be increased with a falling
    redstone current.

    Youtube: XSign Counter

    1. Download the zip or the jar file (the .zip includes flexjson)
    2. Put the XSigns.jar in your plugins folder.
    3. XSigns needs flexjson-2.1 download it or get it with the .zip
    4. Place flexjson-2.1 in your lib/ folder
    5. Enjoy :)
    1. Just replace the XSigns.jar
    • switch text on signs with redstonecurrent
    • create counters
    Download(.zip | .jar)
    Source Code

    Version 0.8
    • 1.2.4-R1.0 compatible
    Version 0.7
    • Minecraft 1.5_2 compatible
    Version History (open)

    Version 0.6
    • toggleable XSigns
    • [counter] command for building counters
    Version 0.5
    • Now it works with Wall Signs with current from the back
    Version 0.4
    • Big XSigns added
    Version 0.3
    • better Multiworld support
    Version 0.2
    • Now should work like any other redstone device
    Version 0.1
    • Release

    INFO (Bug/Issue Tracking)
    I'm not very active in the Forum, and sometimes a bit inactive. But I will maintain the Plugin nevertheless. I use GitHub, so if you find a bug, please create a ticket on

    Thank you :)
    DoomLord, sventi83 and MuttsNuts like this.
  2. Offline


    This is nice :)
    But where i could use it?
  3. Offline


    I use it to give my redstone circuits a better output like "Track 1 active"
    Maybe I should make some more Youtubevideos :)
  4. Offline


    um...... I am new to this. I am not sure where the lib/ folder is or how to get to it? is that the libary folder?
  5. Offline


    No Problem :)
    just create the lib folder parrallel to the plugins folder

    • plugins/
    • lib/
    • world/
    • ops.txt
    • ...
  6. Offline


    I like the idea but i think that having to have it on the same line limits it 2 much the lines are not all that long.

    Or can it be on 2 lines?

    Say i wanted to have a really long word On the line i could not fit both can it be done like?

    Line 1 < hello this
    Line 2 Big MSG|
    Line 3 Hi >
  7. Offline


    Hmm you can write it as:
    <hello this| Hi>
    <Big MSG...|>

    To make it accessible over more lines, my plugin must decide where to make the line breaks.
    Maybe I try to include it but I also thinking about a console command to make long signtexts.

    What did you think what would be better?
  8. Offline


    Chat command maybe idk not good at that kind of stuff.

    with a chat command you could do what i said and seprate each line on the sign with a , so the command could be like.

    /sign text1isbig|test2isbig,line2iscool|line2isnotcool,normaltext,normaltext

    that would work well ofc it would edit the sign your looking at. that would mean you could have 2 settings for the line that take up the whole line atm its limited to being under half a line each for each state that sucks... its already short even shorter uh no thanks.
  9. Offline


    I've got another idea, hope you like it :)
    (Big XSigns)
  10. Offline


    hmm, looks good. I might try this on my server.
    I've got an idea though. You could make it so that, when there are more than 2 messages, every time the current changes (or powers on, but change is faster), the next text appears, in the same order in which they were made. I.E. you make a sign like this:
    <text1|text2|text3|text4> (could be the Big XSign way ofc.). When you first change the current, it shows 'text1'. The next change shows 'text2', the next 'text3', the next 'text4', and then back to 'text1'. This way, you can more or less create a ticker on a sign.
  11. Offline


    Sounds good, i think I will include this in the next release. But you must wait a short time, because I got many Exams during the next two weeks [​IMG]
  12. Offline


    Yey :)

    On another note, what's the texture pack you used in the video? It looks epic :)
  13. Offline


    Hi there, I love this plugin!

    I only have one request. For wall mounted signs, can you allow us to power them by powering the back of the block the sign is mounted to? That way I could hide my wiring and not need a redstone torch under the sign to switch it.

    Thanks :)
  14. Offline


    I use Minecraft Enhanced

    Sorry my fault, thank you for finding this Bug :)
    I try to fix it soon
  15. Offline


    i was advised to try the x signs for my construct (an auto collection and delivery system for great so far, a lot of work to get them all sorted) will sort a video when its down (wont be for a few days)
  16. Offline


    So many ideas:
    Shop - <Open;Closed>
    Mines - <Open;Locked>

    Very nice plugin, definitly going to be using this... just to come up with some fun things,
    Im sure I will have tons as soon as I think about it :)
  17. Offline


    It doesnt work for me.
    i get this error:
    17:17:22 [INFO] XSigns error: flexjson not found!
    17:17:22 [SEVERE] java.lang.ClassNotFoundException: flexjson.JSONSerializer
    17:17:22 [SEVERE] at$ Source)
    17:17:22 [SEVERE] at Me
    17:17:22 [SEVERE] at Source)
    17:17:22 [SEVERE] at
    17:17:22 [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    17:17:22 [SEVERE] at java.lang.ClassLoader.loadClass(Unknown Source)
    17:17:22 [SEVERE] at java.lang.Class.forName0(Native Method)
    17:17:22 [SEVERE] at java.lang.Class.forName(Unknown Source)
    17:17:22 [SEVERE] at orangenpresse.xsigns.XSigns.checkFiles(
    17:17:22 [SEVERE] at orangenpresse.xsigns.XSigns.onEnable(
    17:17:22 [SEVERE] at
    17:17:22 [SEVERE] at
    17:17:22 [SEVERE] at org.bukkit.plugin.SimplePluginManager.enablePlugin(Si
    17:17:22 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugin(CraftSe
    17:17:22 [SEVERE] at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftS
    17:17:22 [SEVERE] at net.minecraft.server.MinecraftServer.e(MinecraftServe
    17:17:22 [SEVERE] at net.minecraft.server.MinecraftServer.a(MinecraftServe
    17:17:22 [SEVERE] at net.minecraft.server.MinecraftServer.d(MinecraftServe
    17:17:22 [SEVERE] at
    17:17:22 [SEVERE] at
    17:17:22 [INFO] XSigns disabled


    it also says this:
    17:17:17 [SEVERE] Could not load plugins\flexjson-2.1.jar in plugins: null
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager.
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.d(
    Caused by: Jar does not contain plugin.yml
    ... 9 more

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  18. Offline


    You can see it at the first line.
    It cannot find the flexjson library (which is used for saving the data).

    At your second post I can see you have the library in the same folder as the plugin, that couldn't work.
    Just create a /lib folder parallel to you plugin folder (maybe the folder is already there) and move the
    flexjson-2.1.jar there.

    • plugins/
    • lib/
    • world/
    • ops.txt
    • ...
    Hope this helps :)
  19. Offline


  20. Offline


    Done :)
  21. Offline


    Absolutely love it!
  22. Offline


    It doesn't work on MC1.4 - CB611
    Waiting for update, I love this plugin :(

    EDIT: working with 617! :D
  23. Offline


    Thank you for testing it :)
  24. Offline


    hey orangenpresse, just letting you know that on 1.5 it messes up with
    2011-04-22 23:31:44 [SEVERE] Could not pass event REDSTONE_CHANGE to XSigns
    java.lang.NoSuchMethodError: net.minecraft.server.WorldServer.g(III)V
            at orangenpresse.xsigns.XSignsBlockListener.checkCurrent(
            at orangenpresse.xsigns.XSignsBlockListener.onBlockRedstoneChange(
            at org.bukkit.plugin.RegisteredListener.callEvent(
            at org.bukkit.plugin.SimplePluginManager.callEvent(
            at net.minecraft.server.BlockPressurePlate.g(
            at net.minecraft.server.BlockPressurePlate.a(
            at net.minecraft.server.Entity.move(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.Packet10Flying.a(SourceFile:126)
            at net.minecraft.server.NetworkManager.a(
            at net.minecraft.server.NetServerHandler.a(
            at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
            at net.minecraft.server.MinecraftServer.h(
  25. Offline


    I've got the Problem, and fixed it :)
  26. Offline


    Can you add colors. It will by nice to have red off text and green on text.
  27. Problems building XSigns - flexjson library - using NetBeans - SOLVED

    Edit: Solved - I overlooked the default caused the classpath to be set to something other than the directory the flexjson-2.1.jar file was located. This was only a problem when building the plugin from the source because the manifest file was different than the one included with the zip file.

    Hey, I'm using your XSigns plugin on a Bukkit server running Java 1.5. Creating a new project using your existing source code works fine and I'm able to successfully add Bukkit and flexjson as libraries. However, when I try running the plugin on Bukkit it gives me the error [SEVERE] java.lang.ClassNotFoundException: flexjson.JSONSerializer

    I've confirmed that the flexjson-2.1.jar file is located in /lib directory in the bukkit root, but I think that it's looking for the file in a different path after building. NetBeans is somewhat new to me, but I am fairly sure I have not made any mistakes when building since it is loaded by Bukkit and runs up until the checkFiles.

    Does the json library jar have to be located in a certain directory relative to the source code or the compiled jar, or does the classpath only matter at the time of building? The same error occurs on both the server and when running Bukkit through Netbeans.

    One thing I noticed in the .classpath file included with the source .zip is the key classpathentry kind="lib" points to "C:/Users/Benedict Burckhart/Dropbox/Minecraft/Bukkit/flexjson-2.1/flexjson-2.1.jar". I'm not sure if the .classpaths file is used by NetBeans, as I tell it to find the library file somewhere else (obviously), but I would like to know the purpose of this file.

    Anyway, I hope you can help me figure out what's going on. I'm actively learning how to create Bukkit plugins and use the NetBeans IDE.

    Thanks for your time, NipplesOfTheFuture
  28. Offline


    Uhh the .classpath should not be in ^^
    I use Eclipse, but I'am happy that it can be also build with NetBeans :)

    It should be possible, I will add this soon :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 11, 2016
  29. Hi Orangenpresse

    we are having a small issue with xsigns, we are using it with minecart mania to have button controlled station sign.

    in minecart mania if you put [station:123] it will then navigate the miencart system you have built to get to the destination. we have built some push button stations with a line of signs with
    1st edit
    2nd edit


    the sign is working as intended when we hit it with redstone it changes as we can see the text, but it does not seem to work with minecart mania. if we remove the xsigns and put a manual one it it works fine. We had it working fine in RB670 but now. we are not seeing any errors in the logs at all. Do you know if this is an issue with xsign?


    current versions of CB, xsignb and MM

    cb: 740
    xsign: 0.7
    MMC: 1.1.9
    MMautomations: 1.1.2
    MMSignCommands: 1.1.3
    MMChestcontrol: 1.1.3
    MMAdminControls: 1.1.4
  30. Offline


    Hmm please make one test:
    Create the XSign as you explained and trigger it to the station text.
    Then restart the Server and try it.

    I think Minecart Mania don't recognize that the Signtext is changed, have you asked Afforess too?

Share This Page