Inactive [MECH] TeslaCoil v2.6.2 - Keep mobs at bay - the futuristic way! [CB 1.4.5-R0.2]

Discussion in 'Inactive/Unsupported Plugins' started by darklust, May 5, 2011.

  1. Offline


    TeslaCoil - Tesla Coil mob control:
    Version: v2.6.2

    Usage: the player must construct a tower of no less than 3 iron(configurable) blocks, and connect this directly to a redstone current. While the current is active, all mobs within a radius proportionate to the height of the coil (3 blocks high = 3 block radius), above or below ground, will be fried. The towers ping every second, so mobs chasing you will quickly regret it

    Moved to BukkitDev:
  2. Offline


    ^^^^ this exactly. I just switched from GM to PermissionsBukkit and group exclusion is no longer working. It excludes players fine, just not groups. I'm also in favor of the ghast fireball idea since it will make it a bit less deadly. So ghast towers usable by players and lightning towers for admin barriers. (would also get rid of the zombie pigmen problem :)
  3. Offline


  4. Offline


    I am having the same trouble.. Once in awhile it will kill mobs but most of the time it does nothing
  5. Offline


    hey guys.

    i recently started a new bukkit server to try out new plugins.
    So i wanted to try this one out.
    But i was kinda unable to get it running.
    Do i need a permissions plugin to use the tesla coil or is it enough to be op?
    Did i miss any settings? tesla reload does work but setting up a tower of iron blocks with a source at the bottom block
    does not do anything, even with a sign to filter stuff.
    Please help
  6. Offline


    The Plugin seems to be broken .. I messed around with it for about a week still can't get it to work. The odd time it will work after you shut down the server and turn it back on but it random strikes every mob no matter what the signs say then it will quit and never work again.. No errors in the server log unless you use the reload command.

    We will just have to wait till the plugin developer repairs/updates the plugin to the current bukkit server release.

    Oh to the developer make sure if you have not already add spout support

  7. Offline


    The plugin works fine for me (1185) except for the group permission thing w/ PermissionBukkit. Hitman what version of bukkit you using?
  8. Offline


    Oh wow it's updated!
    I may have to post my 100 pigmansplosion pic in joy :)
  9. Offline


    I was using 1185 I just upgraded to 1240..
    My problem might be because I am using spout server plugin & client. I herd that can mess up plugin's if the plugin does not support spout
  10. Offline


    Doesnt work q.q i am doing something really wrong. I am op but dont have a permissions plugin.
    teslareload works at least the message appears

    blocktype: 42

    radiusmultiplier: 0

    teslaradius: 15

    safelightning: false

    vradius: 12

    setping: 1

    sandtoglass: true

    those are my settings, but upon stacking 3 blocks of iron and putting a lever on the lowest and switching it nothing happens with creeps arround. also tried the sign thing, but i guess thats just an extra option

    oh its working now, erased the directory and reloaded the plugin again also updated bukkit

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  11. Offline


    My server is using Bucket Permissions but the groups do not seem to be working.
    to be clear if I put "[players]" on the first line and "admin" on the second I should get zapped but I do not. If I put "[players]" on the first line and "thefathermind" on the second I get zapped. I thought this was working before. The only thing permissions related that I have changed is changing the default group from "default" to "guest". My account "thefathermind" is ONLY in the "admin" group. I also tested it on other players that were in the "user" group and I could not affect them ether.

    ~ Merlin
  12. Offline


    Loving the plugin, I had one question. How hard would it be to add an option to disable the thunderclap for lighting caused by a tesla coil? By the time I get four or five going on my server, the thunder sound is almost constant, and people started complaining.
  13. Offline


    Teslacoil doesnt seem to be working all that well for me. its radiuses are messed up

    blocktype: 42
    radiusmultiplier: 5
    teslaradius: false
    safelightning: false
    vradius: 2
    setping: 1
    sandtoglass: false
  14. Offline


    Whats happening?! Can't Download. Could not open file ex/dcount for writing. Make sure PHP has write permission to this file.

  15. Offline


    i cant get it to work.... <--- n00000b! can i have a little instruction on how to?
  16. Offline


    love this plugin and have been using it since it first came out, however I do have a request that in the settings you allow the teslars to be used like they where before - without signs, where they just hit everything.

    -[OGN] Kordale
  17. Offline


    if using [players]ex the tesla also hits pigs, which spawns zombie pigmen which the tower then proceeds to strike nonstop. can we have a filter to avoid targetting pigs?
  18. Offline


    Try setting it to only hit chickens or zombies or something...I don't know how I did it, but the way I have mine set up it kills pigs. I think it has to do with the "safe lighting" option, but like I said...not 100% sure
  19. Offline


    I only have to commit a few more changes before I release an updated version of the plugin with the requested features. I have been working on a bit of a side-venture lately, and have had little time to add everything in, I apologize.

    Without safe-lightning, the AOE of the lightning can strike pigs close to the targeted mob and convert them into immortal pig zombies. When I rewrote the code I forgot to place the pig-zombie killing feature back in, but that will be rectified in the next update.
  20. Offline


    lol~ no wonder when a pig spawned in the tower's radius, we had a endless barrage of lightning until we go kill the pigzombie with godmode. (otherwise we get zapped)
    BTW, whats safe-lightning? I don't see it in the config file.
  21. Offline


    Im getting a zip file when I download it, not a .jar file so whats going on?
  22. Offline


    I have built a tesla coil in real life and when i saw the name of this plugin i was shocked (not literly) to see somthing as old as a tesla coil is in modern day games. This is the best plugin i have ever seen in my life. i just installed it and it was my favorite. Thanks. You get 1,000,000 brownie points.

    on that page click the third file on the right. it will bring up your browsers downloader.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 15, 2016
  23. Offline


    how can i make it so the top of the tesla coil has to be a certain blick?
    EX) i'll have 5 blocks of iron and then the top block has to be a diamond block
    Anybody no?
  24. Offline


    Again I apologize for the long absence, lots of personal stuff going on, but I will continue to update this plugin and I am still incorporating the features I mentioned earlier.

    Glad you enjoy it :D

    This is currently not possible, but I'll add it to my to-do list.
  25. Offline


    i have a prob, this:


    i cant fit the l onto my friends name, multi line support?
  26. Offline


    ok thanks cause it would be nice if you had to have a diamond block on the top cause then not so many people would make them in survival mode cause diamand is rare
  27. Offline


    Man, this plugin is epic.
  28. Offline


    Hi, I am running craftbukkit 1532, essentials 2 65, and YETI permissions.
    Plus worldguard, and Thundertools (another lightning plugin) and such - i cant seem to get this plugin to work?

    I tried a 24 block high iron block tower inside my wizard tower, and a 3 block high iron block tower on some sand.
    My permissions seem ok as i can /teslareload
    I tried with and without a sign.

    I just never seem to get the lightning to happen. What am I doing wrong here?

    here is my config:
    blocktype: 42
    radiusmultiplier: 1
    teslaradius: 24
    safelightning: false
    vradius: 2
    setping: 5
    sandtoglass: true
  29. Offline


    I was able to create a network of coils under ground to protect my tunnels and my fortress from prying eyes. Using a redstone wire extended by the relays I have about a 600 block stretch of protected tunnel to my fortress all controled by a single hidden on/off switch. Thank you!! It is very cool.
  30. Offline


    Updated for the unofficial builds of Bukkit for 1.0, if you are still running 1.8 servers please do not update as this only includes the new mobs and a confirmation method.

    Also, thanks to TheFatherMind for hosting the plugin for me :]

    First, the plugin is no longer supporting YETI's permissions, so I don't know if that would impact it. Second, I just want to point out that your vradius is 2, so if anything is not 2 block above or below the base it won't be targeted. The teslaradius is a constant 24, so having a 24 block-high tower is unnecessary. Other than the permissions though, I don't see anything wrong.
  31. Offline


    Download link times out, not working.
    This link here works though.

    Creating a tower without a sign will kill all mobs. Is there a similar method to kill all players?

Share This Page