Inactive [MECH] ScubaKit 3.1.0 - Use helmets to stay underwater [2034][1.2.3-R0.1]

Discussion in 'Inactive/Unsupported Plugins' started by Choelian, Jun 13, 2011.

  1. Offline


    Current Version: 3.1.0 for CraftBukkit [2034][1.2.3-R0.1]
    Helmets change how long you can stay underwater.​
    This plugin is 1.2 ready. BRING IT ON BUKKIT STAFF.
    I hear this plugin is crazy complex. like 200 lines of code OMGGGGGGGGGGGGGGGGG
    You put it on your head, then jump in the water. You'll be able to stay in the water a great deal longer. The length of time (or if it has to even be a pumpkin) is configurable.​
    • Different helmets can change your maximum air to different amounts.
    • The default amount of air a player has (no helm) can be configured as well
    • None
    open config.yml in Plugins/ScubaKit/ . If it does not exist, you can either get it from the Full Zip, or just run your server once with the ScubaKit installed. ScubaKit will automatically generate the file.​
    It should look something like this;​
        leatherAir: 320
        diamondAir: 320
        ironAir: 320
        pumpkinAir: 320
        chainAir: 320
        defaultAir: 320
        goldAir: 320
        ignorePermissions: true
        SuperPerms: false
        blockHatInstalled: false
        debugLogs: false
    Values shown here are default values assumed if a value is missing.
    The number listed is the number of tics you can stay underwater with the helm indicated in the words next to said number. I believe vanilla Minecraft's default value is 300, but by default we give our players a little extra breathing room. ignorePermissions tells the mod to not bother doing permission checks, instead we assume everyone is allowed to use scubagear.​
    Permission Nodes:​
    inside the config file are 2 settings that control permissions​

    Permissions settings (open)

    ignorePermissions: true​
    SuperPerms: false​

    If ignorePermissions is set to true, we don't bother checking for permissions when players run around with fancy helms on.
    If ignorePermissions is false, then there is a single node to set whether or not a player can use ScubaGear:
    Simple Permissions Node (open)

    ScubaKit.ScubaGear.* - allows players lungs to be altered by the mod​

    Or, you can use its children nodes to set specific helms as usable. In this way, each helm has its own permission node
    ChildrenPermissions Nodes (open)

    ScubaKit.ScubaGear.Pumpkin - allows players lungs to be altered by wearing a pumpkin helm​
    ScubaKit.ScubaGear.Chain - allows players lungs to be altered by wearing a chain helm​
    ScubaKit.ScubaGear.Leather - allows players lungs to be altered by wearing a leather helm​
    ScubaKit.ScubaGear.Iron - allows players lungs to be altered by wearing an iron helm​
    ScubaKit.ScubaGear.Gold - allows players lungs to be altered by wearing a gold helm​
    ScubaKit.ScubaGear.Diamond - allows players lungs to be altered by wearing a diamond helm​

    Please note, that by default, nothing gives extra air, you must configure it.

    3.1.0 - Fixed error on movement while not wearing a helm. Oops. Also moved all strings to a seprate file so they can be changed into any language.​
    3.0.2 - SuperPermissions fix. (Thanks Andrewkm)​
    3.0.1 - Updated for bukkit #1938. Removed silly "in 3d" message​
    3.0.0.D - Updated for bukkit #1597. Fixed infinite air exploit​
    3.0.0.C - Updated for bukkit #1337. New setting, displayWarningMessage, toggles the air remaining message on or off. Spout servers shouldn't need the warning message since bubbles update properly​
    3.0.0.B - Updated for bukkit #1240. No changes.​
    3.0.0.A - Updated for bukkit #1185. Finished blockHat support, and changed how we do it. It should be slightly smarter/faster. Pumpkins no longer give extra air by default. People were getting on my case about only using pumpkins, which was just flat out false. Configure it yourselves (existing config files aren't changed by this).​
    3.0.0 - Totally redid permissions support. We now also support SuperPerms. The nodes are the same between the two. BlockHat support extended for more blocktypes. TypeIDs 1-6 added. Several bugfixes. Added new bugs too probably.​
    2.1.7 - New setting, debugLogs, defaults to false. If set to true, spams your logs uselessly.​
    2.1.6 - Bukkit 1060. Also hacked in support for glass blocks on your head, if you use BlockHat​
    2.1.5 - High detail level logging fix. Whoops. Should probably test better.​
    2.1.4 - Changed the way we load. Better now. No need to upgrade if you're running 2.1.3​
    2.1.3 - Config file ... rearranging. Compiled against bukkit #1000​
    2.1.1 - Minor edge case fix for servers without the permissions plugin.​
    2.1.0- in depth permissions.​
    2.0.0 - Permission support. (3.1.x and 2.7.x should both work)​
    - lots of code rearrange. woo!​
    1.1.2 - Minor fix to logging​
    1.1.1 - Undid "fix" in 1.0.2 Much happier now​
    1.1.0 - Changed to way we check how much air you have. Remaining air is checked every 15 seconds. If you have less air renaming then your maximum air. We say "you have x seconds of air left" (or you are out of air). This fixed "you are out of air" spam.​
    1.0.2 - "Fixed" you have x seconds of air remaining for max air settings that ended with 00​
    1.0.1 - Air remaining messages now in seconds, rather then Tics. Or Ticks, or whatever i was.​
    -Air remaining messages now added in for values as high as 10,000 tics. (500 seconds)​
    1.0.0 - Initial Release, suck on that!​

    Coming Soon:
    Configurable recharge time.​
    Consumables. Thinking about it.​
    More options.​

    *You don't need the full zip. The JAR will create the config files if they don't already exist.
    Stormbow, Bjourk, Joannou1 and 3 others like this.
  2. Offline


  3. Offline


    Using the test build for my 1.0.0 Bukkit build. It doesn't seem to work. It enables fine and such in the server, but staying underwater with any helmet just makes me drown. x.x
  4. Offline


    Would you post your config for me? And what craftbukkit build you're using. It works great on both my test server and my public server, yet has many issues on other peoples servers. I have yet to nail down the problem (or reproduce since CB 1550).
  5. Offline


    Please update! My members love this plugin!
  6. Offline


    1 bug to iron out and its ready.
    Spiritwind likes this.
  7. Offline


    Nice, looking forward to it :D.
  8. Offline


    Your download popped up a "Exploit" message on my Microsoft Security Essentials. I'm sure you aren't malicious, but I wanted some clarification.
  9. Offline


    As far as I know, there isn't anything dangerous, but if you want to be on the safe side, you can download it at, Curse does a virus scan on everything uploaded iirc. That said, 3.0.0.D hasn't shown up yet. It usually takes half a day or so before uploads show up.
  10. Offline


    Thanks Choelian! It's working fine, and my computer hasn't exploded, so I'm sure it's fine.
  11. Offline


    I am one of those folks who is getting nothing happening. I am using the standard yml in the zip file. Also using PermissionsEX, mcMMO, essentials, worldguard, worldedit, hawkeye, lockette, modifyworld, minebackup, pickboat, dynmap, and borderguard. This is a hosted solution I believe it is on Linux.
  12. Offline


    Made a vid OF your plugin :)
    Its still uploading soon it will be up
  13. Offline


    It would be very nice if this plugin didn't create hundreds of bubbles across and flowing off the left side of the screen.


    Maybe limit it to the full width of the hearts and food?


    The default .yml file uses the game's normal durations. You have to increase those numbers to stay under water longer.

    That's the problem: Microsoft. I never get false positives with Avira or Malwarebytes.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  14. Offline


    I am running into a issue with Super Permissions, I want to use the permissions plugin and I have that set to true, but Super Permissions, seem to pop up alot of errors in my log. When I do set permissions to false and super permissions to true, no more errors, but then I cannot get scubakit to run the way I want it to run. I am uploading the log, permission, and scubakit config.

    Attached Files:

  15. Offline


    Good lord, apparently the website decided to stop e-mailing me when people post in this thread. Alright, lets answer some questions.

    @Fozzthulu Using the default yaml changes nothing (well, it adds about 1.5 seconds to normal breath, but thats because I like to round up). We no longer set the pumpkin to longer by default because I about about 10 emails asking why is only allow changing the pumpkins granted air level. Which bugs the hell out of me because it simply isn't true.

    @Freestyling I have not watched it yet, but assuming it isn't telling the world that its an awful plugin, do you mind if I add it into the main post?

    @Stormbow That's a new "feature" of minecraft 1.0.0. I'm hoping a future build of bukkit will give me more control of the bubbles. If not, I may have to implement some sort of fancy code Goliath to do it myself. Also, thanks answering Fozzthulu's question.

    @Drej_X_Army I'm still at work, I'll look into your issue when I get home tonight. (on the ticket you posted on

    Go visit your ticket on

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 16, 2016
  16. Offline


    CoaRSE NOT add it in the main post :)
  17. Offline


    Your plugin.yml shows ScbuaKit.*:
    (Spelling of ScbuaKit should be ScubaKit)
    - This is why everyone is having permissions issues. I tried permission ScbuaKit and it works perfectly fine, however ScubaKit does not) ... lol :p
    Choelian likes this.
  18. Offline


    Thank you VERY MUCH for finding this. If sending cookies through the internet becomes possible, I'll send you a beer. Because that will be possible first I'm sure.

    New Version 3.0.2 fixes this bug.
    andrewkm likes this.
  19. Offline


    I absolutely cannot get this to work on my server.

    Have the latest version above, have the latest bukkit. I have no permissions of any sort on my server as it's just myself and a friend playing. I have "ignorePermissions: true".

    I tried to change the 'default air' to something higher to see if the plugin was working. Nope, the default always stays the same. defaultAir: 1000 acts the same as defaultAir: 320
  20. Offline


    Super idea! Use a glassblock hat! Looks super awesome...
  21. Offline


    i suggested this
  22. Offline


    I´m noob with minecraft and server. After running craftbukkit server, he create the folder inside plugin and when I opened the folder I got the file lang.yml with this an error, is the same error in config.yml:

    disable_complete: Disable Complete
    no_config_exists: No config File Exists. Creating one...
    no_permissione: No Permissions system detected.
    super_perms_active: Super Permissions Active
    error_config404: Config file not found
    error_IOexception: This should really never happen
    error_invalid_config_file: Your config file is invalid
    '1': Thanks for using ScubaKit!
    reminder: Remeber to change ScubaKit.ScubaGear to ScubaKit.ScubaGear.* in your permissions!
    all_values_0: All values returned as 0. Possible loading error.

    I don´t use any permission. Someone can help me? please
  23. Offline


    Hi, does this work with bukkit 1.2.5-R3.0? I see it loading on the console, but it doesn't seem to do anything. I have permissions installed, and ignorePermissions is set to true.

    Edit: It works now - I think I had too high of a value for air settings, I reduced it and now it works.
  24. Offline


    What was the value at before it was working? I'd like to add a warning to the plugin to warn future admins.
  25. Offline


    PLEASE UPDATE TO 1.3.!!!!!! D:

Share This Page