[MECH] RedstoneChips 0.97 - Integrated circuits plugin [1.5.1-R0.2]

Discussion in 'Archived: Plugin Releases' started by eisental, Jan 19, 2011.

  1. Offline


    RedstoneChips 0.97 / BasicCircuits 0.97 / SensorLibrary 0.34
    (Last update on April 30th, 2013, cb 1.5.1-R0.2)


    • Build chips with any number of input and output pins, from compact 2 block chips up to whatever you can imagine.
    • Choose from over 50 different chip types and several 3rd party chip libraries.
    • Most chip types can work with a wide or infinte range of i/o configurations. Sign arguments allow you to customize chip behavior.
    • Chips can communicate through redstone, or directly by touching each other. Some chip types can also communicate over wireless channels.
    • Chips can be built in almost any imaginable structure allowing very compact circuits.
    • Debug and maintain large projects using various tools and commands.

    [cake] Help me spend more time working on RedstoneChips. Please donate

    Circuit libraries made by other people:
    Changelog (open)

    RedstoneChips 0.97 (Apr 30th, 2013)
    • Fixed the saving bug on cb 1.5.1.
    • Added an option to disable update checking.
    BasicCircuits 0.96 (Apr 30th, 2013)
    • pixel: Added a maximum distance value preference to prevent lags and server crashes. The max can be changed using/rcprefs pixel.maxDistance x and defaults to 7.
    • sram: Fixed a problem with anonymous memory.
    SensorLibrary 0.34 (Dec 1st, 2012)
    • daytime: Fixed daytime offset bug.

    Full changelogs and source code @ github.com:
    RedstoneChips [gunpowder] BasicCircuits [gunpowder] SensorLibrary
    DoomLord, Shamebot, Vecht and 6 others like this.
  2. Offline


    I'm getting the following errors when I try to load the plugin on bukkit 450

  3. Offline


    i just updated my craftbukkit and the plugin stopped working.
    im using craftbukkit 465..
    can you try to fix it?
  4. Offline


    I'm pretty sure that the new craftbukkit versions have changed something. When the author see this, I'm sure they will release an update. I'm sure as of now, the plugin developer is probably working on an update as we speak.
  5. Offline


    I finally managed to upload and update everything. Updated to work with latest craftbukkit build, some new circuits, some command tweaks and now you can build a chip with any block type you want (say goodbye to sandstone or whatever you were using).
    The plugin should find out if you're trying to activate a chip that's too big (if you're trying to activate the whole ground dirt for ex.) but let me know if the relaxed rules cause any problems :)
    Any block you can attach a sign to should work except a block type that's already used for some other function like input block or output block or sand and gravel.

    Special thanks to needspeed10 and shamebot for testing and suggesting new ideas.

    I want to use this occasion to ask you guys for some more help with donations. It's been a long time since anyone helped out while the number of downloads has grown considerably since than.
    I also plan to put some google ads on the website soon so I would appreciate any clicks :)
    I hope you don't find it as disgusting as I do...

    And last but not least, I made a new video showing how to use the print circuit for scrolling text. I hope it's clear and sorry about the brightness.
  6. Offline


    Nothing wrong with google ads. They're pretty unobtrusive, and can bring in some income, so no complaints there.

    Could it be possible in the future to use different colored wool as the component blocks? So, for example, use WOOL_BLOCK:BLUE for my interface block?
  7. Offline


    Could be possible theoretically, although it will require quite a lot of work just for this special case.
  8. Offline


    hi :)
    First of all, i LOVE your plugin.
    I think it's the most usefull plugin for bukkit so far.

    I just have some problems when it comes to building my own Chips using your template.
    When I try to build the Template it just outputs a bunch of errors:
    [INFO] Scanning for projects...
    [WARNING] Some problems were encountered while building the effective model for
    [WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-comp
    iler-plugin is missing. @ line 13, column 21
    [WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-jar-
    plugin is missing. @ line 21, column 21
    [WARNING] It is highly recommended to fix these problems because they threaten t
    he stability of your build.
    [WARNING] For this reason, future Maven versions might no longer support buildin
    g such malformed projects.
    [INFO] ------------------------------------------------------------------------
    [INFO] Building LibraryTemplate 1.0-SNAPSHOT
    [INFO] ------------------------------------------------------------------------
    [WARNING] The POM for org.tal:RedstoneChips:jar:0.82 is missing, no dependency i
    nformation available
    [INFO] ------------------------------------------------------------------------
    [INFO] ------------------------------------------------------------------------
    [INFO] Total time: 0.454s
    [INFO] Finished at: Tue Mar 01 18:07:11 CET 2011
    [INFO] Final Memory: 2M/15M
    [INFO] ------------------------------------------------------------------------
    [ERROR] Failed to execute goal on project librarytemplate: Could not resolve dep
    endencies for project org.tal:librarytemplate:jar:1.0-SNAPSHOT: Failure to find
    org.tal:RedstoneChips:jar:0.82 in http://repo1.maven.org/maven2 was cached in th
    e local repository, resolution will not be reattempted until the update interval
     of central has elapsed or updates are forced -> [Help 1]
    [ERROR] To see the full stack trace of the errors, re-run Maven with the -e swit
    [ERROR] Re-run Maven using the -X switch to enable full debug logging.
    [ERROR] For more information about the errors and possible solutions, please rea
    d the following articles:
    [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyReso
    It seems like somehow the RedoneChips.jar is missed..

    Is there any solution to this? Would be really awesome, since i really would like to make some new stuff :)

  9. Offline


    How are you trying to build it exactly? Are you using an IDE or straight from the command line?
    You probably don't have RedstoneChips-0.82.jar in your maven repository.
    If you have git installed, the easiest thing would be to recompile RedstoneChips.
    Run these from the command line:
    git clone [email protected]/eisental/RedstoneChips
    cd RedstoneChips
    mvn package install
    The last command should compile it and copy it into the maven repository. After that, building it should work (I hope). I realize a proper guide would be helpful, but I don't have one yet ;)
  10. Offline


    Re wool colors: Ouch. Yeah, if it's not a simple job, probably not worth it then. I was just hoping to be able to make circuits cheaper (gold comes to mind) without giving up the bright colors to make it easy to see what my circuit is doing at a glance.
  11. Offline


    Works perfect now! Thank you so much :)
    There wasn't a copy of RedstoneChips in the rep.. (I'm new to this stuff)

    Now i try to implement some of my ideas :D
  12. Offline


    Cool. Let us know if you make anything useful :)
  13. Offline


    yes i did and still only get 2x2x2 ,hab das auch gemacht with the signs, didnt bring anything more
  14. Offline


    This plugin is so awesome! My friends and I are CS majors so we love this sort of thing. If I could make a request though, would you make an option in the daytime circuit to give gametime minutes? The conversion factor is easily obtained to be 16.66666 ticks/1 min, and despite how fun it might be to figure out how to do the division using redstone, it would be much less annoying to have it done in the plugin code.
  15. Offline


    Well, I'm not sure how to help. Can you explain exactly how are you trying to build it? A diagram would help...
    --- merged: Mar 3, 2011 12:23 AM ---
    Thanks, glad you like it. I guess I could add the minutes, didn't think of any uses for that. Are you building a clock? :)
  16. Offline


    This is exactly what I'm doing [​IMG]
  17. Offline


    Updated to SensorLibrary-0.21
    daytime can output game minutes. Made some other small changes to daytime time field argument. Check the docs if you're having any problems.
  18. Offline


    Thanks, man!
  19. Offline


    First I have to say it's an awsome plugin :D

    But something bothers me...

    I've tried to address a large number off outputs with one or two inputs (via an or) but this doesn't work.
    Is there a way to translate the state of one input to an huge number of outputs?
  20. Offline


    If I understand what you mean, you can use the router for that but it won't be very convenient since you have to specifically say on the sign which input to route to which output(s), and you would need to trigger the 1st input (clock) to update the outputs. I could make a repeater circuit that copies the state of 1 input to any number of outputs. Would that help?
  21. Offline


    Yes this would be very usefull, thanks!
  22. Offline


    Trying to load this plugin, regardless of which version of CB we use, and even with absolutely no other plugins running, both BasicCircuits and SensorLibrary produce an unable to load error. The base plugin loads fine, however.

    Pretty much the same thing as this poster, only the base plugin actually loads.
  23. Offline


    I need a copy of the exact error you're getting. If it's EXACTLY the same as the one you quoted, it means you're using an old RedstoneChips version. If you do, though I doubt it, make sure to install the latest version and see if it still happens.
  24. Offline


    After further testing, it looks like the issue was that the filenames being changed to omit the version number was the issue.

    On our server, we keep version numbered copies of all plugins in another directory, then symlink them into the plugins folder, so changing versions and keeping track of which one is installed becomes much simpler. Funny thing is that I tried changing the filenames back to normal before, but it never worked last night. For some reason it decided to work this time though, so all seems to be fine, we just broke the standard procedure we use for this plugin.
  25. Offline


    Yes, you must keep RedstoneChips-0.xx.jar with the same filename otherwise BasicCircuits and SensorLibrary won't know where it is. You can change the library filenames to whatever you want.
    I hope to solve this in some future release but I don't want to make it harder to code circuit libraries by using some hackish solution.
  26. Offline


    Issue with RedstoneChips 0.82/0.82/0.21 on Craftbukkit 493 (I see that you aren't advertising 493 so feel free to ignore me here)

    My issue is that circuits are deactivating on server restart.
    In addition to RC, I'm running ControllerBlock 1.14, Permissions 2.5.2, General, and MultiVerse 1.5.
    Working in an alternate world called "creative".
    The test circuit is a simple xor gate. 2 inputs, one output. When simply playing, it works exactly as expected. However, when I stop and start the server, the circuit deactivates and is forgotten. I can activate it again with a right-click and it starts working again. No errors in the log, but here it is if its useful. I note that it always says "0 active circuits".
    Show Spoiler

    14:37:03 [INFO] Starting minecraft server version Beta 1.3
    14:37:03 [INFO] Loading properties
    14:37:03 [INFO] Starting Minecraft server on *:25565
    14:37:04 [INFO] This server is running Craftbukkit version git-Bukkit-0.0.0-493-g8b5496e-b493jnks (MC: 1.3)
    14:37:04 [INFO] Preparing level "world"
    14:37:04 [INFO] Preparing start region
    14:37:05 [INFO] [Permissions] version [2.5.2] (Phoenix) was Initialized.
    14:37:05 [INFO] [General] version [] (TheBeginningOfTheEnd) loaded
    14:37:05 [INFO] [Permissions] version [2.5.2] (Phoenix) loaded
    14:37:05 [INFO] RedstoneChips: Loading > photocell, pirsensor, rangefinder, daytime.
    14:37:05 [INFO] RedstoneChips: Loading > adder, and, clock, counter, demultiplexer, divider, flipflop, multiplexer, multiplier, or, pisoregister, print, random, receiver, shiftregister, transmitter, xor, decoder, encoder, pixel, pulse, not, synth, srnor, terminal, router, ringcounter, iptransmitter, ipreceiver, comparator, delay.
    14:37:05 [WARNING] RedstoneChips: World creative was not found on the server.. Ignoring circuit.
    14:37:05 [INFO] RedstoneChips: 0 active circuits
    14:37:05 [INFO] RedstoneChips 0.82 enabled.
    14:37:05 [INFO] ControllerBlock: 1.14 by Hell_Fire
    14:37:05 [INFO] ControllerBlock: Using IRON_BLOCK (42) as ControllerBlock, loaded 0 disallowed types from config
    14:37:05 [INFO] ControllerBlock: Loaded v1 data - 0 ControllerBlocks loaded
    14:37:05 [INFO] ControllerBlock: Enabling full redstone check
    14:37:05 [INFO] ControllerBlock: Events registered
    14:37:05 [INFO] [MultiVerse] Permissions Found
    14:37:05 [INFO] [MultiVerse] - Version 1.5 (Permissions 2.1+) Enabled
    14:37:05 [INFO] [MultiVerse] Loading World & Settings - 'world' - NORMAL
    14:37:05 [INFO] [MultiVerse] Loading World & Settings - 'nether' - NETHER
    14:37:06 [INFO] [MultiVerse] Loading World & Settings - 'creative' - NORMAL
    14:37:06 [INFO] [MultiVerse] 3 - World(s) loaded.
    14:37:06 [INFO] [MultiVerse] Loading Portals
    14:37:06 [INFO] [MultiVerse] 2 - Portal(s) loaded.
    14:37:06 [INFO] Done (0.276s)! For help, type "help" or "?"
    14:37:08 [INFO] 143 recipes
    14:37:08 [INFO] dashkal [/] logged in with entity id 157
    14:37:16 [INFO] Loaded world: creative
    14:37:16 [INFO] Loaded world: world
    14:37:24 [INFO] dashkal lost connection: disconnect.quitting
    14:37:26 [INFO] CONSOLE: Stopping the server..
    14:37:26 [INFO] Stopping server
    14:37:26 [INFO] RedstoneChips 0.82 disabled.
    14:37:26 [INFO] [Permissions] version [2.5.2] (Phoenix) disabled successfully.
    14:37:26 [INFO] [MultiVerse] - Disabled
    14:37:26 [INFO] Saving chunks
    14:37:26 [INFO] RedstoneChips: Saving circuits state to file.
  27. Offline


    Do you have a RedstoneChips folder in the plugins folder? What's the folder exact name? Do you see anything in your redstonechips.circuits file?
    I don't think this has anything to do with 493. I'm running on 497 at the moment and it works fine. Maybe some problem with filenames.
  28. Offline


    First, I love this plugin! Thank you very much!

    But i noticed some strange behavior of the srnor circuits. I use this plugin together with Controller Blocks to control a Minecart system. I have 3 Buttons for 3 directions, every button goes on one input on a srnor circuit. With the help of a controller block the matching rails are spawned. That works all great, but after a server restart i have to toggle 2 times to get it working again. So it seems the state of the circuit isnt saved properly.

    In that case its not that bad, because its no problem to toggle a few times, but i also have a srnor latch which gets its input from a MinecartMania sensor. This circuit is not really comfortable to reset, because I have to trigger two sensors witch a minecart ;)

    Oh and I'm running Craftbukkit 440 and Redstone Chips 0.82.
  29. Offline


    Thanks! Never noticed that bug before. Fix is on the way.
  30. Offline


    Searched through my server log today and I found this:

    2011-03-05 21:44:30 [SEVERE] Could not pass event BLOCK_RIGHTCLICKED to RedstoneChips
    java.lang.ClassCastException: net.minecraft.server.TileEntityChest cannot be cast to net.minecraft.server.TileEntitySign
    	at org.bukkit.craftbukkit.block.CraftSign.<init>(CraftSign.java:16)
    	at org.bukkit.craftbukkit.block.CraftBlock.getState(CraftBlock.java:287)
    	at org.tal.redstonechips.CircuitManager.checkForCircuit(CircuitManager.java:72)
    	at org.tal.redstonechips.RedstoneChips$1.onBlockRightClick(RedstoneChips.java:112)
    	at org.bukkit.plugin.java.JavaPluginLoader$20.execute(JavaPluginLoader.java:222)
    	at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:59)
    	at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:225)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:480)
    	at net.minecraft.server.Packet15Place.a(SourceFile:57)
    	at net.minecraft.server.NetworkManager.a(SourceFile:230)
    	at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:75)
    	at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
    	at net.minecraft.server.MinecraftServer.h(MinecraftServer.java:357)
    	at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:272)
    	at net.minecraft.server.ThreadServerApplication.run(SourceFile:366)
    Not sure what caused it.
  31. Offline


    My redstonechips.circuits:
    Show Spoiler
    [{activationBlock: [-30, 66, -42], structure: [[-30, 66, -42], [-30, 66, -43], [-31,
    66, -43], [-30, 66, -44], [-29, 66, -44], [-28, 66, -44], [-30, 66, -45]],
    signArgs: [], inputs: [[-31, 66, -43], [-30, 66, -45]], state: {}, interfaces: [],
    class: xor, outputs: [[-28, 66, -44]], world: creative}]

    Note that if I bring up the server and shut it down without doing anything, it promptly blanks out (that is, it reverts to a file with only [] in it).
    --- merged: Mar 6, 2011 4:57 AM ---
    Update: I just found something interesting in my log:
    20:55:22 [INFO] RedstoneChips: Loading > photocell, pirsensor, rangefinder, daytime.
    20:55:22 [INFO] RedstoneChips: Loading > adder, and, clock, counter, demultiplexer, divider, flipflop, multiplexer, multiplier, or, pisoregister, print, random, receiver, shiftregister, transmitter, xor, decoder, encoder, pixel, pulse, not, synth, srnor, terminal, router, ringcounter, iptransmitter, ipreceiver, comparator, delay.
    20:55:22 [WARNING] RedstoneChips: World creative was not found on the server.. Ignoring circuit.
    20:55:22 [INFO] RedstoneChips: 0 active circuits
    20:55:22 [INFO] RedstoneChips 0.82 enabled.

    RC Loads before MultiVerse. "creative" hasn't been loaded yet.

Share This Page