Inactive [MECH] RapidBuild v2.0 - build faster [1000]

Discussion in 'Inactive/Unsupported Plugins' started by Naitsirhc Hsem, Jul 2, 2011.

  1. Offline

    Naitsirhc Hsem

    RapidBuilder is a plugin that allows you to select an area and fill it.



    • Select 1 block with right click and one block with left click
    • Hold the item in your hand that you want to fill the area with
    • type /rfill or /rf
    • If you are an OP, it does not decrease the ammount of item in your inventory
    • If you are not OP, it takes the items from your inventory, until you run out
    • If you are holding air, it deletes the selected blocks
    • Basic functionality
    • Bugs:
      • filling large areas with items like torches causes massive server lag
    • Fixed ALOT of small issues
    • created a repo
    • whitelist items
    • permissions
    • drops from air fill
    plwjr2000 likes this.
  2. Offline


    Please use bold font for section names and a proper list, not just '*' characters, there are buttons for that when you edit the post
  3. Offline

    Naitsirhc Hsem

    ok, will fix it
  4. Offline


    love the mod its a great mod for building
  5. Offline

    Naitsirhc Hsem

    thanks for the feedback, be careful with torches though, too many will crash a server
  6. Offline


    Hi, this message keeps coming up:
    SEVERE] Could not load 'plugins/RapidBuilder.jar' in folder 'plugins':
    java.lang.UnsupportedClassVersionError: Bad version number in .class file

    what do i do?
    Kazinto likes this.
  7. Offline

    Naitsirhc Hsem

    I have never heard of that one before, what version of bukkit are you using?
  8. Offline


    it says version: git-Bukkit-0.0.0-904-g9277096-b953jnks (MC: 1.7.2)
    im on mac btw
  9. Offline


    Judging by the developer's avatar and the error that comes up, I'd guess he uses Linux.

    @Naitsirhc Hsem
    I'd guess you named the directory with /'s in it. These are only for Linux file paths. Instead, write the path like ("text" + File.separator + "other text") as opposed to ("text/other text"). This will adjust the / or \ as necessary for the OS.

    EDIT: Nevermind, just looked at your source.
  10. Offline


    oh and when i try this it say an externel error has happend how can you or i fix that?
  11. Offline

    Naitsirhc Hsem

    please post your bukkit version along with the error
  12. Offline


    nvm it works now i need to delete the metainf its a great mod for making roads houses
    oh and by the can i make it go up? i have a linux computer
  13. Offline

    Naitsirhc Hsem

    what do you mean?
  14. Could you use a different command, /fill overlaps with WorldEdit, which half the MC planet uses.
  15. Offline

    Naitsirhc Hsem

    sure, I have some fixes to do anyway
  16. Offline


    i mean like if you put a block on the ground and put a block in midair than right click the bottem then left click the top block the right /fill will that work?
  17. Offline

    Naitsirhc Hsem

  18. Offline


  19. Offline


    I really like this.

    "I'll clear some land" client crash, server warning over 1 million updates, doesn't crash "oh, thats was a 5 million cube change" :D
  20. Offline


    Hi, a friend owns a server and I asked to install this plugin and he did. Now when I write /fill it says " An internal error occurred while attempting to perfrom this command".
    I don't know if I have to install something to work, or am I doing something wrong?
    Btw, I don't have clear the selection with right-left button, may I to have my hand, a block, or it doesn't matter?
  21. Offline


    Hello friend! I would like to make a few recommendations to your plugin, if you don't mind.
    1. The block selection process could interfere with other plugins, so I recommend you give the option to toggle the "selection" mode in-game. Fye, type /rbselect to activate selection mode, and again to turn it off.
    2. This has been said before, but you should change /fill to something like /rbfill, so that it doesn't conflict with Worldedit.
    3. I know you already plan on it, but please integrate permissions; we already know the advantages to this. :)
    4. Another good idea would be able to set a maximum block selection limit for the fill item "Air", since users have infinite of this.
    5. Finally, a cool feature to add would be /rbundo, for obvious reasons.
    Your plugin has some insane potential, and I hope you consider some of my recommendations! Peace out friend!
  22. Offline

    Naitsirhc Hsem

    Sure, I have been busy working lately :/
  23. Offline


    Oh my gosh man, I am in fricken love with this mod. The simplicity of it and the amount of time it saves, haha, this is so great. Amazing job.

    Make sure you have the thing you want to fill the area with in your hand when you type /fill.
    I usually right click with my pickaxe, go to the other spot and left click with my pickaxe, then ill pull out my block (lets say stone) and then type /fill

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 17, 2016
  24. Offline


    I'm loving this plugin, many thanks and kudos to the dev.....GREAT
  25. Offline


    I always get this error message, when I click a block.
    Capture.PNG And minecraft says "An internal error occurred while attempting to perform this command" after writing /fill.

    Edit: Using latest bukkit.
  26. Offline

    Naitsirhc Hsem

    I need to fix the plugin, I wrote it when I was just starting to play with the bukkit api. I will hopefully finish sometime this weekend
  27. Offline

    Naitsirhc Hsem

    New Version!

  28. I get an error messsage when I run my server:

    My bukkit build is 1000
    My minecraft version is 1.7.3
    My OS is Windows 7.
    any other information needed?

    [SEVERE] Error occurred while enabling RapidBuilder v2.0 (Is it up to date?): null
    at java.lang.Enum.compareTo(Unknown Source)
    at org.bukkit.plugin.SimplePluginManager$
    at org.bukkit.plugin.SimplePluginManager$
    at java.util.TreeMap.put(Unknown Source)
    at java.util.TreeSet.add(Unknown Source)
    at org.bukkit.plugin.SimplePluginManager.registerEvent(
    at me.cmesh.RapidBuilder.RapidBuilder.onEnable(
    at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    at org.bukkit.craftbukkit.CraftServer.enablePlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.init(
  29. Offline

    Naitsirhc Hsem

    Wierd, seems like a issue with java's HashMaps. What version of java are you using?
  30. I am currently using Java version 6 update 26

Share This Page