[MECH] Multiple Inventory Pages v2.0 [1.4.7 R0.2]

Discussion in 'Archived: Plugin Releases' started by geqoo, Jan 1, 2012.

  1. Offline


    This looks great! Any chance you will be adding permissions, instead of just the op?
  2. Offline


    i found a bug you could try fix if you have a almost broken tool put it in your inv then change inv then change back your tool will be fixed any chance of a fix please also permissions support with a config inv's for different usergroups :D
  3. Offline


    I will look at it, thanks for the report!

    Add: I looked at it & I can't reproduce the bug. If you want it to be fixed, please be more detailed in your next description.
  4. Offline


    Plugin will be updated after Bukkit 1.1 stable is released!
  5. Offline


  6. Offline


    Great! ;)
    But still no Permissions support :(
  7. Offline


    yup & I don't gonna add it, because it is not needed.
  8. Offline


    Oh, I completely overlooked the fact that it now gives the command / setpp <play name> <amount of pages>. So should the permissions problem solved. Sorry! ;)

    But now I have another problem. I've put some stones in inventory 2 and eventually moved to inventory first From there, then back to 2 and this inventory was empty.

    No matter what I remove and no matter where I put it off after the inventory has changed, it is empty.

    I use Bukkit for MC 1.1. With version 1.6.1 there is the problem. Version 1.6, which is not intended for MC 1.1 How everything ;)

    EDIT 2:
    A change in the inventory number is possible only when players present. That is a little impractical.
  9. Offline


    thsi sounds really nice. i tried it in a few hours. but i have one question. is it possible to get an option to set the page count at permissions? so that i can give the user group 2 pages, the vips 3 pages and mods 5 pages

    the /setpp command isn't a solution when many people coming and going, because every time a new player arrived, a mod should use the command and when no mod is online the player must wait.
    oh and where can use the command? i think with no permissions everyone can use it and this is what i don't want.
  10. Offline


    Can't donwload. It doesn't load the page
  11. Offline


    I checked the link. It is online.
    Only OPs can use that command.
  12. Offline


  13. Offline


    What about if this had instead of using /multiinv you can just ingame when you press E for your inv there is a scroll button?
  14. Offline


    The problem is that this is client modding, but I realize it only with Server Plugins.
    If you use the Spout Client, you can use . and , to switch your pages.
  15. Offline


    Note: This plugin is not compatible with the Plugin "Up 2 Date".
  16. Offline

    5000 People


    5000 people are confused
  17. Offline


    The latest dev build is named as that.
  18. Offline


    the shortcuts ain't working plz help
  19. Offline


    This really should have permissions, it's a bit arrogant thinking it doesn't need it.

    For example if someone wants to make it that VIP's and donators have this but builders don't....they can't do it without adding everyone in manually.
  20. Offline


    found bug..
    use the /inv 1~..

    Enchantment in the inventory if there are items
    Enchant the item removed
  21. Offline


    Like really, please add permissions.
  22. Offline


    Spout Keyboard Bindings are fixed (but the release is not published right now).

    What I am working on currently:
    -Edits in the code structure to make the plugin run faster
    -Fixing the Enchantment Bug

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 22, 2016
  23. Offline



    enchant bug and inventory switching bug..

    error codes:
    please watch this video

  24. Offline


    That's because another process has the database in use currently. Restarting your system or killing all java processes before you start your server again should fix it.
  25. Offline


    i've been looking for a plugin like yours for some time. But unfortunately it doesn't work with my server. I'm not shure what the problem is, but maybe you have an idea.
    ok, what happend. I installed the plugin and when i go online everything works fine. I can switch inventory pages and everthing works the way I expected. The objects from ic2 lose all stored power, but that's ok.
    now comes the strange part. a second player logged in and tried to switch pages. switching from page 1 to 2 worked fine. but switching back doesn't work. As long as we're both logged in we both have that problem. as soon as the second player disconnects it starts working again for me, but the second player can't switch back to page 1. even if there is nobody else on the server.
    the server shows this error:
    21:16:55 [SCHWERWIEGEND] Exception in thread "Thread-2603"
    21:16:55 [SCHWERWIEGEND] java.lang.IllegalArgumentException: Specified enchantment cannot be applied to this itemstack
    21:16:55 [SCHWERWIEGEND] at org.bukkit.inventory.ItemStack.addEnchantment(ItemStack.java:283)
    21:16:55 [SCHWERWIEGEND] at me.geqoo.multiinv.SwitchThread.run(SwitchThread.java:148)

    I restarted the server and checked if java was closed but that didn't help. i checked the stord data and there was nothing enchanted in the second players inventory.

    Could my version and my other mods be causing this problem. I would love to get this working. ;-)

    Here's some information about my craftbukkit version and my installed plugins:

    craftbukkit-1.1-R3.jar premodded with ModloaderMP 1.1, Minecraft Forge, BuildCraft 2.2.12, IndustrialCraft² 1.64 r1, RedPower All 2.0p4d downloaded at http://www.mcportcentral.co.za/index.php?topic=1037.0

    I also have Ironchests 2.3a, ChargingBench r2 for 1.1-R3 - IC² 1.64 and Thermometer1.1.9 r1 installed

    in addition I have 18 more bukkit plugins installed. If you want a detailed list, just ask. Any idea what might be the problem?

  26. Offline


    Can't download, is there any other mirror?
  27. Offline


    Umm...May be useful
  28. Offline


    I don't think your other plugins are causing the problem. The message "Specified enchantment cannot be applied to this itemstack" is only displayed if this item cannot be enchanted.
    Looks like a database error. Try to delete the database file & try again.
    Could be a bug with Essentials as well.
  29. Offline


    Permissions support will be out in the next days.

  30. Offline


    Planned for 1.8:

    New code elements
    Fixed a bug with OnlyOp
    Fixed a bug with LooseAllPagesOnDead
    Added Permission Mode support

    I am doing several tests with the new version of the plugin so I will release it next time!
    Permissions support will be in then.

Share This Page