Inactive [MECH] MultiInv V2.4.1 - Per World Inventories [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Pluckerpluck, Feb 17, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    I changed my spawning so people respawn in the same world and that fixes it for me.

    Good enough.

    Thanks for the plugin.
  2. Offline


    Look at Slow Health this will do what you want as it supports multiworld health settings and is fully customisable even though its still on 566 works fine on the 600 series builds.

    If you wanted to turn off health degrading on a world basis use the latest WorldGuard along with it.
  3. Does that separate health on different worlds though? Or does it just affect health different on different worlds? If it doesn't it may be better if you ask them to implement it. I'll probably still add it though as it adds to the idea of separation between worlds.

    @Flenix about your chests across worlds. Recently released was a plugin called RemoteChests. See if that can do what you want.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  4. Offline


    Hey the Inventory shares.txt isn't doing anything for me. It does not work when i put the names of the world in like:
    No errors, nothing.
  5. Offline


    Where does MultiInv save the inventories? I tried deleting all the files in world/players, but it didn't reset their inventory. How do I reset everyone's inventory? I'm getting this odd bug where if they store something in a chest, log out, log back in, they will have their original items in their inventory, as well as the chest, enabling them to duplicate items.
  6. It's under plugins/MultiInv/inventory/ but that's changing eventually. If you want a complete reset you'll also have to delete the player data files again in the world file. That's an interesting problem you're describing though... it seems like my plugin isn't saving the inventory properly... might be my problem or might be a bukkit problem... I don't know.
    On server start it will either say shares.txt loaded successfully or error. If it loaded successfully (and the file is in the right place) then it means it found the worlds "world" and "item" so I don't know what the problem would be...
    Do the worlds just act as if they were never shared? Or is something else happening?
  7. Offline


    I'm using essentials and MultiVerse. I have MultiInv installed, latest version. We have two worlds, normal and survival. In survival, no player can spawn items (I have multiworld permissions set up with groupmanager). When people use /mvtp survival to go to the survival world, they DO get a fresh inventory. But I have a few glitches:

    1. When a player in the normal world /tp's to a player in survival, they do NOT switch to their survival inventory.
    2. When a player in the survival world logs out, then logs back in, their inventory is gone.

    Is this an issue with MultiVerse or MultiInv? Thank you very much for your time!
  8. Erm... interesting issues. Which plugin do you use to tp to a player (is it essentials)? If that plugin does certain things (which it shouldn't do) my plugin may not recognise the change in world.

    However, the logging out problem is odd. When they log out the return back to where they logged out right? You don't have some plugin that causes all logins to be at the spawn point? Otherwise you could try removing from my plugins folder and letting it reset. See if that helps.

    But I'm changing a lot in how the information is stored for the future update so it may help these problems because it should be more robust.
  9. Offline



    Great plugin, extremely valuable.

    Is this compatible with craftbukkit b670? I'm ready to go to b670 if this plugin will work on it (i've collected most of my other necessary b670 plugins). Please let me know anyone out there :)

  10. There's no reason that this shouldn't be compatible with b670. I believe others have got it to work fine on it and it works fine for me. Every now and then someone comes up with a strange strange problem though.... but that's in general and not related to a particular version of craftbukkit.
  11. Offline


    It seems to be working fine with b670 for me.

    Feature request time:
    Could you add a command to make someone's inventory temporarily persistent across worlds (after which changes are saved to the original world when you disable it or disconnect)?

    Additionally, could you add a command to make someone's inventory persistent when they die? (Is that even possible? And it can't conflict with Tombstone either) And optionally an additional permission for making it apply automatically upon login/world change. This could be useful on the creative world on my server.
  12. Offline


    Thx!! i love it! this made my day!^^
  13. Yay things to do. First should be possible. I'm working on the new method of storing data which will make this much easier as I'll be able to store some more information on inventories if I choose to.

    But the second request confuses me... doesn't that just mean not lose items on death? I can't really work out what you were doing.
  14. Greetings, your plugin looks really good and we want to use it to block people of bringing items from the creative world.
    But when your plugin is loaded it says that 2 of 4 worlds are non-existant (they work perfectly for any other plugin) and the two other worlds seem ok, but won't share their inventory.
    The config file looks like this:
    world, faraway, nether,
  15. I'm going to guess that your problem is the trailing commas on each line. I suspect it's making the plugin look for two worlds named (blank)

    Edit: Oh, and you don't need to list the world using its own inventory, just the ones sharing. So your shares.txt would look like this:

    world, faraway, nether
  16. sry, that wasn't the problem.
    The plugin still claims the worlds wouldn't exist.
  17. Offline


    I installed this plugin yesterday, but for whatever reason; it doesn't work.

    Whenever I enter another world by portal or by command, I still keep my items.
    I use MultiVerse.
  18. Offline


    i've been getting a null pointer error every time a user disconnects. it doesnt seem like its really affecting anything, as it's caused no real trouble. however i get
    "Could not pass event PLAYER_QUIT to multiInv."
    i'm running craftbukkit 670, multiInv 1.5.2, and quite a few other mods. might it just be a change in the "player_quit" event? if you'de like me to i can post a log etc.
  19. Which two worlds are they? Are you sure you've spelt them correctly... and does it later say that shares.txt loaded?

    Doesn't work at all? That seems very odd... it should work with MultiVerse as well. Are there any errors at all in the console when you start the server?

    You may have discovered an important error here... some people have had trouble with inventories not saving properly when people log out and back on in a short time.

    Can you post the entire stack trace to me? As in the entire error.
  20. I post the complete log:

    2011-04-12 13:56:35 [INFO] [MultiInv] shares.txt contains minor non-existant world faraway
    2011-04-12 13:56:35 [INFO] [MultiInv] shares.txt contains minor non-existant world nether
    2011-04-12 13:56:35 [INFO] [MultiInv] Shared worlds loaded succesfully
    2011-04-12 13:56:35 [INFO] [MultiInv] version 1.5.2 is enabled!
  21. Offline


    i've tested a bit, i get this whenever i log out, but only if my inventory has changed. if i log in, and log out without changing anything, i dont get the error, but if i drop something or add something, i get this.
    i'll post you all my addons and versions if you need them in a little bit, going out to get lunch so i'll be back later.

    Attached Files:

  22. Offline

    Don Redhorse

    there is a plugin for that... linked chest or similar iirc which will link chest via signs
  23. Offline


    hiramas, attach your shares.txt, and tell me the names of the worlds your server currently has running. i could give you a quick hand with this.
  24. Offline


    This is the error I get
    2011-04-11 18:57:04 [SEVERE] Could not pass event PLAYER_TELEPORT to MultiInv
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.NetServerHandler.teleport(
        at org.bukkit.craftbukkit.entity.CraftPlayer.teleport(
        at com.onarandombox.Rigby.MultiVerse.MVPlayerListener.onPlayerMove(
        at org.bukkit.plugin.RegisteredListener.callEvent(
        at org.bukkit.plugin.SimplePluginManager.callEvent(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.Packet10Flying.a(SourceFile:126)
        at net.minecraft.server.NetworkManager.a(
        at net.minecraft.server.NetServerHandler.a(
        at net.minecraft.server.NetworkListenThread.a(SourceFile:100)
        at net.minecraft.server.MinecraftServer.h(
    By the way, I use cb670.
  25. Hm... this may actually be a bug based around how the shares load... I'm working on a major new version that I'm hoping will rid me of these bugs once and for all (but I'm willing to bet bugs shall remain elsewhere)

    Erm... how sure are you that you've downloaded 1.5.2.... or that you don't have an old version still in the plugins folder...I thought I'd fixed that error and the line numbers in the error correspond to an older version of the plugin... I'm also amazed that you haven't noticed the error changing worlds... (unless you currently only have shared worlds... then you'd never see it)

    Erm... are you using version 1.5.2??? If you are and you have this problem then I've seriously messed up somewhere because that shouldn't be happening...

    I'm working on the new code now... so if it is a bug I'm hoping to have fixed it by then

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  26. Offline


    haha, yes thats my fault. i accidentally clicked 1.5.0b instead of "latest jar" should be good now, thanks for the help :D
  27. Offline


    nope unfortunately :(
  28. Offline


    How do you install plugins then? :confused:
  29. Offline


    I am kind of curious of this myself. If you cannot upload files to the server how do you do anything on the server at all. You have to have some sort of upload option Cpanel,Insim, a Webapp of some sort. How did you install the server to begin with ?
  30. Offline


    FTP but i cant run exes. and the host came with a stop/restart button i cant activate the exes personally or close the server i can just press the button to terminate/restart it :p
Thread Status:
Not open for further replies.

Share This Page