Inactive [MECH] MultiInv V2.4.1 - Per World Inventories [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Pluckerpluck, Feb 17, 2011.

Thread Status:
Not open for further replies.
  1. 1) Well, on first log in (with my plugin) your current inventory will be save to which ever world they log on in (which with one world is the Main Map).

    2) I will add the multiple player names because it's a good idea... it just is... I'll probably make it the default as well with an option to override it to a single file if people prefer that.

    3) The best I can do is create a programming api that will let other programs change the inventory data I have stored... because there's no proper way to store multiple inventories... I've made my own system.... But the api (if I make it) would return a bukkit inventory so it could be edited almost the same way that another system would do it... the only addition is the plugin would have to save the changes to multiInv.

    But if I do plan to leave this project I'm hoping I can give it up to someone else officially so that it doesn't just die... for example, I have a feeling that MultiVerse will add an inventory system at some point in the future. But with open source code I'm sure it wouldn't be too hard to updated by someone else. Especially as this is getting closer to the point where it will be stable over many bukkit releases as there isn't much to break (and what can is easily fixable).

    The problem is with no proper way to store inventories (as of now) any plugins that do so will conflict.... but I'd be more than happy to co-operate with another dev to help transfer inventories from one system to another... allowing my plugin to die gracefully when at the end of its life.
  2. Offline


    I've installed this and it works fine, except for the sharing between multiple worlds. My /plugins/MultiInv/shares.txt looks like this:

    But all 4 worlds want to keep their separate inventories when I warp between them.

    EDIT: Figured it out. Need a space after the comma. It would be nice if it wasn't that specific.
  3. Offline


    Was testing a import of a old dat file.

    Tried the delete command on myself player not found.

    Tried copying my old dat in MultiInv overwrote it when I logged in.

    Only way I could get the old dat file for my player in with items etc was to rename

    Make a blank one load my old inv and rename the old file back after I had my items on me.

    Which of course as mentioned is not a good way to do it.

    If each player was separate I would just delete my multi inv player file copy my old dat file into players and login again.

    As someone above my initial post also mentioned they had a corrupt multi inv player file.

    I was just testing a border with the old inv which you will keep your items but be teleported to spawn if you are outside the border which is fine as its just going to be a central hub mby 100 blocks from spawn in each direction or so.

    Be nice if there was just a player and item converter but didn't do location data.
  4. Yea, sorry... I can make it work with just a comma.

    As I said there's currently a bug with the delete command. You have to add a " at the end of the name... I've fixed it for the next release but it's reliant on a new recommended build being released.

    So to delete the user Revenger:

    /MultiInv delete Revenger"

    with the trailing "

    But I'll change it to work with separate inventory files... and note they are JUST inventory files... not full player data files. I just have to ensure that I have a way to detect the original inventories.dat file so I can convert it to seperate files.

    And I have no idea what your last line meant...

    P.S. I'm really waiting for a bukkit recommended build to be released... If I update my plugin before it's released then it won't work on the current recommended build which is BAD.
  5. Offline


    Sorry for the late reply, but this worked like a charm for me! Was able to delete the individual player without a problem and the corruption was gone. It wasn't really corruption. Turns out my old /item command wouldn't handle ID's that weren't used and it would immediately crash the client if one was spawned. Upon returning to the world with the unused ID in inventory, the client would again crash. Using the trailing " fixed the repetition and I fixed my /item :). Thanks so much!
  6. Offline


    Last like was just a be nice if there was some tool to just take a players items and import them into your program without there location data.

    So you can just import only there old items.
  7. Offline


    Out of impatience, I have hacked at MultiInv until it loads and runs on the current recommended build (602) without error. I've tested it in only the most perfunctory of ways, but it seemed to work as perfectly as it's always worked. Anybody else who's terribly impatient, have at the files below.

    Attached Files:

  8. Woo, updated... however most people can't run the latest RB because other plugins break...

    But I think I may have fixed the moving item bug..

    Oh @Hakaslak ... I completely forgot about you... I am so sorry... but I have a feeling the problem was fixed in the latest update.

    @Nipper I think I fixed the bug... you may want to test it though. (And be thorough... make sure you can place or use any items you think you have taken across. I was able to "move" items but in reality I'd just eradicated them from existence and my client thought they were still there)

    And I'm working on separate inventory files per player... It's a nice idea but it requires quite a bit of code to change.

    Also @FrozenGhast I thank you for posting the fix. It's quite depressing when such small changes break a plugin. But anyway, I thought I should say thanks and tell you that the current update not only fixes the plugin but also improves the function and fixes a bug. So you will still want to update even though your version works.

    I'm hoping nobody finds a super bug in the new update... as always back up your inventories.

    That was commandbook wasn't it... it did that... but I'm glad to see you got this fixed.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  9. Offline


    Question may sound stupid, but how reliable is this plugin?

    I mean, how big is chance that someone wil lloose their items when teleporting or even manage to keep items from previous world?
  10. Offline


    Considering it's not working at all at the moment, 0% reliable.

    Sarcasm aside, it's great when it's updated. Haven't had a problem with it.
  11. Offline


    It's working for me. I had teleported several times and had separated inventories normally. But friend said he lost pickaxe (which was actually only item he had when he teleported).

    It may be one-time issue or something, but i really don't want to loose items or see people walking with tons of diamonds from creative world. That's why asked.

    It's working for me. I had teleported several times and had separated inventories normally. But friend said he lost pickaxe (which was actually only item he had when he teleported).

    It may be one-time issue or something, but i really don't want to loose items or see people walking with tons of diamonds from creative world. That's why asked.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  12. Offline


  13. Offline


    I think there are not an differences.

    Also, i have found a bug. I have died and respawned in another world (ServerPort bindpoint). But when i teleported back to the world, where i died, i got my items back.
  14. Offline



    I get this when i start up my server:
    12:43:23 [INFO] [MultiInv] Shared worlds loaded succesfully
    12:43:23 [SEVERE] Nag author: 'Pluckerpluck' of 'MultiInv' about the following:
    onWorldLoad has been replaced with a new signature, (WorldLoadEvent)

    Any idea when this will be fixed or if there is a fix already?
    I use Craftbukkit version git-Bukkit-0.0.0-612-g4c7a9e7-b617jnks (MC: 1.4)

  15. Hm... I thought I'd removed that... but you should know that it isn't problem that will stop the plugin working...

    Anyway, I'm going to fully update my test server today and get it working.

    Erm... I think I fixed the only bug where people could transfer items but loosing items... you shouldn't and if you do there's a bug I have to fix.

    I may be able to fix that now because I never could before... I will have to check some things about the respawning event...
  16. Offline


    Any way we can have a manual command to save everyone's inventories? I'm using this and save-all doesn't seem to save them, and I've had lots of complaints after a reboot about inventories reverting back to when they either 1) joined the server that session or 2) warped between worlds.
  17. Great Idea. I'll add that (or I'll see if there's a way to catch the save-all event)
  18. Offline


    Add the WORLD_SAVE event :)
  19. Offline


    On latest 1.5 and also when we were on 1.4 players are having serious issues with various blocks in there inventory.

    I don't know if it is bukkit or your plugin but here is what happens.

    Spawn stone slabs, stone etc

    Place allot.

    Break them replace break again etc

    Pickup, Move them arround.

    As soon you mouse over there is no label and you will crash.

    This seems to be a big bug and I'm getting bugged allot about it even if we are only a test server so I'm letting you know.
  20. please add to CraftBukkituptoDate
  21. Offline


    Is there a chance that player won't get his inventory back when teleporting for the first time? It happened to two of my friends already.
  22. It is on CraftBukkituptoDate... make sure the file is called MultiInv.jar (may or may not be case sensitive)
    There's no reason why they should lose it... I'll look into it.
    I'm pretty sure that my plugin doesn't do anything unless you teleport to another world... it just sits inactive until you teleport, then when you do it checks if you changed world... if you didn't, nothing happens... but who knows... seems more like a client error though...

    Also, atm make sure you shut down the server properly... it saves inventories on the /stop command.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 9, 2016
  23. Offline


    I don't know we had at least 3-5 people confirm this bug.

    It could be a notch bug but was in 1.3 and now 1.4.
  24. Bug on startup...

    I had to rename the MultiInv.jar to zMultiInv.jar for it to work correctly with MultiVerse.

    It was loading too quickly after MultiVerse (before it had actually finished) and not seeing the third world. I was having to do a /reload to get it to recognise the third world.

    Renamed with a z prefix makes it load later adn no problems.
  25. That is a very strange problem... are you sure about that because it will look like it fails if it doesn't catch the worlds first time but it should try to reload the shares.txt every time a new world loads... and except for the shares.txt it works with worlds as people teleport to them.

    In what way does it not recognise the world? Not shared?

    Note: My plugin currently doesn't check to see if the teleport event is if you have a plugin that restricts teleports from OTHER plugins then this may not work. Fixing that for next release.
  26. Offline


    Thank you for that. Oddly enough /stop never showed up on any list of server commands I looked at online. That definitely fixed the problem. Saving inventory on save-all would definitely be good as well though.
  27. Offline


    I notcied that on my server, when I first go to a world, sometimes the inventory is lost. Maybe it has to do with me dying in the other world as well, but my incentory dissappears . SOmeone else cam eup with the same problem in another world. Any idea why?
  28. I'm going to have to perform some tests with this... Do you die in a world and respawn in a different world? Because that causes some problems that I'm trying to work with right now. But if it is just lost on a new world...

    Btw, how is is lost? Are you going to a shared world first time and the entire inventory is lost? Do you go there and come back to no inventory? Or are you referring to how the inventory you log on with only is saved in the world you first log on in (on first login after plugin)?
  29. Offline


    Well, I had a bunch of stone and stuff in my inventory, and I'm not sure what happened. I dont think it was because it was a new world, because the same thing happened to any other person on my server.
  30. Offline


    I just opened a pull request with this change.
Thread Status:
Not open for further replies.

Share This Page