Inactive [MECH] MultiInv V2.4.1 - Per World Inventories [1060]

Discussion in 'Inactive/Unsupported Plugins' started by Pluckerpluck, Feb 18, 2011.

Thread Status:
Not open for further replies.
  1. Offline


    Currently the world names are case-sensitive which may be the problem. Just to check (as this doesn't happen for me but it may for you), what order do the plugins activate? Does multi-verse run before this plugin? If it doesn't then that could be the problem that I'd have to try and to fix (potentially because you changed the name of the jar file).

    As for the other errors. That may be my fault. Often when the plugin disables itself it breaks something else. So I've asked it to run the world check first now, for the next update which should stop that.

    But I'll work on making the worlds case-insensitive because that could be a major problem.

    Also, there's a change that having only one world on a line is causing a problem because I didn't actually think to test that. I'll try fixing that all now though. Works for me

    Edit: Turns out that isn't case-sensitive... Just to check, you actually need to run multi-verse though for this to work. Something has to create/load the worlds before MultiInv can work with them. But as I have no way to ensure that my plugin loads after them I'm not sure what I can do... unless they're loaded alphabetically.

    I also don't get iConomy breaking, so I'm not sure what the problem you have is... my iConomy loads before MultiInv though
  2. Offline


    World names are fine, do you think i have to chage it to lowercase? I'll try and tell you what happend.

    I think that multiInv is loading before multiverse, I have tried to change MultiInv_1.1.0.jar to XMultiInv_1.1.0.jar to try to force that one to be the last one in load, but it didn't works.

    Code (Text):
    1. 2011-02-20 21:53:15 [INFO] Starting minecraft server version Beta 1.2_01
    2. 2011-02-20 21:53:15 [INFO] Loading properties
    3. 2011-02-20 21:53:15 [INFO] Starting Minecraft server on *:25565
    4. 2011-02-20 21:53:15 [INFO] This server is running Craftbukkit version git-Bukkit-"6743361" (MC: 1.2_01)
    5. 2011-02-20 21:53:15 [INFO] Preparing level "Duendedreams"
    6. 2011-02-20 21:53:15 [INFO] Preparing start region
    7. LWC    [1,491]    Loading shared objects
    8. Config    [1,491]    Loaded 10 config entries
    9. LWC    [1,491]    Native library: lib/native/Linux/amd64/
    10. Updater    [1,491]    Update detected for LWC
    11. Updater    [1,491]    Latest version: 1.53
    12. 2011-02-20 21:53:18 [INFO] [iConomy] version [2.2] (Aime) loaded
    13. 2011-02-20 21:53:18 [INFO] WorldGuard 3.2.2 loaded.
    14. 2011-02-20 21:53:18 [INFO] WorldGuard: No known permissions plugin detected. Using configuration file for permissions.
    15. 2011-02-20 21:53:18 [INFO] WorldGuard: Single session is enforced.
    16. 2011-02-20 21:53:18 [INFO] WorldGuard: TNT ignition is PERMITTED.
    17. 2011-02-20 21:53:18 [INFO] WorldGuard: Lighters are PERMITTED.
    18. 2011-02-20 21:53:18 [INFO] WorldGuard: Lava fire is blocked.
    19. 2011-02-20 21:53:18 [INFO] WorldGuard: Fire spread is UNRESTRICTED.
    20. Factions info:   === INIT START ===
    21. Factions info:   You are running version: 1.0 beta4
    22. Factions info:   Config was loaded from disc
    23. Factions info:   Loading all factions from disc...
    24. Factions debug:  loaded faction 6
    25. Factions debug:  loaded faction 5
    26. Factions debug:  loaded faction 2
    27. Factions debug:  loaded faction 1
    28. Factions info:   Loading all followers from disc...
    29. Factions info:   Loading all boards from disc...
    30. Factions debug:  loaded board -7135056258018194578
    31. Factions debug:  loaded board 3953074513980074435
    32. Factions debug:  loaded board 8148013383954005427
    33. Factions debug:  Cleaning board: -7135056258018194578
    34. Factions debug:  Cleaning board: 3953074513980074435
    35. Factions debug:  Cleaning board: 8148013383954005427
    36. Factions info:   === INIT DONE (Took 95ms) ===
    37. 2011-02-20 21:53:18 [INFO] WorldEdit 3.2.2 loaded.
    38. 2011-02-20 21:53:18 [INFO] WorldEdit: No known permissions plugin detected. Using configuration file for permissions.
    39. 2011-02-20 21:53:18 [INFO] [Permissions] version [1.9] (Handler) loaded
    40. 2011-02-20 21:53:18 [INFO] [General] version [2.1] (Salvez) loaded
    41. 2011-02-20 21:53:18 [INFO] [AntiBuild] version [1.0] (Reborn) loaded
    42. 2011-02-20 21:53:18 [INFO] [iChat] version [1.5] (Maria Holic) loaded
    43. tiredman version 0.4.1 [TODO CORRECTO]
    44. iConomyChestShop version 0.5 is enabled!
    45. Updater    [1,491]    Update detected for LWC
    46. Updater    [1,491]    Latest version: 1.53
    47. LWC    [1,491]    Loaded command: /lwc -admin
    48. LWC    [1,491]    Loaded command: /lwc -create
    49. LWC    [1,491]    Loaded command: /lwc -free
    50. LWC    [1,491]    Loaded command: /lwc -info
    51. LWC    [1,491]    Loaded command: /lwc -p
    52. LWC    [1,491]    Loaded command: /lwc -modify
    53. LWC    [1,491]    Loaded command: /lwc -unlock
    54. LWC    [1,491]    Loaded command: /lwc -owners
    55. LWC    [1,491]    -> PLAYER_QUIT
    56. LWC    [1,491]    -> ENTITY_EXPLODE
    57. LWC    [1,491]    -> BLOCK_INTERACT
    58. LWC    [1,491]    -> BLOCK_DAMAGED
    59. LWC    [1,491]    Using Nijikokun's permissions plugin for permissions
    60. LWC    [1,491]    Loading SQLite
    61. PhysDB    [1,491]    Creating physical tables if needed
    62. MemDB    [1,491]    Creating memory tables
    63. SQLite    [1,491]    Using: Pure
    64. 2011-02-20 21:53:19 [INFO] [MultiInv] version 1.1.1 is enabled!
    65. 2011-02-20 21:53:19 [INFO] [MultiInv] shares.txt contains major non-existant world INFIERNO
    66. 2011-02-20 21:53:19 [INFO] [MultiInv] shares.txt contains major non-existant world outworld
    67. 2011-02-20 21:53:19 [INFO] [MultiInv] Plugin disabled.
    68. 20-feb-2011 21:53:20 org.bukkit.craftbukkit.CraftServer loadPlugins
    69. GRAVE: com/nijikokun/bukkit/Permissions/Permissions (Is it up to date?)
    70. java.lang.NoClassDefFoundError: com/nijikokun/bukkit/Permissions/Permissions
    71.     at com.nijikokun.bukkit.iConomy.iConomy.setupPermissions(
    72.     at com.nijikokun.bukkit.iConomy.iConomy.onEnable(
    73.     at
    74.     at
    75.     at org.bukkit.plugin.SimplePluginManager.enablePlugin(
    76.     at org.bukkit.craftbukkit.CraftServer.loadPlugin(
    77.     at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    78.     at net.minecraft.server.MinecraftServer.e(
    79.     at net.minecraft.server.MinecraftServer.c(
    80.     at net.minecraft.server.MinecraftServer.d(
    81.     at
    82.     at
    83. Caused by: java.lang.ClassNotFoundException: com.nijikokun.bukkit.Permissions.Permissions
    84.     at$
    85.     at Method)
    86.     at
    87.     at
    88.     at java.lang.ClassLoader.loadClass(
    89.     at java.lang.ClassLoader.loadClass(
    90.     ... 12 more
    91. 2011-02-20 21:53:20 [INFO] Done! For help, type "help" or "?"
    Edit: Same with lowercase world names.
  3. Offline


    Ok, I have a plan for this... I'm going to make another txt file called plugins... and in it I'll place the names of all the plugins that I know will need to load first. If any plugin in the list loads, then my world check will run. If they don't then there's no multiworld. Might take a bit to get working though. I'll have a check...

    Edit: What OS are you on?
  4. Offline


    Great, but I think it's more complicated than it seems.
    Anyway, here you have a beta tester ;)

    Thanks a lot by care.
    --- merged: Feb 20, 2011 9:45 PM ---
    Ubuntu 64 10.10
  5. Offline


    That's a really odd problem because I have the same OS and it works fine for me... but I haven't quite worked out how bukkit loads plugins...

    Anyway, I've posted a potential fix. It will fail loading shared worlds the first time (but not disable plugin) and then when it detects MultiVerse it will try load them again. I really do not know what that other problem is... but as my plugin doesn't disable anymore (at least I don't think it does) there's a low chance that's the problem...

    Edit: I'll add this check for permission Plugins as well in the future as you may also be stuck with having to use op.txt powers. Atm, that isn't too bad though (as you can only use /MultiInv delete)
  6. Offline


    There is no error now! but shared invetories doesn't work yet.
    Code (Text):
    1. 2011-02-20 23:43:58 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugin for permissions.
    2. 2011-02-20 23:43:58 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    3. 2011-02-20 23:43:58 [INFO] Minecart Mania Core version 0.93 is enabled!
    4. 2011-02-20 23:43:58 [INFO] [MultiInv] shares.txt contains minor non-existant world INFIERNO
    5. 2011-02-20 23:43:58 [INFO] [MultiInv] shares.txt contains major non-existant world outworld
    6. 2011-02-20 23:43:58 [INFO] [MultiInv] Failed to load shared worlds
    7. 2011-02-20 23:43:58 [INFO] [MultiInv] version 1.1.3 is enabled!
    8. 2011-02-20 23:43:58 [INFO] [MYWARP]: 7 warps loaded
    9. 2011-02-20 23:43:58 [INFO] [MYWARP] Permissions enabled.
    10. 2011-02-20 23:43:58 [INFO] MyWarp 1.9 enabled
    11. 2011-02-20 23:43:58 [INFO] [MultiInv] Detected MultiVerse. Reloading shares.txt
    12. 2011-02-20 23:43:58 [INFO] [MultiInv] shares.txt contains minor non-existant world INFIERNO
    13. 2011-02-20 23:43:58 [INFO] [MultiInv] shares.txt contains major non-existant world outworld
    14. 2011-02-20 23:43:58 [INFO] [MultiInv] Failed to load shared worlds
    15. 2011-02-20 23:43:58 [INFO] [MultiVerse] Loading World & Settings - 'INFIERNO' - NETHER
    16. 2011-02-20 23:43:59 [INFO] [MultiVerse] Loading World & Settings - 'outworld' - NORMAL
    17. 2011-02-20 23:44:00 [INFO] [MultiVerse] Loading World & Settings - 'Duendedreams' - NORMAL
    18. 2011-02-20 23:44:00 [INFO] [MultiVerse] - Version 0.5.4 Enabled
  7. Offline


    Damn, it tries to load the worlds before MultiVerse does! Even though it detects it.I'll see if I can figure out how to remedy that... until then. Try renaming:
    MultiVerse -> zMultiVerse
    MultiInv -> aMultiInv
    or the other way around. Might help...
    --- merged: Feb 20, 2011 11:50 PM ---
    This time, I'm sure I fixed it.... try the new jar file and tell me if it works...
  8. Offline


    Sure? xDDD
    Code (Text):
    1. 2011-02-21 07:57:07 [INFO] WorldEdit 3.2.2 loaded.
    2. 2011-02-21 07:57:07 [INFO] WorldEdit: No known permissions plugin detected. Using configuration file for permissions.
    3. 2011-02-21 07:57:08 [INFO] [Permissions] version [1.9] (Handler) loaded
    4. 21-feb-2011 7:57:08 org.bukkit.plugin.SimplePluginManager loadPlugins
    5. GRAVE: Could not load plugins/MultiInv_1.2.0.jar in plugins: null
    6. org.bukkit.plugin.InvalidPluginException
    7.     at
    8.     at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    9.     at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    10.     at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    11.     at net.minecraft.server.MinecraftServer.e(
    12.     at net.minecraft.server.MinecraftServer.c(
    13.     at net.minecraft.server.MinecraftServer.d(
    14.     at
    15.     at
    16. Caused by: java.lang.NoSuchMethodException:<init>(org.bukkit.plugin.PluginLoader, org.bukkit.Server, org.bukkit.plugin.PluginDescriptionFile,,, java.lang.ClassLoader)
    17.     at java.lang.Class.getConstructor0(
    18.     at java.lang.Class.getConstructor(
    19.     at
    20.     ... 8 more
    21. 2011-02-21 07:57:08 [INFO] [General] version [2.1] (Salvez) loaded
    22. 2011-02-21 07:57:08 [INFO] [AntiBuild] version [1.0] (Reborn) loaded
    23. 2011-02-21 07:57:08 [INFO] [iChat] version [1.5] (Maria Holic) loaded
    24. tiredman version 0.4.1 [TODO CORRECTO]
    25. iConomyChestShop version 0.5 is enabled!
    26. Updater    [1,491]    Update detected for LWC
    27. Updater    [1,491]    Latest version: 1.53
    28. LWC    [1,491]    Loaded command: /lwc -admin
    29. LWC    [1,491]    Loaded command: /lwc -create
    30. LWC    [1,491]    Loaded command: /lwc -free
    31. LWC    [1,491]    Loaded command: /lwc -info
    32. LWC    [1,491]    Loaded command: /lwc -p
    33. LWC    [1,491]    Loaded command: /lwc -modify
    34. LWC    [1,491]    Loaded command: /lwc -unlock
    35. LWC    [1,491]    Loaded command: /lwc -owners
    36. LWC    [1,491]    -> PLAYER_QUIT
    37. LWC    [1,491]    -> ENTITY_EXPLODE
    38. LWC    [1,491]    -> BLOCK_INTERACT
    39. LWC    [1,491]    -> BLOCK_DAMAGED
    40. LWC    [1,491]    Using Nijikokun's permissions plugin for permissions
    41. LWC    [1,491]    Loading SQLite
    42. PhysDB    [1,491]    Creating physical tables if needed
    43. MemDB    [1,491]    Creating memory tables
    44. SQLite    [1,491]    Using: Pure
    45. BorderGuard Lite (Round) version 2.0 is enabled!
    46. Loaded HotSwap version 4 by Zenexer.
    47. PlgSetspawn version 2.1 is enabled!
    48. Take yourself wonder by wonder, using /magiccarpet or /mc. Magic Carpet version 1.1 is enabled!
    49. 2011-02-21 07:57:09 [INFO] WorldGuard: Permissions plugin detected! Using Permissions plugin for permissions.
    50. 2011-02-21 07:57:09 [INFO] WorldEdit: Permissions plugin detected! Using Permissions plugin for permissions.
    51. 2011-02-21 07:57:09 [INFO] Minecart Mania Core version 0.93 is enabled!
    52. 2011-02-21 07:57:09 [INFO] [MYWARP]: 7 warps loaded
    53. 2011-02-21 07:57:09 [INFO] [MYWARP] Permissions enabled.
    54. 2011-02-21 07:57:09 [INFO] MyWarp 1.9 enabled
    55. 2011-02-21 07:57:09 [INFO] [MultiVerse] Loading World & Settings - 'INFIERNO' - NETHER
    56. 2011-02-21 07:57:10 [INFO] [MultiVerse] Loading World & Settings - 'outworld' - NORMAL
    57. 2011-02-21 07:57:11 [INFO] [MultiVerse] Loading World & Settings - 'Duendedreams' - NORMAL
    58. 2011-02-21 07:57:11 [INFO] [MultiVerse] - Version 0.5.4 Enabled
  9. Offline


    It may have confused you because I never changed the threads title. But I'm pretty sure that this is being caused because you haven't updated craftbukkit.

    It does say in the OP at the top... but download version 1.1.4 instead if you haven't updated your craftbukkit yet due to other plugins breaking.

    And please give me good news and tell me that's the problem...

    Note: I remember you said you were using build 345. If so, download 1.1.4
  10. Offline


    I't works fine for me now :) thanks a lot!
  11. Offline


    How can i link the Nether with a normal world?
    Because it works only for me like this:
    DefaultWorld --> NetherWorld

    But it has to be this:
    DefaultWorld <--> NetherWorld

    So when i go to the nether, i got my items from the default world.
    I take some netherrack, go back, and my items are the same as Before... (without netherrack)

    Did i something wrong?

    ive tryd this too:
    DefaultWorld --> NetherWorld
    NetherWorld --> DefaultWorld
    but then it says:
    2011-02-26 10:53:41 [INFO] [MultiInv] shares.txt contains multiple instances of Nether
    2011-02-26 10:53:41 [INFO] [MultiInv] Failed to load shared worlds
    2011-02-26 10:53:41 [INFO] [MultiInv] version 1.1.4 is enabled!

    So then it still only works like this:
    DefaultWorld --> NetherWorld
  12. Offline


    I'm having a simliar problem to the above poster.

    I want world2,3,and 4 to share inventory. completely. If you collect 4 dirt in world 2, and then go to world 3, you have 4 dirt there too. BUT if you pick up 3 cobble in world 3, I want it in world 2. None of this "Major" stuff.

    How do I do that? Nothing I've done has worked.
  13. Offline


    This is exactly what I need to merge the creative and survival server we are currently running (can't have people bringing their creative inventories to the survival world!), except for one thing... I can't have people losing their hard earned items on the survival server.
    The server merge is currently way overdue and the creative server is still running on hMod on 1.2_02, so since 1.3 came out people have been unable to play on the creative server. Could you please fix the first time run thing soon so I can finally merge the servers? This is exactly the plugin I've been looking for since multi world support was initially added.
  14. Offline


    The problem I'm getting is people losing their stuff when the server restarts...any reason why?
    btw, it only happens to SOME people, other people are unaffected...
  15. Offline


    Same here, inventories seem to be locked to the point when the plugin was first used. Now when someone logs in they are given whatever they had at that point. Anything they collect during their session is lost when the log out. Not making my survival players happy at me. :s

    bukkit 447
  16. Offline


    If the server stops, then inventorys on the none default map get erased

    Bukkit 440
    MultiInv 1.1.1
  17. Offline


    Sorry, I was away on holiday over the last week. I have a feeling I forgot to ensure that inventories were saved on plugin disabled.... (I think I'd assume that users were auto logged out... guess not) I can fix that for the next update.

    Also, I really REALLY want to change the way that I save the inventories (will almost certainly fix the problems people have above which I'll look into). However until I create a way to convert the current system over to the new I probably won't implement it (I'll still look into the other problem though).... It's meant to share inventories... not sure why it won't...
    --- merged: Feb 28, 2011 1:23 AM ---
    Just wondering... do they lose their session if they log out whilst in the "main" world? Tomorrow I'll look into this problem but if you can answer this before then it may speed up my debugging process.
    --- merged: Feb 28, 2011 2:36 AM ---
    Final edit... If willing, try removing the after adding the worlds in shares.txt... I have a feeling I know what the problem is and that "may" fix it.
  18. Offline


    I had the same inclination and deleted the and now it seems to be working properly. At least the inventories aren't being reset. It isn't sharing worlds though, which isn't as big of a deal.
  19. Is there a way to install this without loosing players inventories?
  20. Offline

    Tyler Ferm

    NAG NAG NAG!!!! [​IMG] just thought when you had time you could fix this =D

    Code (Text):
    1. 2011-02-28 15:02:39 [WARNING] Using the stupidly long constructor
    2. ckerpluck.MultiInv.MultiInv(PluginLoader, Server, PluginDescriptionFile, File, F
    3. ile, ClassLoader) is no longer recommended. Go nag the plugin author of MultiInv
    4.  to remove it! (Nothing is broken, we just like to keep code clean.)
    5. 2011-02-28 15:02:39 [INFO] Hint! It's probably someone called 'Pluckerpluck'
  21. Offline


    New update: Unfortunately you'll have to remove the current didn't intend that to change but it did.

    Pretty sure that was fixed in version 1.2... definitely fixed in 1.3
    Current inventory is now stored as the inventory for the world they're in (may change that to a configurable
    default world later)
    Should be fixed.. unless the server crashes or another plugin stops MultiInv disabling (because it has caused an error
    I think I fixed this, try now.
  22. Offline


    Installed the plugin, worked fine for a while... but... then I noticed I had my creative inventory in the nether instead of the survival inventory. Someone else also experienced the same thing, and another person reported his survival inventory being brought over to creative, and afterwards stayed the same no matter where he went, then somehow changed back.

    My shares.txt is:
    Code (Text):
    1. survival, nether
    2. creative
    Tried restarting the server, and I still have my creative inventory in the nether instead of my survival inventory.
  23. Offline


    Still not working,
    I get this error when i start the server,
    I've tried:
    And only:
    But i get the same error.
  24. Offline


    I get the same error. bukkit 448.

    If I take everything out of shares.txt it doesn't happen and per world inventories are working. I can live with that for now since nether portals aren't functional on my server now anyway.
  25. Offline


    My Nether portals works fine.
  26. Offline


    Have you tried removing the The 1.3 update requires removal of the which I didn't originally intend.

    Someone had to go and find a bug where I haven't a clue what the problem is... to lower the number of potential problems if a world doesn't share it's inventories with another, don't put it in the shares.txt
    ... it may have something to do with how I check to see if you've changed worlds (as there's not proper way at the moment) and a mix of that and server lag... not sure though... there's no reason for it to work for a while then fail...
  27. Offline


    "Have you tried removing the The 1.3 update requires removal of the which I didn't originally intend."

    Yes. I've deleted the inventories file after each update to see if it solves the problem. It seems to straighten things out for a while. I'll be away for a week but if my users report any more issues I'll let you know.
  28. Offline


    Ive tried it again after deleting, and i don't get the error anymore.
    BUT: it's the same again, only NewWorld --> Nether works.
  29. Offline


    D: you're right... but it was working before.... more trouble shooting then...

    Wait: I was testing without world sharing... testing again...

    Ok, I don't have this problem... you're definitely on the latest version... and you deleted I can't work out what the problem could possible be...

    Edit: Ok I know the problem... I don't have it due to the alphebeticity of my world names
    --- merged: Mar 1, 2011 5:48 PM ---
    @Jelle try it now. I think the new version will fix the problem. It seems to work for me...
  30. Offline


    HELL YEA!!!
    Thanks man! it's working now :)
    Dam, they will be happy to go to the Nether again XD
Thread Status:
Not open for further replies.

Share This Page