Inactive [MECH] MiningTNT v0.4 - Choose what TNT destroys [1.2.4]

Discussion in 'Inactive/Unsupported Plugins' started by Taco, Feb 6, 2011.

  1. Offline


    Mining TNT v 0.4

    What this plugin does:
    This plugin simply changes TNT to affect only what you want it to. This is so that people can use TNT to mine without the worry of greifing.

    - Causes TNT to destroy only stone by default
    - Other blocks can be added to what can be destroyed by TNT.
    - Allows height restrictions for TNT.
    - All settings can be found in
    - Creeper nerf can now be toggled on and off.
    - Adjustable block yield.
    - TNT can either set off other TNT or destroy it.

    Download MiningTNT (.jar)

    Show Spoiler

    - Initial release.
    - Added ability to select blocks dropped.
    - Added height restrictions.
    - Fixed creepers acting like TNT.
    - Fixed block destruction system.
    - Indestructible blocks such as Adminium can no longer be destroyed with TNT.
    - Creepers can act like TNT.
    - Updated for beta 1.3
    - No more stupidly long constructor message.
    - Fixed all ore/mineral drops.
    - Fixed a conflict with HigherExplosives.
    - Fixed TNT chaining
    - Added more options to the config
    - Moved config file to plugins/MiningTNT

    MuttsNuts likes this.
  2. Offline


    I prefer to either write plugins from scratch or not at all, I'm not much for updating other's plugins. >.<
  3. Offline


    I was actually implying just looking at his source and seeing where the conflict is happening, and seeing if you could work around it.
  4. Offline


    Doesn't seem to work after Beta 1.3 update.
  5. Offline


    yeah... too bad
  6. Offline


    Working on fixing it.
  7. Offline


  8. Offline


    Fixed, it just needed to be recompiled with the latest bukkit files. Updating the first post accordingly shortly.
  9. Offline


    i still get the stupidly long constructor message. plz fix
  10. Offline

    Soul Reaper

    I do not have any sort of config file. The plugin is loaded though
  11. Offline


    I have a question about config file. Is altitude 70 means sea level?
  12. Offline


    I just felt that 70 was an acceptable number, you can change it as you see fit.

    Also, I've updated this to fix the stupidly long constructor message. Updating is not mandatory.
  13. Offline


  14. Offline

    Lee Hayward

    Could you provide a wiki or readme for this plugin.. What exactly is the maximum altitude settings? Great plugin btw. Thanks!
  15. Offline


    Confirming this as well on b450 (I know it's not the recommended build, but it contains bugfixes I want.)
  16. Offline


  17. Offline


    long constructor with b441 as well.
  18. Offline


    how about an update for the recommended build. you are a little behind
  19. Offline


    I'm not sure if I'm an idiot or what, but I just installed this plugin and it didn't autocreate anywhere? Am I just not seeing it?

    EDIT: It's a RAR, not a JAR. I blame it on not wearing my glasses. Anyway, it gives the InvalidPlugin thing posted a few posts above when I try to actually load the right file. Build version b483.

    2011-03-02 04:14:16 [SEVERE] Could not load plugins/MiningTNT.jar in plugins: n$
            at org.bukkit.plugin.SimplePluginManager.loadPlugin(SimplePluginManager$
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManage$
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(
            at net.minecraft.server.MinecraftServer.e(
            at net.minecraft.server.MinecraftServer.a(
            at net.minecraft.server.MinecraftServer.d(
    Caused by: java.lang.NoSuchMethodException: com.FriedTaco.taco.MiningTNT.Mining$
            at java.lang.Class.getConstructor0(
            at java.lang.Class.getConstructor(
            ... 8 more
    I am no expert - in fact I'm a total idiot about this stuff - but what's java.lang.Class.getConstructor0? With a 0 at the end? Is a fix as simple as a typo?
  20. Offline


    Cheers to dev for including the .java source in the jar :)

    I fixed it.. but now the offiicial dev has updated it..
  21. Offline


    I already fixed this, I guess I forgot to upload it though. My bad. XD
    Manji and GarethNZ like this.
  22. Offline


    I have a small plugin I have wrote for my private server.

    I can't figure out how to fix this error:

    21:55:59 [SEVERE] Could not load plugins/MiningTNT.jar in plugins: null
    at org.bukkit.plugin.SimplePluginManager.loadPlugin(
    at org.bukkit.plugin.SimplePluginManager.loadPlugins(
    at org.bukkit.craftbukkit.CraftServer.loadPlugins(
    at net.minecraft.server.MinecraftServer.e(
    at net.minecraft.server.MinecraftServer.a(
    at net.minecraft.server.MinecraftServer.d(
    Caused by: java.lang.NoSuchMethodException: com.FriedTaco.taco.MiningTNT.MiningTNT.<init>()
    at java.lang.Class.getConstructor0(
    at java.lang.Class.getConstructor(
    ... 8 more

    What do I need to know? Please?
  23. Offline



    I can only suggest you need THE LATEST craftbukkit (build ~490+), and you NEED the Permissions plugin installed as well.
  24. Offline


    I'm going to assume you haven't set up your plugin.yml correctly here and/or you didn't do your commands right. I'll link you to the thread about the change in how commands work.

    Edit: Here's the thread, read through it (not just the first post) and it should help you out:
  25. Offline


    Thanks. I am pretty sure this is what I was missing.

    I had fixed the long constructor, I had fixed the PLAYER_COMMAND issue but after that I was just lost.
    I do have my plugin.yml setup correctly but ... the post you posted I did not do. Thank you again.
  26. Offline



    With this plugin loaded TNT doesn't destroy anything. Not even the blocks in the "DestroyTheseBlocks" field.
    The TNT blows up and all blocks around it remain.

    I am running Mining TNT 0.2 and the latest recommended build of craftbukkit 493

    This is my Mining TNT properties file
    Mining TNT v 0.1 configuration
    Add item ID's sparated by spaces for them to be affected by TNT.
    //DestroyTheseBlocks=1 2 3 4 17
    DestroyTheseBlocks=1 2 3 12 13
    TNT destroys the blocks when the plugin isn't running. Is there something I have wrong in these settings?

    EDIT: It's ok. Fixed it. I must have been too high in the map. Changed MaxAltitude to 128 and now it works where I was.
  27. Offline


    Okay, been toying around with your plugin for a few days, and I kinda like it. One huge issue for me though: TNT does not chain together like it should. Dunno how to change that myself, and I don't know if other people get the same issue, but I would really like to see chain mining working again.
  28. Offline


    what if you add the ID for the TNT block to the properties file?
  29. Offline


    Manji, that wouldn't work, because it just drops the TNT drop instead of setting it off (I just tried it).

    Also ran into the problem of using this on things like redstone ore and diamond ore, as destroying them with TNT makes them drop redstone ores and diamond ores, instead of powder and diamonds, respectively. This is problematic, because neither of them is smeltable, so there's no way of getting the intended drops out of them.

    EDIT: OK, I take that back. Diamond can be smelted. Redstone cannot, however. I just found out coal cannot either. And who knows if using it on gravel would make it drop flint like it's supposed to now and then? It would be nice if they dropped their intended drops.

    EDIT2: OK, so I was looking at the source (THANK YOU TACO FOR INCLUDING THAT!), and it seems it would be very easy to add in the proper drops for Diamonds and Coal and Redstone ores. Making TNT chain might be a little harder, but I only have to look into it a little further. I suspect it's not actually as difficult as I'm thinking.

    EDIT3: Wow, this is getting long. Anyway, Taco, I was noticing that you used the dropItemNaturally function of getWorld(), so you would think it would drop redstone dust from destroyed redstone ore... Maybe this is a bug that needs to be reported to the Bukkit devs?

    EDIT4: OK, fixed the redstone drops. Now both inactive and active redstone drop dust when destroyed.

    I also managed to figure out how to make TNT chain, but unfortunately the TNT chain seems to be a bug within Craftbukkit itself, as I just tried making a chain without this plugin installed and it actually spawned a third TNT somewhere and blew it up... Very weird...

    OK, so I fixed the diamond, redstone, and coal drops, and also made snow not drop anything, also, TNT can chain, however I would suggest you don't let it, because TNT chaining is buggy in Minecraft server itself. So, here's what I've got, if anyone's interested:

    Of course, all original work credited to Taco, and along with his spirit, source is inside the jar here as well. If/when Taco updates this himself (unless he wants to use mine, which he's welcome to do, just give a little credit :D) to accomplish what I have it accomplishing, I will remove this download.

    OK, so I realized that redstone drops 4 dusts, not 1, and clay also needs to drop clay balls (and four, instead of one), so I'm releasing another small update to address these issues.

    <Edit by Moderator: Redacted mediafire url>

    If anyone is interested, I could make it so glowstone drops a single dust or several, instead of itself (though I can't imagine why anyone would want that...), based on values in the properties file.
    Last edited by a moderator: Dec 15, 2016
    GarethNZ likes this.
  30. Offline


    Updated for recommended build/le bump.
  31. Offline


    Using your mod, works great so far!

Share This Page