Inactive [MECH] MagnetBlock v0.4.7 - Movable Structures controlled by Redstone [1060]

Discussion in 'Inactive/Unsupported Plugins' started by narrowtux, Mar 2, 2011.

  1. Offline


    Hi, i just found a weird bug. Somehow my structure vanished but it's existing because when i push a magnet's button i saw the collision report in the console, so i checked my structure's blocks.csv and i just found that all blocks have been turned to AIR.

    The bug occured twice for now, just to let you know ^^
  2. Offline


    This is happening randomly to me as well. When it does I do a /reload and they reappear, but the blocks all become cobblestone and throw up the "[SEVERE] Block has encountered AIR Type!" Error in the console.
  3. Offline


    Magnet block loads up on Bukkit 602 but previously saved structures no longer appear... will test new structures now.

    P.S. Red Remote working fine on 602


    Tested new structures... Block placement is not registering on bukkit 602. No txt returned and no info stored in file.

    If I try and use /mbfs it returns an internal error message to the console
  4. Offline


    red remote seems to be loading but not magnet block on build 617
  5. Offline


    I'm currently working on it. If you don't miss rotation currently, I can upload the new version. It includes configuration for items and type of the magnet block.
    You can specify which item should do what.
    So for example, you can make an item that does everything:
    this would mean, that the cake-item would push a structure in every direction. The vector (1,1,1) you specified will be multiplied with this unitV((playerLocation-clickedBlockLocation))*itemVector. (If you don't understand math, just don't configure anything ;) it will work without configuration like before).

    Rotation is currently not implemented. I want to provide a configuration where you can specify the transform-matrix for each item. A simple rotation matrix for rotating on the y-axis looks like this:
    [ 0, 0, 1]
    [ 0, 1, 0]
    [-1, 0, 0]
    With this addition, you can scale structures, do complex rotations on multiple axes or ...

    My question is: Is it ok, when I first release the version without rotation and do another update after rotation and this matrix-transformation stuff has been done?
  6. Offline


    well your plugin is broken for now so i think you should update it to work for last recommended build and then edit rotation in the next version..
    your plugin is great so please update :)
  7. Offline


    i agree i never used rotation so just having the structures re appear and move to magnets is fine with me
  8. Offline


    Indeed getting it to work with new versions of bukkit seems like priority to me.
    This is what I consider to be one of the most important plugins on my server, love your work :D
  9. Offline


    Thanks for your patience, version 0.4.2 [602] is up!
  10. Offline


    I just updated this into my server, I had the older version, which worked fine. But with this new version, I encountered an interesting problem.
    I read about the new-semi permissions, but because my server is private for my friends me, I decided not to create the folder. I updated the structure-elevator and it didn't work. Frustrated I went and created a test with one block and one magnet, and it didn't work. So I went and created the semi-permissions folder and just added my name to it, and the test worked, as did the elevator. It's a small problem that was easily fixed, thanks for the great plugin!
  11. Offline


    How can i change the ironblock to an Labis Lazuli block
  12. Offline


  13. Offline


    Can't wait to see this awesome plugin working withe the last recommended build (617) :p
  14. Offline


    Great Plugin! I love it! Would it be possible, Blocks made by Worldedit could be registered? I tried to make a 90.000 Block Gate, but I can´t build them by Hand...
    And maybe, first Magnet is on as long as the Second one is not powered, but this is not really necessary!
    Thank´s for that one.

    Edit: Now I have read it:
    Damn. I just tried to use the Debug mode from World Edit to get the Coordinates of changed blocks, but it doesn´t seem to save them anywhere. So It would only be possible if your Plugin could make a scan of maybe radius 128 first and save all blocks there temporarely. And a second scan would register then all blocks, which have changed.
  15. Offline

    kazuhiro suzuki

    i want to use this plugin in 617:D

    from fukushima
    CyborgOne likes this.
  16. Offline


    me 2 :)

    but have the same problem like CyrussM

  17. Offline


    Amazing plugin, I was looking for one for making a train. But every time I move to the next station, I don't move with the train but go through the glass instead. Help?
  18. Offline


    Do you have got a solid ground? What material is the ground made of? Any information you can give me about your train helps ;)
  19. Offline


    My train is made of stone and glass. The front and the back are glass while the sides are hollow. The corners are made of stone (not cobblestone). The iron block is in the front but down, not in the center of the train. The ground is made of solid stone. When I leave the back made of glass, I just move right through it, but when I make it stone instead of glass, I lose about half a heart. Any help?
  20. Offline


    using magnet block 0.4.2 and bukkit 670, one of my users has a 3 tall 1 wide/depth bookcase that he uses to conceal an entrance but when ever the server reloads or using the essentials plugin suite to restart the plugins without restarting the whole server causes the structures to encounter air and convert to cobblestone.
  21. Offline


    Is this working with 670?
  22. Offline


    Yes, I just didn't marked it as working for it ;)
  23. Offline


    yay 670 :D i made a airshow lol
  24. Offline


    @narrowtux i have noticed that after time the plugin stops working and the server needs a reboot.

  25. Offline


    Hey, I am having a problem. I have created a very big port which I am trying to move up into the air so that ships would be able to enter through it. (it's an entrance to a harbour)
    I noticed that with magnet blocks, I am only able to move things on sides, and not up and down. I've tried with both small objects and my big entrance. The entrance is made up of wood and fences, but it won't even move one block..
  26. Offline


    You have to use the stick to move up/down. I seperated it to prevent unintended up/down-movements.
  27. Offline


    so I can't move stuff up and down with magnets?
    Also, it doesn't move when I hit it with the stick :p
  28. Offline


    Have you tried to reload with /reload? Sometimes the structures have a little glitch after they've been built. When you reload the plugin, it should work.
  29. Offline


    umm no :p I'm kinda new to bukkit. Do I just typ /reload in game?
  30. Offline


    Yup, that's a builtin command.
    Also the /plugins commands is included, which shows you the installed plugins on the server. It's quite useful to see the plugins that are installed on a server

Share This Page