Inactive [MECH] MagnetBlock v0.4.7 - Movable Structures controlled by Redstone [1060]

Discussion in 'Inactive/Unsupported Plugins' started by narrowtux, Mar 2, 2011.

  1. Offline


    Hey There!

    Is it possible to let the structure rotate with redstone?
    if yes, how?:)

    Schöne Grüße;)
  2. Offline


    No that's not implemented at the moment, but it's planned.
  3. Offline


    @narrowtux Resolved the issue :) The jar seemed to have a space in it somewhere that caused errors when saving. Thanks for the help [cake]
  4. Offline


    thanks for the quick answer:)
  5. Offline


    Thanks for the cake :D
  6. Offline


    hey there, i love this mod, although i've only just begun using it, i'm having a problem where larger objects seem to stall out and the mod itself seems to just stop working, i'm trying to make a long range monorail that will go between the two main cities on my server, i want it to observe all the scenery between them so i've made the track and thats no problem. the problem is after i make the structure and say hit it with a feather it moves two blocks then stops responding, if i add a magnet it moves two to three blocks in the direction of the magnet then stops moving. i'm not sure what to do because their isn't alot of files to this mod so i'm not sure what to diagnose. I'm running the server on so i have limited access to the actual files. i'm only able to upload .jar files to the plugin directory and i'm able to delete files (but not folders) any suggestions would be much appreciated.
  7. Offline


    That is a common problem. If you've got Essentials, use the command /reload to reload the plugin. Then it will work.
    The thing is that MagnetBlock thinks that there are blocks in the way, but that's not right. If you reload, the "ghost"-blocks will vanish and your structure will move.
    Alternatively, restart the server.
  8. Offline


    thanks for the suggestion, yeah its weird sometimes the reload works sometimes it doesn't but the restart seems to fix it and i haven't had any problem yet with it.
  9. Offline


    your plugin is awesome. I used it to make a train with a 600 block long tunnel between my house and a friend's house
    I also found out that if you make a structure that is a 3 by 3 flat square you can use the follow command to make it into a flying carpet that keeps you up in the air when your walking. I've had no problems with it that reloading the plugins or restarting the server havnt solved. Thanks for the awesome plugin :)
    Edit: Apparently I spoke too soon. I just turned my server on and the whole train disappeared. The "structure" was still there, because when I flipped on the magnets the whole thing appeared out of cobblestone, its just that all the blocks I had made it out of were no longer there
  10. Offline


    That can happen when you don't save properly. How do you shut your server down?
  11. Offline


    I use the stop command, though I may have just exited out of it. good to know why it happened.
  12. Offline


    I just can't seem to get this to work. Every time I try, the structure (I'm trying to make doors) will move a block or two, then stop. There's nothing in the way, it just stops moving. Frustrating. ><
  13. Offline


    Use the /reload command or restart the server, that helps. I will investigate further what causes it and fix it.
  14. Offline


    Have you thought of doing a north/south pole for the magnets? Like, you have a "north" magnet on the ground and a "south" magnet on your structure, and they attract to eachother. The biggest issue I've been running into is that the plugin doesn't seem to care what part of the structure hits the magnet. By using attracting blocks you can make sure the structure ends up where you want it
  15. Offline


    i have this problem to. my theory is that the structure thinks the end of the 32X32 chunk is a wall but i might be wrong
  16. Offline


    Well, I figured out why I was having so many issues. When you create a new structure, it's supposed to tell you to lay your blocks down. Not sure the exact text, but it's something along the lines of "Place your blocks now!" It should also tell you when you've added a block to your structure. Well, if the plugin is hiccuping, it won't actually say anything, neither when you create a structure or when placing blocks. It will still record the structure, but it won't function properly. Just /reload or restart the server until you get the proper messages and you should be fine.

    Any word on fixing the blocks turning into cobblestone?
  17. Offline


    I think there may be some confusion here on the language of the server restart. narrowtux, those of us using are running our servers remotely through MyMcAdmin so we only have the option to restart or stop the server through that server gui.

    The button and /restart through the server have the same results with the structures turning to cobblestone running bukkit 556.

    Is there a possibility that MyMcAdmin compatibility is the issue?

    ***Note*** I installed the PorteCoulissante plugin which makes fences into working gates without commands. It does not have this issue with the restart. Perhaps you could review with the author and see if he had this issue as well.
  18. Offline


    The problem is, that MagnetBlock works with all blocktypes and the other plugin you mentioned uses fences so it doesnt have to check the blocktype. MagnetBlock has to do that because the blocktype is not constant. bukkits getType-method doesnt work every time and returns air instead of the real blocktype.. when that happens, it turns the block into cobblestone so that you can see your structure though.
  19. Offline


    I believe I understand where you are coming from. His most likely checks that specific block type and creates the movable object from it.

    The problem though isn't that we are returning air when placing the blocks but rather that it does not load the saved file on a restart. Before a restart I can open the structure file and it will read with the blocks I placed.

    Immediately after restart I am looking at an identical file but with the block type all replaced by air.

    I have saved all structures and forced a save on the server before restarting it and it will always overwrite the existing file with air when it comes back online.

    So it's not the return I'm having a problem with but the loading of already existing structures.

    Is there a reason that your code would need to search on a server load? Shouldn't it just use the saved file info to create the structure?

    And just to clarify, I still love your plugin and use it extensively for any cobblestone structures that I want to move. Makes an excellent drawbridge.

    Thanks again for all of your hard work and for being the most responsive Plugin Developer I've spoken with.
  20. Offline


    At start, the structure is loaded completely from the file but when it is already saved with false values, it's also cobblestone.
  21. Offline


    But that's just it. The file is correct after I stop the server. But when it is loading it turns to air.

    I am using MyMcAdmin and have tested this repeatedly.

    I save everything and stop the server completely. Open the Structure files and check block type, confirm that everything is set as I placed it.

    Start server... file has changed to air for all blocks.

    I have even changed the file manually prior to server start and saved it with the same result.

    Perhaps this has nothing to do with your plugin or bukkit but with some feature of MyMcAdmin.

    #edit for more info

    I have also done this without moving the structure from it's origin as I thought that perhaps a server autosave during the block movement may have corrupted the blocks but the result was the same.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  22. Offline


    At least, it overwrites the blocks when they are not present then. Can you give me a total list of all your plugins installed?
  23. Offline


    I tested this with Essentials, Runecraft, and Treehugger installed. I believe MyMcAdmin also runs with fakePermissions by default.

    If you would like I would be happy to test this on bukkit without the plugins to see if I get the same results with and without MyMcAdmin.

    I have to run with MyMcAdmin due to the host settup I am using for now.
    #edit for clarification

    this means I am stuck with that option for my server but I can still test the default bukkit.jar on my personal computer

    I just tried to run from my Mac with just Bukkit 556 and MagnetBlock and received the following errors.

    I'm assuming this is an issue with Mac/bukkit based on the errors but I tried Essentials and it loaded fine.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  24. Offline


    Hi guys,

    I love this plugin but I've got the cobblestone glitch too ! I think there is a problem with world edit ! Because when i edit a structure using the super pick axe, the blocks i removed will be be replaced by cobblestone when moving. I think you can search this way.
  25. Offline


    Dont work , ok sometime move 1 or 2 block but then it stops and do nothing. And now my server is laggy like Hell.
    no Status Message in the Chat , only finish Message is showing, nothing else.
    No error Message in the server log, only spam with server overload.

    CPU: Intel i7-2600 CPU @ 3.40GHz (4 Cores)
    RAM: 16033 MB
  26. Offline


    I had the same issue. See my post from the last page:

  27. Offline


    That's intended. If you go into edit mode first with /mbes name, the blocks you remove will also be removed from the structure list and won't turn into cobblestone.
  28. Offline


    Actually, i always use mbes when editing, but when i use super pick axe from worledit, the blocks i removed will always be cobblestone during first movement.

    i'm uploading a video !
  29. Offline


    Ah, sorry you really can't use an external plugin unless it sends out the BlockBreakEvent (I suppose it doesn't).
    In mbes mode, it just listens for this event (and theres no other event either), so you have to break all the blocks by hand.
  30. Offline


    Okay ! That's what i wanted to know ;) !

Share This Page