Inactive [MECH] MagnetBlock v0.4.7 - Movable Structures controlled by Redstone [1060]

Discussion in 'Inactive/Unsupported Plugins' started by narrowtux, Mar 2, 2011.

  1. Offline


  2. Offline


    i tried to make an elavator but every time it just goes past me and doesn't detect me at all and it leaves me at the bottom of the shaft any reason why?
  3. Offline


    What material did you use for the elevator ground?
  4. Offline


    i figured it out when the server cant keep up the detection of the person doesnt work so great and i used diamond block
  5. Offline


    It's a bit laggy when you play on a public server, I noticed that too.
  6. Offline


    Really great idea for a mod. I play with a couple of friends on a private server and we have a fleet of ships we wanted to move. We were really excited at the prospect of our squadron flying over a hill into a crowd of creepers. However, it seemed to be very spotty in the way it worked. When it worked, it worked great. But that was only maybe a third to half of the times we tried it. We could create structures just fine (although being able to select existing structures would be a fantastic addition) but often times they wouldn't move at all. They would also never rotate no mater what. With this update we decided (unfortunately) to uninstall this mod. We all agreed it was an awesome idea but we were let down with its functionality.
  7. Offline


    Sometimes, structures won't move after you created them, then you can type in /reload to reload all plugins. After that, it works.
    Rotating structures is currently disabled.
  8. Offline


    is there a way to optimize this plugin anymore so you dont have as much server overloaded because i think its taking up alot more recourses than other plugins
  9. Offline


    hey does this plugin wotk on build 818 and 819???
  10. Offline


    That lays in the nature of the plugin. Animations (let them be in minecraft or on the xy-application on your desktop) always take much more resources because the display has to be recalculated every time.
    It should work because there weren't any plugin-breaking changes. I haven't tested it, though.
  11. Offline


    This is AWESOME!!! Now we can make working planes, cars, and other stuff! Combine this with chaircraft and you can actually sit down in the vehicle.

    I can't move my structure! I use Craftbukkit 818.

    Nevermind, i held the wrong tool ;)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  12. Offline


    This works with chair craft? cooooool!!!
  13. Offline


    yea i know quite a bit about this stuff but im sure there are ways to optimize the plugin to take less recources or maybe not in minecraft but in normal animation style there is always room for optimization
  14. Offline


    The effect would be marginal, so you'd max. win 1% of CPU.
  15. Offline



    can you please update threadtitle, that it works with last rc #818 ?
  16. Offline


    fucking awesome, keep it up
  17. Offline


    This is a great pluggin, but I seem to be having an odd problem with it. Whenever I try to use it, I get the attached error.
    It moves one a singe meter just fine, then stops. I've also gotten smaller structures ( a few blocks in size) to move without error.
    17:25:55 [SEVERE] java.util.ConcurrentModificationException
    17:25:55 [SEVERE]       at java.util.AbstractList$Itr.checkForComodification(Unk
    nown Source)
    17:25:55 [SEVERE]       at java.util.AbstractList$Itr.remove(Unknown Source)
    17:25:55 [SEVERE]       at java.util.AbstractCollection.removeAll(Unknown Source
    17:25:55 [SEVERE]       at com.dreadreaver.bukkit.floodgates.FloodGatesBlockPhys
    17:25:55 [SEVERE]       at
    17:25:55 [SEVERE]       at Source)
  18. Offline


    There's a known bug which doesn't let you move a structure after you created it. Try the bukkit-cmd /reload after that.
    The error you posted is not really my fault, it's FloodGates, I assume.
  19. Offline


    hi, i think all your plugins are awesome :)
    heres a request:
    i know its called magnet blocks, but can you make it so the structure moves in a predetermined way like, you set the movement, then the strucktures memorises it, and everytime a person gives energy to the magnet it moves in the way you set it, and when you light another magnet or the same magnet twice, it moves backward, that would be very awesome, maybe hard and buggy (i dunno of programming but i bet you can) but awesome, please read this :)
  20. Offline


    Thanks, I got rid of Floodgates (forgot that was even in there), and it's working fine now.

    Noticed a small glitch (or an unintended feature, if you prefer). If redstone is a part of what's moving, it drops a ton of redstone. Perhaps there's a way to disable drops on items that are connected to a structure? Maybe there already is and for whatever reason it doesn't cover redstone?
    Either way, it works great (bit of a bumpy ride on my new elevator, but still beats climbing). I just have more redstone than I know what to do with now. :Edit2: no longer does that. Must have been something it does when it's been first created.
    :Edit1: It would seem that it breaks after adding another structure in, too. I went back to my previous structure after building my elevator (both have completely different structure names) and it no longer works. I checked, and the magnets are getting power. However, the structure no longer seems immune to me breaking it (I took out a few pieces with my pickax and they acted like normal blocks. They dropped and didn't automatically replace themselves)
    :Edit3: I rebuilt the gate and both structures work now. Still not sure what caused it to stop working in the first place. However, there is a consistent glitch that I'm running into. Whenever I remove a magnet (/mbrm), it drops a magnet that when and if I can pick it up, I can't get rid of it. If I try to drop it using 'q', it returns to my hand. Same story if I try to place it anywhere.
    :Edit4: And I don't know if anyone has already reported this, but I'm getting spammed with "[SEVERE] Block has encountered AIR Type" messages, followed by my structure not moving.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  21. Offline


    dear narrowtux,

    I've got a problem with my magnetblock...
    Everytime when i start up the server there is a message that says magnetblock.cfg not found.
    Then I go ingame and every magnetblock doesnt work anymore so i've to rebuild every single structure every single day...
    Plz help soon...

  22. Offline


    Have you fixed the "Cobblestone-Bug" yet??
  23. Offline


    If you look in the OP he lets you know you have to create the config file. He even gives a simple one that you can copy and paste to create for your own.

    Here is the section from the OP about configuration:

    MagnetBlock can be configured by a text file. This is absolutely optional, if you don't provide one, it will use the defaults that you are used to.
    With the configuration file you can adjust the blocktype of the magnets and which items should move in which direction.
    Example Configuration file with default values:

    #What blocktype should magnets be?
    #Configure the actions of items.
    #this decides how much the structure is moved when you use the specified item.
    #How much should the structures accelerate?

    Create a new file in server/plugins/MagnetBlock, called magnetblock.cfg
    The magnet-property should be clear.
    With item=, you can create a new push/pull item and define on which axes the item should push or pull. If you type in 1,1,1 , the specified item will move the structure in any direction. This is still dependent from the view of the player that clicks on the structure. If you type in 2,0,2 , the structure will move only on x and z axis, but will move by 2 blocks.
  24. can you also make a magnet that rotates the structure?
  25. Offline


    I use your MagnetBlock's extensively and it's awesome. But just yesterday I found something not working like you'd expect it to. Do you think it would be possible to make dispensers keep their items upon structure movement? Or if you're not performing updates anymore, do you mind if I modify it on my own?

    Thank you.
  26. Offline


    I found something weird in the blocks files. When the structure is created, the coordinates of the blocks are stored, but when you move the structure, the blocks files do not record the new location of the structure blocks. So, when I restart the server, the plugin search the structure at its origin point, and found nothing. The blocks id in the blocks file become AIR blocks, and the blocks of the moved structure are now destructible. The only way to keep my structures usable is to move them to their origin point when I close the server.

    I think this is the cause of the troublesome cobblestone/AIR problem. If the location info in the blocks file are updated each time you move the structure, or when closing the server, this would solve the problem. I'm still on CB733, with the latest version of the plugin.
  27. Offline


    its working fine with CB 953. is there a way to make it less jumpy? like by slowing down the speed in the config?
  28. Offline


    I tested the plugin on a nude server with only the magnet plugin CB953 and the problem was gone. When exiting, the data in the blocks files is correctly updated. But when I put all my plugins, the problem restarts. I'm searching for the plugin causing the conflict.

    I tested everything and I found it has nothing to do with plugin conflict, but I finally found the source of the problem. When you close the server clicking on the X button of the window, it will not save the position of the structure in the blocks files. So you have to use the "stop" command to close the server, it will save the data correctly before exiting. It works fine both on CB733 and CB953.
    The structures can only move block per block, so it's a bit jumpy. If you were talking about big jumps, like 3-5 blocks jumps, that's because your structure is too big. I tested a 500 blocks structure and it worked fine, but a 1000 blocks structure has one entire second lag, making the movement very jumpy with a 3-5 blocks jump. Adding a configurable default limit of 1000 blocks per structure should be a good idea.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: May 10, 2016
  29. Offline


    I left a comment a while back saying this is an awesome plugin and I stand by what I said. This is probably the plugin I most enjoy on bukkit. What I'd love to see here is a repelling magnet: like Iron Block is a magnet that pulls the structure towards it and a gold block pushes it away or something of the kind. That would be awesome for various reasons and reduce the amount of redstone wires needed for lifts and the like.

Share This Page