[MECH/FUN] Guns+ v1.8 - Guns, Guns, Guns Galore![SPOUT][1.4.7-R1.0]

Discussion in 'Archived: Plugin Releases' started by atlan1, Jan 31, 2012.

  1. Offline


    Can you help me.
    I am trying to use the war plugin and in order to put the item i have to do this
    item: insert item id
    but the problem is this
    item: 318:1034
    it wont work if you put the second: there and an error occurs
    is there any way to fix this?
  2. Offline


    I really ned help. The only gun I need is the sniper rifle (Which I am pretty sure is default) so I didn't change anything in the config or stuff. Then when I try to shoot the gun or zoom I get this error:

    [SEVERE] Could not pass event PlayerInteractEvent to GunsPlus

    And then a bunch more Mumbo Jumbo. I really need help I have not found an answer. Thanks.
  3. Offline


    Use the bleeding edge version.
  4. Offline


    Thanks so much your a life saver.
  5. Offline


    Um.... none of my guns appear to be doing damage, whether I melee with them or shoot them.
    EDIT: Just to clarify, they'll hit the target, as in, the target will flash red, and in the case of animals, freak out as if it's been hit, but it won't do any damage.

    Console gives no suspicious errors. wtf? D:

    EDIT: Also, I tried letting the general.yml regenerate itself, and I'm getting the same bug as I did before. If I set the zoom key to Z, the controls will glitch up and be left click to shoot and right click to zoom. For the record, this has always happened, not just for this version, I just never particularly cared about it enough before melee damage was added.

    EDIT2: I think I figured out the problem with the damage, but I can't fix it myself. Before I had all my melee damage nodes read "melee: " (like the installation guide said) instead of "melee-damage: ", so I changed them all and now melee damage appears to work. However, it appears that regular damage no longer works - instead of using the value I put in for damage, it uses the value I put in for melee damage.
  6. Offline


    Ah, I think I know what the problem is here, I will fix it now.
  7. Offline


    I guess it has to do with a different separator character like with PvPArena. You will have to read all the configuration tutorials :p
  8. Offline


    Hey, the plugin looks great! I've tried installing and adding guns but in the run.bat of the server it always says that "[Guns+] The node 'tripod.recipe.ingredients' in general.yml is missing or invalid! Defaulting!" for everything. I've redone the folders (eg. the guns, ammo, recipes) five times and it still isn't working. Any help would be greatly appreciated.
  9. Offline


    Yea, all the guns do 1/2 heart damage now. Same as Typical_Name, I assume.
  10. Offline


    The problem is that no matter what guns are doing the melee damage for some reason. Just remove the melee node in general.
  11. Offline


    Actually, I'm pretty sure it defaults to doing 0 damage if you leave the melee node blank (as happened at first, since I had entered it incorrectly).

    I downgraded to the working version. Hopefully an update comes soon, I was really looking forward to bayonets :/.
  12. Offline


    My mistake. All of mine just do the same damage regardless of the damage settings. I'll revert back too and await an update.
  13. Offline


    Yeah I am using Atlan1's Gunpack and it is turning out fine, as there are no errors except one. Same with a lot of people I cannot damage players/mobs. They will be shot but no damage will be taken out of their health. I really need help on this. Thanks guys.
  14. Offline


    For which plugin this one and link please
  15. Offline


    He's working on fixing this, there's nothing you can do besides downgrade to an older version :/.
  16. Offline


    Will downgrading to an older plugin mean downgrading the server too?
  17. Offline


    ... I'm not sure what you're trying to ask me.
  18. Offline


    I didn't updated my pack yet. Thats why.
  19. Offline


    Just wondering if there was a fix created yet for those of us who are having problems with players or mobs that we shoot not taking any damage? Also thanks again for a great mod!
  20. Offline


    I can't do the fix as updated we have set up for 1.2.5 are not able to be released due to spout issues
  21. Offline


    Shift click is broken. It happened to me too.
  22. Offline


    Hi, I’m very new to mods for minecraft in fact this is the first mod I’m trying to get to work so sorry if it’s something stupid on my part, my issue is it seems I can’t craft any of the guns or ammo, if I go to the work bench and try to craft any guns or ammo it shows up in the “output” of the work bench but no matter what I do I can’t get it into my inventory it just flash’s in my inventory then disappears. I have the latest versions of craftbukkit, spoutplugin and GunsPlus. In my server.txt file I get the following error

    [SEVERE] Could not pass event PlayerInteractEvent to GunsPlus
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:304)
    at org.bukkit.plugin.RegisteredListener.callEvent(RegisteredListener.java:62)
    at org.bukkit.plugin.SimplePluginManager.callEvent(SimplePluginManager.java:459)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:177)
    at org.bukkit.craftbukkit.event.CraftEventFactory.callPlayerInteractEvent(CraftEventFactory.java:147)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:889)
    at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:120)
    at net.minecraft.server.Packet18ArmAnimation.handle(SourceFile:38)
    at net.minecraft.server.NetworkManager.b(NetworkManager.java:229)
    at net.minecraft.server.NetServerHandler.a(NetServerHandler.java:113)
    at org.getspout.spout.SpoutNetServerHandler.a(SpoutNetServerHandler.java:172)
    at net.minecraft.server.NetworkListenThread.a(NetworkListenThread.java:78)
    at net.minecraft.server.MinecraftServer.w(MinecraftServer.java:567)
    at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:459)
    at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Caused by: java.lang.NoClassDefFoundError: me/lyneira/MachinaRedstoneBridge/MachinaRedstoneBridge
    at team.GunsPlus.GunsPlusListener.onPlayerInteract(GunsPlusListener.java:100)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.bukkit.plugin.java.JavaPluginLoader$1.execute(JavaPluginLoader.java:302)
    ... 14 more

    Hopefully somebody can help

  23. Offline


    Known bug of v1.2.3.
    You can either install Machina or downgrade to 1.2.2.

    @Everyone who has problems with damage of Guns.

    Downgrade to 1.2.4 with installed Machina or wait about one day to the update which will fix all the bugs.
  24. Offline


    I'm getting problems..

    19:21:13 [WARNING] [Guns+] The node 'melee-damage' in gun AUG is missing or invalid!
    19:21:13 [WARNING] [Guns+] The node 'melee-damage' in gun ACR is missing or invalid!
    19:21:13 [WARNING] [Guns+] The node 'melee-damage' in gun SCAR is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun Xm25 is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'additions' in gun Xm25 is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun Javelin is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'additions' in gun Javelin is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun M249 is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun M60 is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun Skorpion is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun P90 is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun 44Magnum is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun DesertEagle is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun Striker is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun Spas12 is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun RSSAS is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun Barret is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun DragonsBreath is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'additions' in gun DragonsBreath is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun AK47 is missing or invalid!
    19:21:14 [WARNING] [Guns+] The node 'melee-damage' in gun Galil is missing or invalid!
    I get this in every pack I download.. Somebody help me please?
  25. Offline


    The pack you're using isn't up to date.

    Spoutcraft is not just a mod but a new CLIENT.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 13, 2016
  26. Offline


    Yeah , texture was really ugly !
  27. Offline


    So... where is it (the new version, I mean)? Has it been released yet? I'm really looking forward to this :D!
  28. Offline


    Noob question. How do I melee? And use the Tripod?
  29. Offline


    Woot! First to download new version of Guns+! (assuming the label on it was accurate)

    You melee just as you would melee with anything (left click by default).

    Tripods are a bit tricky, I haven't experimented much with them myself. From what I understand: First place tripod, then click on it while holding a weapon (make sure you aren't in creative mode). The weapon will then be attached to the tripod. Then click on the tripod again to enter it, and click on it when you are ready to leave (again in survival mode).

    EDIT: My guns no longer show up in the creative mode menu (ammo appears to be fine). I suspect that something must therefore have been changed about the config; however, I don't know what it is.

    This is what my guns.yml looks like:

    And I get these errors in the server logs:

    I notice that the node "fire-behavior" is allegedly missing, but I've never heard of it, and it doesn't appear to be in the installation guide. What is it?
  30. Offline


    i am delteing posts to avoid spam (see minevahicles if u see what i mean).

    i have the new updated version. i am OP on my server.
    i hold a gun in my hand, and it says 6/11 (11 in inv) shots.

    i right click, and nothing happens!
    am i doing something wrong?
    i have latest craftbukkit, spout, and guns+

Share This Page