[MECH/FUN] Guns+ v1.8 - Guns, Guns, Guns Galore![SPOUT][1.4.7-R1.0]

Discussion in 'Archived: Plugin Releases' started by atlan1, Jan 31, 2012.

  1. Offline


    SirTyler atlan1

    How in the world do I use millisecond timing with shot delay?
  2. Offline


    help me fix spouterrors and cant find any guns?
    15:18:23 [INFO] Starting minecraft server version 1.2.5
    15:18:23 [INFO] Loading properties
    15:18:23 [INFO] Starting Minecraft server on *:25565
    15:18:23 [INFO] This server is running CraftBukkit version git-Bukkit-1.2.5-R1.0
    -b2149jnks (MC: 1.2.5) (Implementing API version 1.2.5-R1.0)
    15:18:23 [SEVERE] Could not load 'plugins\Spoutcraft.jar' in folder 'plugins'
    org.bukkit.plugin.InvalidDescriptionException: Invalid plugin.yml
            at org.bukkit.plugin.java.JavaPluginLoader.getPluginDescription(JavaPlug
            at org.bukkit.plugin.SimplePluginManager.loadPlugins(SimplePluginManager
            at org.bukkit.craftbukkit.CraftServer.loadPlugins(CraftServer.java:207)
            at org.bukkit.craftbukkit.CraftServer.<init>(CraftServer.java:183)
            at net.minecraft.server.ServerConfigurationManager.<init>(ServerConfigur
            at net.minecraft.server.MinecraftServer.init(MinecraftServer.java:156)
            at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:422)
            at net.minecraft.server.ThreadServerApplication.run(SourceFile:492)
    Caused by: java.io.FileNotFoundException: Jar does not contain plugin.yml
            ... 8 more
    15:18:23 [INFO] [Spout] Loading Spout v1110
    15:18:23 [INFO] [eTeleport] Loading eTeleport v1.6
    15:18:23 [INFO] [Better Leveling] Loading Better Leveling v0.3
    15:18:23 [INFO] [GunsPlus] Loading GunsPlus v1.2.2
    15:18:23 [INFO] [Tribu] Loading Tribu v0.4.2.12511
    15:18:23 [INFO] [SMP_Hardcore] Loading SMP_Hardcore v2.0
    15:18:23 [INFO] [PermissionsBukkit] Loading PermissionsBukkit v1.6
    15:18:23 [INFO] [Spout] Enabling Spout v1110
    15:18:23 [INFO] Preparing level "kris"
    15:18:23 [INFO] Default game type: 1
    15:18:23 [INFO] Preparing start region for level 0 (Seed: -5327284240202133374)
    15:18:24 [INFO] Preparing start region for level 1 (Seed: -5327284240202133374)
    15:18:24 [INFO] Preparing spawn area: 89%
    15:18:24 [INFO] Preparing start region for level 2 (Seed: -5327284240202133374)
    15:18:24 [INFO] [eTeleport] Enabling eTeleport v1.6
    15:18:24 [INFO] [eTeleport] Plugin enabled. Version 1.6
    15:18:24 [INFO] [Better Leveling] Enabling Better Leveling v0.3
    15:18:24 [INFO] Creating/loading config
    15:18:24 [INFO] [GunsPlus] Enabling GunsPlus v1.2.2
    15:18:25 [INFO] [Guns+] Plugged into Spout!
    15:18:25 [INFO] [Guns+] -------------- Additions loaded: ---------------
    15:18:25 [INFO] - Silencer
    15:18:25 [INFO] - ExtraScope
    15:18:25 [INFO] [Guns+] -------------- Ammo loaded: ---------------
    15:18:25 [INFO] - SniperAmmo
    15:18:25 [INFO] [Guns+] -------------- Guns loaded: ---------------
    15:18:25 [INFO] - Sniper
    15:18:25 [INFO] - Sniper+Silencer
    15:18:25 [INFO] - Sniper+ExtraScope
    15:18:25 [INFO] [Guns+] ------------  ID's of the guns: -----------------
    15:18:25 [INFO] ID of Sniper:318:1028
    15:18:25 [INFO] ID of Sniper+Silencer:318:1029
    15:18:25 [INFO] ID of Sniper+ExtraScope:318:1030
    15:18:25 [INFO] [Guns+] ------------  ID's of the ammo: -----------------
    15:18:25 [INFO] ID of SniperAmmo:318:1027
    15:18:25 [INFO] [Guns+] ------------  ID's of the additions: -----------------
    15:18:25 [INFO] ID of Silencer:318:1025
    15:18:25 [INFO] ID of ExtraScope:318:1026
    15:18:25 [INFO] [Guns+]  ------------ loaded the tripod block --------------
    15:18:25 [INFO] [Guns+]  ID: 318:1024
    15:18:25 [INFO] [Guns+] version 1.2.2 is now enabled.
    15:18:25 [INFO] [Tribu] Enabling Tribu v0.4.2.12511
    15:18:25 [INFO] Chosen language : english. Provided by Graindcafe with help from
    15:18:25 [INFO] 1 levels found
    15:18:25 [INFO] ºfStarting º4Tribuºf by Graindcafe, original author : samp20
    15:18:25 [INFO] [SMP_Hardcore] Enabling SMP_Hardcore v2.0
    15:18:25 [INFO] Java Version: 64
    15:18:25 [INFO] SMP_Harcore Was Not Loaded! Disabled By Server Host!
    15:18:25 [INFO] plugins/SMP_Hardcore/config.yml: Enable_Plugin = false
    15:18:25 [INFO] [PermissionsBukkit] Enabling PermissionsBukkit v1.6
    15:18:25 [SEVERE] [PermissionsBukkit] Unable to load configuration!
    15:18:25 [INFO] [PermissionsBukkit] Enabled successfully, 0 players registered
    15:18:25 [INFO] Done (2,199s)! For help, type "help" or "?"
  3. Offline


    Spoutcraft is not a plugin. So many people keep doing this no matter how many times in this (and other threads with spout dependent plugins).

    For everyone that tries to put Spoutcraft in the plugin folder; it is a client launcher. Put it on your desktop and RUN it to play minecraft.
  4. Offline


    Hmm, noob question: Is there a way to make a gun require multiple types of ammo - if, for instance, I wanted the ammo requirement of a musket to be both gunpowder and a bullet?

    I know there's a way to make a gun accept more than one kind of ammo, but I don't want the musket to take either gunpowder OR a bullet, I want it to require both the powder and the bullet to actually work.
  5. Offline


    Thank you so much!!! I now know what the problem is. Thanks so much!!!
  6. Offline


    I cannot fire the sniper and my server says:
    23:11:33 [INFO] Unknown packet 51. Skipping contents.
    23:11:33 [INFO] Failed to identify packet id: 51
    23:11:33 [INFO] Unknown packet 51. Skipping contents.
    23:11:33 [INFO] Failed to identify packet id: 51
    23:11:33 [INFO] Unknown packet 51. Skipping contents.
    23:11:33 [INFO] Failed to identify packet id: 51
    23:11:33 [INFO] Unknown packet 51. Skipping contents.
    23:11:33 [INFO] Failed to identify packet id: 51
    rapidly please help me
  7. Offline


    I put in some nodes but people still cant do damage. What exact nodes must I have? I added them all.

    I did. I'll try updating spout plugin

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 13, 2016
  8. Offline


    Uh....permissions? :confused: When I went into configuration, it gave me all those nodes, and it was confusing to tell which ones were the permission codes, and which were not. I still don't know. :p
    Please explain. And please fix. It would be greatly appreciated.
  9. Offline


    Permission nodes are used by permission plugins, you can find a list of them onour bukkit dev on the Permissions page.
  10. Offline


    I just removed them, becaue they did no apparent improvement of the firerate.
  11. Offline


    Er... wait, you can't use millisecond rates on the shot delay? It seemed to work ok for me...
  12. Offline


    Yeah it worked but it had actually no effect, you could not fire faster than with tick tasks. So we could also the bukkit scheduler - which is thread safe - instead.
  13. Offline


    great plugin :)
  14. Offline


    Okay, thanks. And I got the permissions!!! YAY!!!
  15. Hey, um...is there an item ID or something along the lines of that for the guns? I'd like to set them as something you get when you spawn on my server, and to do that I need item ID's. Could you be so kind as to release those?
  16. Offline


    They are output to the console, just look at the console on start up and it will display all id's loaded by the plugin.
  17. Offline


    How to craft them or give me id's item pls
  18. Offline


    You can read the ids in the log.
  19. Offline


    Is there a way I can make it so that you have to press a button (r by default) to reload for some guns, but not for others? I know in the general config file there's a way you can change it for all guns, but I only want old fashioned guns (ie, the flintlock pistol) to have to press a button manually to reload.
  20. Offline


    Allo, my server is currently need of some textures for Fallout Guns. I could do the config myself, but if you would like to make an entire Fallout gun pack go ahead! XD Let me know if your interested!
  21. Offline


    I was working on a couple new gun designs, but when I restarted the server to reload all the files, all of my guns disappeared! (As in, the creative mode interface no longer shows them)

    The configs all appear to be fine and the console didn't give me any helpful error messages.

    What went wrong???

    EDIT: Here's some unhelpful messages from the config:
    Show Spoiler

    It appears that for some reason, it's not recognizing the Guns+ config files that were previously working about 30 minutes ago. I have no idea what I did that could be causing this, I checked everything and it's all done correctly.

    EDIT2: It appears that Guns+ does not like the Colt Python. I removed this particular gun, and everything worked fine again.
    Show Spoiler
  22. Offline


    I am working on a more custom way to control the keys.
    Sorry about those null errors. If you got one this means basically that some of the nodes are not accepted and we did not implement a custom error message for it yet. If you turn debug in general.yml on, you can see the actual error log. Please post this again in a ticket on BukkitDev.
    I guess it has either to do with the NONE under the additions or with the ammo '51' (if you made a ammo called like this it doesn't cause it, I am just guessing that because of its name ), but if this isn't helping you please post a ticket about it on BD.
  23. Offline


    Hmm, it's neither the NONE or the 51, because all of my guns have NONE under additions and there's another gun that uses 51 perfectly fine (51 is fire; I use it as ammo to indicate that the weapon is meant for admin use only).
    I don't think it's really worth bothering the bukkitdev staff with a ticket, though, all I had to do is remove the weapon.

    Actually, now that I look over it again, I think I see what might be the problem - the letters "url" are pasted by the sounds, and I don't think those are supposed to be there. I must have accidentally copied them over. I'll try removing them and see what happens.
    EDIT: Wait, no, they all have that. I remember now, there's two things under sound, the url and the volume level, which is a relatively recent feature. I'm clueless again :/.

    Anyways, I hope bayonets come out soon. I am looking forward to bayonets :).

    Um, noob question... how do I enter a tripod?

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 13, 2016
  24. Offline


    just punch it after you mounted a gun and filled some ammo in, just read in the FAQ about it ;)
  25. Offline


    whenever i try to rename the "Sniper" gun to "Sniper Rifle" then try to add an MP5 below it the plugin breaks D:.
    can you have more then 1 gun or is 1 gun the max?

    also whenever i try Atlan's gun pack it only shows the sniper rifles (Sniper,Sniper+Silencer,Sniper+ExtraScope) in the creative mode screen.
    does that mean that it's not working or do i need to craft the other guns?

    Attached Files:

  26. Offline


    ok i tried again with the atlan's gun pack and it works but i want to make my own custom guns
  27. Offline


    would it help if there was a video on it?
  28. Offline


    Oh my bad, it wasn't working when I was trying it; apparently you need to be in survival mode for it to work (if you punch it in creative mode it just breaks).
    But since you punch it to enter it, how do you break it? (Without creative mode)

    No, you can have many guns, and it's very customizable. I'm not sure what's going on that would make only one gun work. I would have to have more details on how you installed it (it's worth noting that the snipers are part of the default configuration, NOT Atlan's gunpack).
  29. Offline


    How Took a gun out .:'(:'( I Took a gun out Not?
  30. Offline


    Yeah, currently that's a bit impractical. You have to turn it to automatic mode first and then break it.
    I will consider something to fix this.

Share This Page