[MECH/FUN] Guns+ v1.8 - Guns, Guns, Guns Galore![SPOUT][1.4.7-R1.0]

Discussion in 'Archived: Plugin Releases' started by atlan1, Jan 31, 2012.

  1. Offline


    Tyler, where is the new delay option in milliseconds for fire in the config? I checked with a quick search for delay on the page and found nothing... Give me an example of millisecond firing rate differences?

    Also, is Grenades+ coming soon?
  2. Offline


    Hmm, it appears that now I've updated guns+ to 1.2, only OPs can shoot my guns. There was a guy earlier in the thread who had this problem, and he was told to turn off his anti-cheating plugin, but I don't think that's the case in my situation since none of my plugins have ever interfered with guns+ before...

    Any ideas as to what I could be doing wrong?

    EDIT: Just to be sure, I deleted the anti-cheat plugin. Non-OPs still can't shoot :/.
    EDIT2: Just noticed that guns+ now has permission nodes. I added them into the appropriate groups and.... non-OPs still can't use guns :/.
    2eno likes this.
  3. Offline


    where I can find the permission nodes?
  4. Offline


  5. Offline


  6. Offline


    I;m having a problem. Now this is with spoutcraft. So I'm not sure if I should go to them, or if you could help m out. If I have to go to them, please tell me.
    So pretty much my problem is that spoutcraft just won't load. I get an error, and when I check my plugins on the server in-game, it does not recognize spotcraft. it recognizes spout, just not sputcraft. Please help.
    Also, the gun texturpacks wont show up on mine and it goes to flint. I'm guessing this is because I need spoutcraft.
    Any help would be greatly appreciated.
  7. Offline


    I will look into these problems, if you havnt already please make a ticket on the bukkit dev project so it's easier to track.
  8. Offline


    Er, I think it's possible that I just did my permissions nodes wrong. I double-checked them and I noticed that they somehow got reset (even though I had the server off while editing them so they wouldn't reset). I'll test it out once someone else logs into my server.
  9. Offline


    hi there, i am a bit of a noob but i cant seem to spawn any guns in creative mode or from chat and console, i give my self 318 cause it says it in console but i get flint, i put in spout and spoutcraft in my plugins with guns+ (of course) when i first play it shows a message of who made the mod and im just wondering what i may have done wrong. if anyone could reply with instructions on how to install (cause i cant finad any) that would be nice

    Please help :)

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 13, 2016
  10. Offline


    Er, you put spoutcraft in your plugins folder? Spoutcraft isn't a plugin (Spout is), it replaces your Minecraft launcher and allows players to use the plugin.

    That's the only thing I could thing of that's causing your guns to appear as flint. Also, if you want to use the /give command for guns, be sure to put in the appropriate damage values, since that's how the game distinguishes between guns and flint.
  11. Offline


    Your plugins is great ! Thank you :) I've remade the guns of the SDK'Mod Gun for my server, it's work perfectly.
    Guns+ + GrenadePack = Ultime Combo !!!

    However, for the next release, is it possible to change the way the recoil works ? Because it's very annoying to can't move when the player fire ... And sometimes, the sounds of the guns are don't loaded, or they are loaded but sometimes later, no sound ...

    Thank you !

    (Sorry for my english, I'm french, but I do my best ^^ )
  12. Offline


    Please add automatic guns :D. Then i can add machineguns
  13. Offline


    Hi. I am very new at just about everything plugin related, so I have absolutely no idea what I am doing. I have made my own Guns folder, and nothing seems to work. At all. So I would like to ask somebody to fix my files for me. You can keep them, I do not mind, but the textures are not that good. Here is the download link.

  14. Offline


    Recoil is done two ways, the usual way is through the knock back although some use the recoil option. I will explain the pro's and con's.
    Knock back:
    Show Spoiler

    Pro's Knock back:
    • Move player backwards and allows them to keep moving
    • Smoother view
    Con's Knock back:
    • Does not allow for upwards or downwards (of gun) aiming

    Show Spoiler

    Pro's Recoil:
    • Allows for upwards and downwards (of gun) recoil
    Con's Recoil:
    • Very choppy viewing
    • Stops all movement for a moment

    As for sounds this is due to the sound being called too often, a fix is being worked on.
  15. Offline


    Hmm, non-OPs still can't use guns on my server, and I'm pretty sure the permissions file is set correctly (I can't check because WinSCP is busy working on something else at the moment). Do you have any idea what I could be doing wrong? This wasn't a problem back with 1.1.1 or even the bleeding edge version.
  16. Offline


    It looks like the permissions are bugged, I am working on it.

    Permissions solved, in bleeding edge while I add a few simple things to 1.2.2

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 13, 2016
  17. Offline


    Great, but where can I get it? It doesn't appear to be on the devbukkit page.
  18. Offline


    Click the release title for a link or click the files tab on the bukkit dev page, the reason it dosnt show as most recent is due to file not being approved yet.
  19. Offline


    Um, guns still don't work. Did the names of the permission nodes change or something? I double-checked my permissions folder and they're still in there, my only idea is that what they're supposed to be has changed since I put them in.

    EDIT: Whoops, turns out the names of the nodes had changed. I feel stupid now XD.
  20. Offline


    I only changed the overall permission, check the permissions page for the update.
  21. Offline


    Hmm, the enderpearl launcher still doesn't work. Every now and then I can see the enderpearl, but it never does anything :(.
  22. Offline


    That has always been the problem I believe, its because we fire the entity and not treat it as the item.
  23. Offline


    I know for a fact that the enderpearl used to work. I played around with it all the time about, oh, a month or so ago. I think it stopped working at about the same time tripods came out (I doubt the two are related, that's just an estimate of time).
  24. Offline


    THERES 1ZILLION BUGS BUT ITS AWESOME!!! Ihave v1.2 and the guns wont shoot... they use to work fine. HELP!!!
  25. Offline


    update to 1.2.2 and update your config files.
  26. Offline


    I've just been told that recipes aren't working for people. They can see the finished item in the crafting box, but they aren't able to take it out. Ideas as to what I did wrong?
  27. Offline


    1.2.2 Added crafting permissions, they don't have them.
  28. Offline


    ... But I just re-checked the list of permissions, and there's nothing about recipes anywhere in there. Where can I find the full list of permissions nodes?
  29. Offline


    I need a node for when people shoot a gun they do damage to things because currently only ops can do damage! Whats the problem? Is there a permission node to fix this?
  30. Offline


    sorry about that, forgot to add the crafting perms to the page. Updated now.

    Look at the permissions page.

Share This Page