Inactive [MECH] FalseBook 0.96alpha - CraftBook for Bukkit,85++ICs, Gates, Minecarts / MC1.4.6

Discussion in 'Inactive/Unsupported Plugins' started by GeMoschen, Mar 5, 2011.

  1. Offline


    FalseBook - Your CraftBook for Bukkit

    Current version: v0.96alpha
    Minecraft: 1.4.6

    Show Spoiler

    • supported Permissionplugins
      • bPermissions
      • bukkitPermissions
      • Essentials GroupManager
      • Permissions
      • PermissionsEx
      • SuperPerms
      • Vault (still in development)
    • uses the syntax of CraftBook for better compatibility
    • implements over 85 Integrated Circuits (ICs)
    • implements [Lift Up] & [Lift Down]
    • toggleable ...
      • ... bridges
        • undestroyable
      • ... doors
        • undestroyable
      • ... gates
        • undestroyable
      • ... areas
    • a lot of fancy features for minecarts
      • collect and deposit items from chests to minecarts
      • make furnaces which refill themselfs with minecarts
      • program carts to take only specific items out of chests
      • craft things out of a chest with a minecart
      • lift up & down for minecarts!
    • chatsystem with different chat-channels to clean up the normal chat
    • toggleable...
      • netherrack (with fire)
      • pumpkins
      • glowstone <-> another block (even if minecraft itself has the glowstonelamp now...)

    Minecart Blocktypes:
    Show Spoiler

    • BenchOut : Iron-Ore
    • Booster 2x : Gold-Ore
    • Booster 8x : Gold-Block
    • Brake-Block 25% :Gravel
    • Brake-Block 50% : Soulsand
    • Burn : Iron-Ore
    • ConstantSpeed-Block : Iron-Block
    • Craft : Iron-Ore
    • Deposit / Collect : Iron-Ore
    • Eject-Block : Coal-Ore
    • Emitter-Block : Lapis Lazuli Ore
    • Reverse-Block : White wool
    • Station-Block : Obsidian
    • Sort-Block : Netherrack
    • Teleport-Block : Lime wool
    • Program-Cart : Lapis Lazuli
    • Programmed Deposit-Block : Blue wool

    Other Features:
    Show Spoiler

    • Bridge (FalseBookBlock.jar)
    • Doors (FalseBookBlock.jar)
    • Gates (FalseBookBlock.jar)
    • Toggle Netherrack Fire (FalseBookExtra.jar)
    • Toggle Pumpkins (FalseBookExtra.jar)
    • Toggle Soulsand to Glowstone and back (my addition) (FalseBookExtra.jar)
    • ToggleAble Areas (Experimental):

      Define the area with the "Wooden Hoe" (use rightclick)
    • /farea <areaname> -> Adds an Area
    • /delfarea <areaname> -> removes an Area
    • /listfarea -> Lists all Areas
    • /fareatoggle <areaname> autosave -> toggles the autosave function of an area. Autosave = save blocks, when toggling the area off.
    • /fareatoggle <areaname> protect -> toggles the protection of an area. ON = Area is only destroyable/buildable to users with permission: falsebook.destroy.blocks
    • /fareaallow <areaname> id[:subid] -> will add/remove the blocktype from the toggleable blocks of this area. Default: all blocks will be toggled.
    • (FalseBookBlock.jar)

    Important Note:
    You must copy ALL jar-Files over the old ones (all files have been changed) !
    The "Package_..."-Files must go into "plugins/FalseBook/ICPlugins/"

    Download FalseBook 0.96alpha for Minecraft 1.4.6

    FalseBook Wiki - Work in progress

    YouTube-Channel with Videos

    Donations are welcome if you wish to support me


    Attached Files:

    cevio, Artem-s86, Dereku and 67 others like this.
  2. Offline


    how about scrolling a little bit on the permissions page
  3. Offline


    I keep getting the [ FalseBook IC ] Failed selftriggered IC's : 0 Failed how do i fix?
  4. Offline


    i think you should re-read the message!
    it say 0 (zero) ICs failed, it just wants to say you nothing failed and everything is fine
    there is nothing to fix
  5. Offline


    well after that nothing else loads and the server wont turn on it just stops right there at that message
  6. Offline


    this is often the last thing to load (at least on our servers)
    can you type something in the console? does the server respond to console commands?
    if the server responds to console commands you might check if you setup the ip and port correctly and if it is routing properly
  7. Offline


    it does respond to commands like stop and help but when i try to log on to my server its still off and i did not change anything and it was working fine last night
  8. Offline


    I got this error myself using CraftBukkit 1.2.4dev#2122 and Falsebook 0.93.1alpha
    This file is not created anymore. If you need it just create a file /plugins/Falsebook/
    and fill it up with the following (its my old file from prior version, you have to change it for your needs!):
    Funny.. even with those file copied to /plugins/Falsebook/ this error still appears in the log file.
    As everything is working as expected.. you can ignore that message ;)
  9. Offline


    Tanite likes this.
  10. Offline


    i know, your post is 1:1 my experience ;) so nothing new. but i think this file is something essentials for falsebook like mysql support, change ticks-ratio and toggle selftriggered, load unloaded chunks... for servers without unl.performance good way to limit cpu-hunger.
  11. Offline


    With the command-sending (1511) IC how do you phrase the command? I.e. Say I wished to use the worldedit command //butcher 1000, how would I put that on the sign and/or would such a command work without a player reference?
  12. Offline


    is it just me or is it a pain in the ass to find the list of permission nodes for this?
  13. Offline


    Well its explained in the first post named wiki link >LINK<

    Put a sign on a block, write in the second line [MC1511] and in the third line butcher.
    commands dont have to start with the "/" slash. If your command is longer use the fourth line too, but dont use spaces if the command continues to the next line!
    If you did it right the first line will be renamed to COMMANDSENDER.
    Just fire it with a pressure plate or a line of redstone..
  14. Offline



    Also, I have a problem with lifts - any player other than OPs receive the msg - "You are not allowed to use lifts"

    Admins who are not in the OPs file with the falsebook.* permission node cannot use lifts, I must be missing something because i've only found a couple of google results from "You are not allowed to use lifts" so it can't be a big problem just something stupid i've missed.

    Anyone got any ideas?
  15. Offline


    Hi There,

    if you follow the link you will find all permission nodes:

    DHLF likes this.
  16. Offline


    I just kinda figured that out, but said command seems to only work some of the time. Any idea why?
  17. Offline


    MC1200 with PigZombie spam the whole console:

    09:13:27 [SEVERE] java.lang.ClassCastException: org.bukkit.craftbukkit.entity.CraftPigZombie cannot be cast to org.bukkit.entity.Wolf
    09:13:27 [SEVERE]      at com.bukkit.gemo.FalseBook.IC.ICs.worldedit.MC1200.Execute(
    09:13:27 [SEVERE]      at com.bukkit.gemo.FalseBook.IC.ExecutionEvents.ICExecutionEvent.Execute(
    09:13:27 [SEVERE]      at
    09:13:27 [SEVERE]      at
    09:13:27 [SEVERE]      at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
    09:13:27 [SEVERE]      at net.minecraft.server.MinecraftServer.w(
    09:13:27 [SEVERE]      at
    09:13:27 [SEVERE]      at
    FalseBook Build: 0.93.1alpha
    Craftbukkit Build: 2124
  18. Offline


    It is impossible to change % of loss of apples or at all them to disconnect.
    At any change of parameter value changes by default on 10.0
    Help, thanks!
  19. Offline


    Perhaps you are using a plugin like LWC and this protects even the pressure plate so you are the only one who is allowed to use it?
    I am using the commandsender IC together with MC0272 to make my trusted user change their gamemode to creative. This way no other plugin (like LWC) is stopping this command.

    Or it may be a problem with the redstone-wirering, sometimes if the timing is too short they will do only ONCE.
  20. Offline


    Ok well I don't really know what LWC is XD However I set up a simple lever to redstone to sign set up, and I see that the command is going through. It worked once but I guess I could try a button since it would last longer.

    EDIT: Ok I tried it with a plain old mob detector (0271 I think) and it won't do what I want it to, so I'll just scrap it for now.
  21. Offline


    "My IC's aren't working. Anyone got any idea why?

    Like, they just don't become IC's when I make them and on startup it says "Loaded 0 ICs" - we had around 100 (Not bothered if we lose them - new map anyway) - I just need one to lock off the teleport gate for new map to greylist players."

    Still going with this issue. :(
  22. Offline


    Is there a list of permissions somewhere?

    They obviously changed on an update cause my members can't use Lifts anymore unless they have the ability to make them.
  23. Offline


    Thanks for the reply's And i quoted gil so he can find the nodes too... Thanks for the info!!
  24. Offline


    LWC is a protection plugin to keep chest, doors and even pressure plates private. So I thought this could be the problem..
    Maybe you will give it another try.. have a look at this link -> here.
    Although its the description for CraftBook (which have some different commands) it will show you how to put things together.
    Those Mob-Detector.. it take some time to figure out how to expand the "scan" radius.

    Finally the cart-collector works again ;)

    What have you done?
    Do you copied an old world back on your server or did you upgrade?
    If you copied your world.. it is not enough to copy only the world.. you must copy the datafiles as well.
    Falsebook stores the special sign-ics not in the world it put its in something like a database.
    If you LOST those file(s) you have to make new signs and place them on the old places.. manually.

    By the way what happens if you place a sign at a wall and try to type in the code for the sign?
    If the first line of the sign changes it SHOULD be working.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  25. Offline


    that raises a question ive been meaning to ask ive been using worldedit a bit , build in my build area then later plase the building, but im finding the IC's dont run, untill i access them say with simplesignedit once. Is there a scan or refresh option to scan the world for ic signs , or is copy/posting a nogo ?
  26. Offline


    how do i make it so carts move when i spawn them with a [cart] sign?? i cant get them moving. i want to spawn them on a track behind a wall and then send them out to the [station] sign.
  27. Offline


    what are the nodes....
  28. Offline


    Using bukkit 1.2.4.R-01, lifts are working only for ops, and ICs are not working at all. Haven't tried the cart blocks. This is a new world generated with 1.2.3 generator.
  29. Offline


    So... anyone got any alternatives to this plugin (Or would like to work on current issues) [I'm willing to pay quite the buck for it] - and this project seems dead/ignored/not cared for what so ever.

    Seems as though GeMoschen has lost interest, doesn't care about bukkitdev, etc. This whole thread is a mess riddles with ignored bug reports and more - and its time someone said that. Although we do thank you for all your previous work thus far GeMoschen.

    Anyways... If anyone has any alternatives let me know. (Hows craftbook working out for you guys?)
    Tanite likes this.
  30. Offline


    LOL, whats wrong with you?
    The last Falsebook update was 2 weeks ago and the new RB-Build came out a couple of hours ago.
    Do you think GeMoschen is a magician?
    There is no functional alternatives and Craftbook works like mess, because its inactive.
    Build your own plugin, then you know how difficult it is to update a plugin.
  31. Offline


    Once more bumping, since GeMoschen is still AWOL:

    - Is there a rail feature to have chest carts pick up item drops nearby yet?
    - I noticed that a deposit rail two blocks above a deposit rail doesn't work when there is also a redstone torch nearby on the lower level. If you remove the redstone torch, the upper level of deposit rails works again. Is this a fixable bug?

Share This Page