Inactive [MECH] FalseBook 0.96alpha - CraftBook for Bukkit,85++ICs, Gates, Minecarts / MC1.4.6

Discussion in 'Inactive/Unsupported Plugins' started by GeMoschen, Mar 5, 2011.

  1. Offline


    FalseBook - Your CraftBook for Bukkit

    Current version: v0.96alpha
    Minecraft: 1.4.6

    Show Spoiler

    • supported Permissionplugins
      • bPermissions
      • bukkitPermissions
      • Essentials GroupManager
      • Permissions
      • PermissionsEx
      • SuperPerms
      • Vault (still in development)
    • uses the syntax of CraftBook for better compatibility
    • implements over 85 Integrated Circuits (ICs)
    • implements [Lift Up] & [Lift Down]
    • toggleable ...
      • ... bridges
        • undestroyable
      • ... doors
        • undestroyable
      • ... gates
        • undestroyable
      • ... areas
    • a lot of fancy features for minecarts
      • collect and deposit items from chests to minecarts
      • make furnaces which refill themselfs with minecarts
      • program carts to take only specific items out of chests
      • craft things out of a chest with a minecart
      • lift up & down for minecarts!
    • chatsystem with different chat-channels to clean up the normal chat
    • toggleable...
      • netherrack (with fire)
      • pumpkins
      • glowstone <-> another block (even if minecraft itself has the glowstonelamp now...)

    Minecart Blocktypes:
    Show Spoiler

    • BenchOut : Iron-Ore
    • Booster 2x : Gold-Ore
    • Booster 8x : Gold-Block
    • Brake-Block 25% :Gravel
    • Brake-Block 50% : Soulsand
    • Burn : Iron-Ore
    • ConstantSpeed-Block : Iron-Block
    • Craft : Iron-Ore
    • Deposit / Collect : Iron-Ore
    • Eject-Block : Coal-Ore
    • Emitter-Block : Lapis Lazuli Ore
    • Reverse-Block : White wool
    • Station-Block : Obsidian
    • Sort-Block : Netherrack
    • Teleport-Block : Lime wool
    • Program-Cart : Lapis Lazuli
    • Programmed Deposit-Block : Blue wool

    Other Features:
    Show Spoiler

    • Bridge (FalseBookBlock.jar)
    • Doors (FalseBookBlock.jar)
    • Gates (FalseBookBlock.jar)
    • Toggle Netherrack Fire (FalseBookExtra.jar)
    • Toggle Pumpkins (FalseBookExtra.jar)
    • Toggle Soulsand to Glowstone and back (my addition) (FalseBookExtra.jar)
    • ToggleAble Areas (Experimental):

      Define the area with the "Wooden Hoe" (use rightclick)
    • /farea <areaname> -> Adds an Area
    • /delfarea <areaname> -> removes an Area
    • /listfarea -> Lists all Areas
    • /fareatoggle <areaname> autosave -> toggles the autosave function of an area. Autosave = save blocks, when toggling the area off.
    • /fareatoggle <areaname> protect -> toggles the protection of an area. ON = Area is only destroyable/buildable to users with permission: falsebook.destroy.blocks
    • /fareaallow <areaname> id[:subid] -> will add/remove the blocktype from the toggleable blocks of this area. Default: all blocks will be toggled.
    • (FalseBookBlock.jar)

    Important Note:
    You must copy ALL jar-Files over the old ones (all files have been changed) !
    The "Package_..."-Files must go into "plugins/FalseBook/ICPlugins/"

    Download FalseBook 0.96alpha for Minecraft 1.4.6

    FalseBook Wiki - Work in progress

    YouTube-Channel with Videos

    Donations are welcome if you wish to support me


    Attached Files:

    cevio, Artem-s86, Dereku and 67 others like this.
  2. Offline


    Im not sure if anyone else is having this issue. but from some reason Falsebook Minecart stuff is not working for me. I all the falsebook plugins stuff in my server " Excluding .chat" i have falsebook.cart.* as a perm ( using PEX ) i have even tried using all the single node's and not seeming to work.

    It let's me make the sign's like station and says i have made a station. but when i put a cart on the track and push it in the direction of the station it just rolls over the obsidian block and keeps going. i have even tried putting a cart on the obsidian area and getting in and pressing the button nothing still happen's. I have no error's in my console for any of the plugins i got. so im pretty well stumped on what im doing wrong here.
  3. Offline


    Please fix apple drop
    Jobsti likes this.
  4. Offline


    We had this problem too. Take a look here:

    We changed all the Blocks and it worked. It seams to conflict with LogBlock in some way, but don't ask me why
  5. Offline


    No idea if it's reported before or if it's only me.
    But when creating lift signs they can only go up.
    and when you hit the [Lift Up] sign it say "no lift found"
    But the one that goes down works fine.
  6. Offline


    I created a new server with the updated falsebook and I found out that [Lift] Signs dont work for nonOP players.
    I am not using permissions or LWC - I even deleted Essentials Protect. But lifts can so far only be used by ops.
    How do I change this?

    Strange thing is that nonOP players can use [Gate],[Bridge] and [Door] signs but not the lift. :eek:
  7. Offline


    I'm having a problem with [Lift] signs above a certain y axis (height). My sign on y: 124 cannot [Lift Up] to other lifts above it, and it keeps giving "No lift found.". However, when I go down from 124+ down to 124 and below, it works perfectly fine.

    Am I the only one getting this? Is this a bug?

    That's exactly what I got! (sorry for double-post)

    It won't go up above a certain height for me.

    EDIT by Moderator: merged posts, please use the edit button instead of double posting.
    Last edited by a moderator: Jul 17, 2016
  8. Offline


    Thank you for the work around. I didn't really want to resort to changing each block. ( Not that im lazy to. but that most players are used to the default setting's of Falsebook cart block's ) So i switched everything to Wool:Color's which fits nicely. Also gives Wool another use on the server.

    When trying to set a chest to collect items from a storage cart. Is there a way to have it collect multiple thing's?
    I gave it a try but failed.


    Was my attempt.
  9. Offline


    You cannot change appledropchance from 10.0 to *anything*
    On server restart it ALWAYS resets to 10.0 - Can you please fix this, our server is getting filled with apples lol!
  10. Offline


    Yeah they're out of control here too. I guess I'll unload that module after all :/
  11. Offline


    Firstly, I love this plugin. Secondly, would it be possible to change the mob spawning IC 1200 I believe to an entity spawning IC with entity ID as the 3rd line as opposed to name. Or have the option for both? This would allow for spawning tnt, giants, ender crystals and that sort of crazy stuff.

  12. Offline


    Just look here
    you can seperate the items with a "-" like: 35-5-98
  13. Offline


    Where are permissions, me can't find?! Blargh <-- Lol.

    But really, I can't find them anywhere.
  14. Offline


    I have a problem with the configuration for the apple drop chance.
    If I change the value it is overwritten with the standard value (10.0) on the next server start.
    All the other settings seem to keep ther values.

    Oh, I see andrewkm mentioned it already.
    Tanite likes this.
  15. Offline



    Long time since I last posted to you concerning the issues on our server, but those issues are now resolved for the most part. I did, however, want to mention a new other interesting anomalies that I am seeing, along with some suggestions to put on your idea table for future feature additions, should they be worthy.

    Anyways, first off, we're using the latest FB build of yours, along with the latest dev build of bukkit on our server, and I am in the midst of making a new vault system involving FB minecarts and chests.

    We've reassigned white wool as the collect block (fixing the old collect block conflict we had with another plug-in) and that's working great now, but I still can't seem to get cart dispensers working correctly. I've set a small chest over the block, and I get no "verification" message from [FB-CART] telling me that a dispenser block was created. Shoudn't I get one? I think this is the issue I'm having here, as the sign I created is "verified", and is facing the correct direction to "spawn" the minecart.

    The next issue I have is the issue of creator/editor rights with FB-CART signs/blocks/chests/etc. I am creating a place that may require the maintenance of more than myself, and I need others to be able to edit and change FB-CART signs/blocks/etc without breaking the current setup we have. The problem I've noticed is that FB-CART requires one user to create both the block, the FB sign, and any related chest(s) to get this to work. I can have LWC set public (unregistered) permissions on all objects, and it will not work simply because someone else made one or more of the other items, despite me having "edit" privileges on them. Is it possible to lift the user-specific requirements on these objects, and make sure the LWC permissions are the only criteria by which to activate them? This would make for a much smoother functional toolset especially in places where more than one player is working on FB stuff.

    Lastly, don't you have some centralized place that documents (default) FB cart constructs and on their use? I'm having a tough time finding a "wiki" on these, though you have all your ICs listed on the wiki page. Add cart stuff there too and I'll be in happy land. Thanks again!
  16. Offline


  17. Offline


    My Players are not able to usse the [lift up] / [lift down] signs because i cant find any permissions nodes for falsebook. if anybody can give me the permissions nodes. Iam useing permissionsEX Please respond ASAP
  18. Offline



    This is just what I have found, and what I had previously, hope it helps some.
  19. Offline


    Thanks Zaonhort very helpful :D
  20. Offline


    Do you have any idea why he doesn't have the permissions listed?
  21. Offline


  22. Offline


    Player detection ICs seems to be dead. Nothing happens after placing sign...
  23. Offline


    Anyone know what this is? I'm building a huge skyscraper, and my elevator not working is really hindering my progress.
  24. Offline


    Got PigZombie instead of wolves. With previous version sign worked correctly.
    FalseBook v0.93.1alpha, bukkit #2083
    Console errors (open)
    10:27:47 [SEVERE] java.lang.ClassCastException: org.bukkit.craftbukkit.entity.CraftPigZombie cannot be cast to org.bukkit.entity.Wolf
    10:27:47 [SEVERE] at com.bukkit.gemo.FalseBook.IC.ICs.worldedit.MC1200.Execute(
    10:27:47 [SEVERE] at com.bukkit.gemo.FalseBook.IC.ExecutionEvents.ICExecutionEvent.Execute(
    10:27:47 [SEVERE] at
    10:27:47 [SEVERE] at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
    10:27:47 [SEVERE] at net.minecraft.server.MinecraftServer.w(
    10:27:47 [SEVERE] at
    10:27:47 [SEVERE] at
    10:27:49 [SEVERE] java.lang.ClassCastException: org.bukkit.craftbukkit.entity.CraftPigZombie cannot be cast to org.bukkit.entity.Wolf
    10:27:49 [SEVERE] at com.bukkit.gemo.FalseBook.IC.ICs.worldedit.MC1200.Execute(
    10:27:49 [SEVERE] at com.bukkit.gemo.FalseBook.IC.ExecutionEvents.ICExecutionEvent.Execute(
    10:27:49 [SEVERE] at
    10:27:49 [SEVERE] at org.bukkit.craftbukkit.scheduler.CraftScheduler.mainThreadHeartbeat(
    10:27:49 [SEVERE] at net.minecraft.server.MinecraftServer.w(
    10:27:49 [SEVERE] at
    10:27:49 [SEVERE] at
  25. Offline


    Is there a WORKING way to disable permissions? If I try to set 'usePermissionCaching: true'
    to false (in FalseBookCore.yml), the file will reset when reloading plugins :confused:
  26. Offline


    Very nice plugin however currently I have problems with some 1210 ICs. After a while these ICs always disappear, well the signs are just gone. Not all of them but some. Is this a known problem or has anyone already experienced this? The Signs are placed on a wall to replace glas by glowstone above them at night.
  27. Offline


  28. Offline


    i'm having a problem with gates, the fence gates work fine, but when i try to use glass panes or iron bars it says no gate found.
  29. Offline


  30. Offline


    Sorters aren't working for me, they are created but something is wrong with the criteria parameter "ctns:id"

    where i can find them? and it is possible to specific negative ones? like: not mob
  31. Offline


    Permissions aren't working. I'm using PermissionsBukkit. Does FalseBook just not work with SuperPerms?

Share This Page